Jump to content

Kernel packages - Nvidia - Logitech Quickcam


Recommended Posts

First of all, I'm running Mandriva 2009.1. Currently I have this kernel -

uname -a
Linux Duelie #1 SMP Sun Jul 5 19:32:00 EDT 2009 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ GNU/Linux


With this kernel my Nvidia hardware is working, but I can not get the Logitech Quickcam to work. Form harddrake, here is the hardware.


GeForce 6150SE nForce 430

and the module supporting it -

Module: ‎Card:NVIDIA GeForce 6100 and later


The Quickcam.

Bus 002 Device 003: ID 046d:0870 Logitech, Inc. QuickCam Express



Some history. I have had this webcam working with 2008.1. I did a clean install of 2009.1 several months ago. I am now trying to get the webcam working. Last time it worked, it was a struggle. Here is the thread that describes what was done.




From this thread, and the last posts, it appears I need

. This means I can not use the 586 kernel I'm now using. ( I think ).


I installed this kernel

. I can not figure out what nvidia package matches this one, and what I need installed to get the webcam working. I believe I need to 'modprobe mod_quickcam' to support the webcam. I have looked in MCC --> Install software. I find the names in there very confusing.


Right now I have cheese installed. I can see the webcam with lsmod, and /dev/video0 is there. I see coloured confettie on cheese.


Could someone who understands the naming of the kernel packages please give me some direction?


For completeness, here is the output of lsmod.


Module                  Size  Used by
tun                    10912  0      
af_packet              17468  0      
nfsd                  218284  13     
lockd                  66476  1 nfsd 
nfs_acl                 2876  1 nfsd 
auth_rpcgss            35456  1 nfsd 
sunrpc                183040  12 nfsd,lockd,nfs_acl,auth_rpcgss
exportfs                4220  1 nfsd                           
ipv6                  269264  24                               
snd_hda_codec_realtek   194272  1                              
snd_hda_intel          25064  8                                
snd_hda_codec          68828  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6880  1 snd_hda_codec                      
snd_seq_dummy           2464  0                                    
pcspkr                  2268  0                                    
forcedeth              54028  0                                    
snd_seq_oss            29536  0                                    
snd_seq_midi_event      6812  1 snd_seq_oss                        
snd_seq                48976  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          6728  3 snd_seq_dummy,snd_seq_oss,snd_seq           
snd_pcm_oss            37632  0                                             
snd_pcm                74432  5 snd_hda_intel,snd_hda_codec,snd_pcm_oss     
snd_timer              20900  4 snd_seq,snd_pcm                             
snd_mixer_oss          14460  1 snd_pcm_oss                                 
snd                    56516  23 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss                                                               
sg                     28240  0                                                                                      
sr_mod                 14788  0                                                                                      
soundcore               6976  1 snd                                                                                  
snd_page_alloc          8708  2 snd_hda_intel,snd_pcm                                                                
i2c_nforce2             7520  0                                                                                      
nvidia               7227868  36                                                                                     
agpgart                33992  1 nvidia                                                                               
i2c_core               30992  2 i2c_nforce2,nvidia                                                                   
binfmt_misc             8036  1                                                                                      
gspca_stv06xx          30852  0                                                                                      
gspca_main             22108  1 gspca_stv06xx                                                                        
videodev               40352  1 gspca_main                                                                           
v4l1_compat            13440  1 videodev                                                                             
usblp                  11804  0                                                                                      
cpufreq_ondemand        6728  1                                                                                      
cpufreq_conservative     6052  0                                                                                     
cpufreq_powersave       1308  0                                                                                      
powernow_k8            13312  1                                                                                      
freq_table              4380  2 cpufreq_ondemand,powernow_k8                                                         
ppdev                   7232  0                                                                                      
rtc_cmos               12044  0                                                                                      
floppy                 53508  0                                                                                      
parport_pc             35940  0                                                                                      
parport                33900  2 ppdev,parport_pc                                                                     
thermal                15192  0                                                                                      
ohci_hcd               32396  0                                                                                      
button                  5836  0                                                                                      
processor              39944  2 powernow_k8,thermal                                                                  
k8temp                  4188  0                                                                                      
evdev                   9376  7                                                                                      
ehci_hcd               48488  0                                                                                      
usbcore               179408  6 gspca_stv06xx,gspca_main,usblp,ohci_hcd,ehci_hcd                                     
ide_generic             2336  0 [permanent]                                                                          
pata_amd               10656  0                                                                                      
ata_generic             4576  0                                                                                      
ide_pci_generic         3744  0                                                                                      
ide_gd_mod             23328  0                                                                                      
ide_core              106988  3 ide_generic,ide_pci_generic,ide_gd_mod
pata_acpi               3868  0
sata_nv                22276  3
libata                172780  4 pata_amd,ata_generic,pata_acpi,sata_nv
sd_mod                 33944  4
scsi_mod              150964  4 sg,sr_mod,libata,sd_mod
crc_t10dif              1628  1 sd_mod
ext3                  125732  2
jbd                    46736  1 ext3

Link to comment
Share on other sites

Try running the software (skype, cheese, whatever you want to use) from the command line using one of these two commands:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype

I found them on the Ubuntu forum. Modify the path if necessary.

Link to comment
Share on other sites

[i tried both. Each one alters the appearance of the coloured confetti I see, but neither makes a use-able image with my old webcam.


For anyone else reading this thread, and looking for information on the gspca driver, have a look here --> http://www.linuxjour...m-working-gspca


And for compatibility with web cams -->http://mxhaard.free.fr/spca5xx.html


In my case, my webcam is not listed as supported, although there are a lot of Logitech cams there, just not the one I own.


From this site -->http://www.quickcamteam.net/devices/non-uvc-webcams


The driver that works is listed as

0870 ST602 Logitech QuickCam Express

Logitech QuickCam for Notebooks

Labtec WebCam qc-usb

The formatting, first column is the device, second column is the cam name, and the third is the driver, 'qc-usb' Edited by camorri
Link to comment
Share on other sites

I have had a try at installing qc-usb-messenger-kernel-desktop-latest. If I select that package, I get an unsatisfied dependency of qc-usb-messenger-kernel- I don't have that kernel installed at all. I can not list it through Install/Remove software.


There has to be something hosed up in my system, or the files are really not there. Can anyone shed some light on this???


and a urpmq...


urpmq qc-usb-messenger-kernel-

No package named qc-usb-messenger-kernel-

Edited by camorri
Link to comment
Share on other sites

An update. I have a ThinkPad running PCLinuxOS 2009.1. I installed the kdms-qc-usb package on that system. The package installed, and then compiled the driver quickcam.ko. I took my Logitech Quickcam, plugged it in, installed Panorama, and viola, it works.


That system is running a different kernel, and a slightly older version of GCC. However, it all works. So, now I know there is a problem with Mandriva 2009.1 compiling the driver I need.


Is there some place to report this and find some help???

Edited by camorri
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...