Jump to content
jameswong

Access FAT32 partitions [solved]

Recommended Posts

Hi all,

 

My harddisk is set up for dual boot between windows 2000. The harddisk contains 1 partition for NTFS,2 partitions for exts and 4 partitions of FAT32.

 

After I installed Mandriva 2009 Spring, the 4 FAT partitions do not get mount during installation and therefore I cannot see them under "Dolphin". The NTFS partition is OK.

 

I have an external USB harddisk which can also FAT32 and it got mount automatically.

 

Can someone provide me with some guidelines of how to further proceed.

 

Thanks

Share this post


Link to post
Share on other sites
Please open a terminal and post the output of
cat /etc/fstab

and (as root)

fdisk -l

[root@localhost arthur]# fdisk -l

 

Disk /dev/sda: 251.0 GB, 251000193024 bytes

255 heads, 63 sectors/track, 30515 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x0fe70fe7

 

Device Boot Start End Blocks Id System

/dev/sda1 * 1 3002 24113533+ 7 HPFS/NTFS

/dev/sda2 3003 30515 220998172+ f W95 Ext'd (LBA)

/dev/sda5 3003 3766 6136798+ 83 Linux

/dev/sda6 7300 7346 377496 83 Linux

/dev/sda7 7358 14717 59119168+ b W95 FAT32

/dev/sda8 14718 22032 58757706 b W95 FAT32

/dev/sda9 22033 30515 68139666 b W95 FAT32

/dev/sda10 7347 7357 88326 82 Linux swap / Solaris

/dev/sda11 3767 3906 1124518+ 82 Linux swap / Solaris

/dev/sda12 3907 7299 27254241 83 Linux

 

Partition table entries are not in disk order

 

Disk /dev/sdb: 1002 MB, 1002438656 bytes

65 heads, 32 sectors/track, 941 cylinders

Units = cylinders of 2080 * 512 = 1064960 bytes

Disk identifier: 0xc3072e18

 

Device Boot Start End Blocks Id System

/dev/sdb1 * 1 942 978928 6 FAT16

Partition 1 has different physical/logical endings:

phys=(956, 64, 32) logical=(941, 18, 32)

 

Disk /dev/sdd: 80.0 GB, 80026362368 bytes

255 heads, 63 sectors/track, 9729 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x9eebbabf

 

Device Boot Start End Blocks Id System

/dev/sdd1 * 1 9729 78148161 b W95 FAT32

[root@localhost arthur]#

 

[root@localhost arthur]# fdisk -l

 

Disk /dev/sda: 251.0 GB, 251000193024 bytes

255 heads, 63 sectors/track, 30515 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x0fe70fe7

 

Device Boot Start End Blocks Id System

/dev/sda1 * 1 3002 24113533+ 7 HPFS/NTFS

/dev/sda2 3003 30515 220998172+ f W95 Ext'd (LBA)

/dev/sda5 3003 3766 6136798+ 83 Linux

/dev/sda6 7300 7346 377496 83 Linux

/dev/sda7 7358 14717 59119168+ b W95 FAT32

/dev/sda8 14718 22032 58757706 b W95 FAT32

/dev/sda9 22033 30515 68139666 b W95 FAT32

/dev/sda10 7347 7357 88326 82 Linux swap / Solaris

/dev/sda11 3767 3906 1124518+ 82 Linux swap / Solaris

/dev/sda12 3907 7299 27254241 83 Linux

 

Partition table entries are not in disk order

 

Disk /dev/sdb: 1002 MB, 1002438656 bytes

65 heads, 32 sectors/track, 941 cylinders

Units = cylinders of 2080 * 512 = 1064960 bytes

Disk identifier: 0xc3072e18

 

Device Boot Start End Blocks Id System

/dev/sdb1 * 1 942 978928 6 FAT16

Partition 1 has different physical/logical endings:

phys=(956, 64, 32) logical=(941, 18, 32)

 

Disk /dev/sdd: 80.0 GB, 80026362368 bytes

255 heads, 63 sectors/track, 9729 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x9eebbabf

 

Device Boot Start End Blocks Id System

/dev/sdd1 * 1 9729 78148161 b W95 FAT32

[root@localhost arthur]#

Share this post


Link to post
Share on other sites

You also need to post your /etc/fstab file. You can either open the file and copy and paste it here or run the cat /etc/fstab command in the terminal and post the output here.

 

The fstab file is what controls mounting. You probably just need to edit these entries to get your FAT32 partitions to auto mount at boot:

 

/dev/sda7 7358 14717 59119168+ b W95 FAT32

/dev/sda8 14718 22032 58757706 b W95 FAT32

/dev/sda9 22033 30515 68139666 b W95 FAT32

 

and:

 

/dev/sdd1 * 1 9729 78148161 b W95 FAT32

 

Mandriva usually sets up in entries in fstab for FAT32 partitions but they are generally set to not auto mount. It's an easy thing to change.

Edited by pmpatrick

Share this post


Link to post
Share on other sites

[arthur@localhost etc]$ more fstab

# Entry for /dev/sda5 :

UUID=f8d97912-6435-11de-bfcd-2b9329108ba0 / ext3 relatime 1 1

# Entry for /dev/sda12 :

UUID=01d3e2e0-53fd-42d0-b786-96f0c488f1f1 /home ext3 relatime 1 2

# Entry for /dev/sda6 :

UUID=e5143227-d5f8-46e8-87fe-6d5ff20a3c2f /home1 ext3 relatime 1 2

/dev/cdrom /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0

/dev/fd0 /media/floppy auto umask=0,users,iocharset=utf8,noauto,exec,flush 0 0

# Entry for /dev/sda1 :

UUID=01C6A4C7DBC66FA0 /mnt/windows ntfs-3g defaults 0 0

none /proc proc defaults 0 0

# Entry for /dev/sda10 :

UUID=c8cc7479-0436-45d4-a70d-7cc17cca35a0 swap swap defaults 0 0

# Entry for /dev/sda11 :

UUID=135c1f17-1e9a-4445-b831-f371be917360 swap swap defaults 0 0

[arthur@localhost etc]$

Share this post


Link to post
Share on other sites

You don't have any fstab entries for the FAT32 partitions. You may add them by hand.

 

dev/sda7 /mnt/fat1 vfat iocharset=utf8,defaults 0 0

 

...and so on for the rest. Just get sure the mount points do exist.

 

You may also remove the /dev/fd0 line, if you don't happen to have a floppy.

And... why two swap partitions?

Edited by scarecrow

Share this post


Link to post
Share on other sites

Thanks to Greg 2, Pmpatrick and Scarecrow for providing me the invaluable guidance to move forward.

 

One point that I am not able to grasp is the structure within the fstab file. The following is from the original fatab:

 

# Entry for /dev/sda5 :

UUID=f8d97912-6435-11de-bfcd-2b9329108ba0 / ext3 relatime 1 1

 

This one as suggested by scarecrow:

dev/sda7 /mnt/fat1 vfat iocharset=utf8,defaults 0 0

 

Do they mean the same thing?

 

As far as the 2 swap files are concerned I suspect one might have one from the previous version, which are are being removed during installation.

 

Thanks

Share this post


Link to post
Share on other sites

That should be /dev/sda7 not dev/sda7. I would suggest you use this example for you FAT32 partitions:

 

/dev/sda7 <mount point> vfat umask=000,iocharset=utf8 0 0

 

You can choose whatever directory you want for a mount point. Traditionally, most people put mount points in the /mnt or /media directory, thus the suggestion that you make your mount points in the form /mnt/fat*. The addition of "umask=000" in the above line will ensure that you have read/write access to all your FAT32 partitions, which is what most people want. Without the umask option, a mounted FAT32 partition defaults to read only.

 

Re your question about the difference in form for your root partition and what's been suggested for your FAT32 partitions, that's because mandriva and most other distros set up fstab using UUID instead of device files. Device files for partitions are typically in the form of /dev/sd** or /dev/hd**. UUID(universal unique identifier) is an alternative way of uniquely identifying a partition using a lengthy 128 bit number. You can use either method with fstab but it's just easier to use device files.

 

As far as your two swap files go, you can have as many as you want; it won't hurt a thing. Almost all distros, including mandriva, will detect the existence of swap partitions during the installation and automatically set up mount points to use any and all existing swap partitions.

Share this post


Link to post
Share on other sites

# Entry for /dev/sda5 :
UUID=f8d97912-6435-11de-bfcd-2b9329108ba0 / ext3 relatime 1 1
# Entry for /dev/sda12 :
UUID=01d3e2e0-53fd-42d0-b786-96f0c488f1f1 /home ext3 relatime 1 2
# Entry for /dev/sda6 :
UUID=e5143227-d5f8-46e8-87fe-6d5ff20a3c2f /home1 ext3 relatime 1 2
/dev/cdrom /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/fd0 /media/floppy auto umask=0,users,iocharset=utf8,noauto,exec,flush 0 0
# Entry for /dev/sda1 :
UUID=01C6A4C7DBC66FA0 /mnt/windows ntfs-3g defaults 0 0
none /proc proc defaults 0 0
# Entry for /dev/sda10 :
UUID=c8cc7479-0436-45d4-a70d-7cc17cca35a0 swap swap defaults 0 0
# Entry for /dev/sda11 :
UUID=135c1f17-1e9a-4445-b831-f371be917360 swap swap defaults 0 0

/dev/sda7 <mount point 1> vfat umask=000,iocharset=utf8 0 0
/dev/sda8 <mount point 2> vfat umask=000,iocharset=utf8 0 0
/dev/sda9 <mount point 3> vfat umask=000,iocharset=utf8 0 0
/dev/sdb1 <mount point 4> vfat umask=000,iocharset=utf8 0 0
/dev/sdd1 <mount point 5> vfat umask=000,iocharset=utf8 0 0

 

Paste the above in a file named "fstab". Replace <mount point n> with an actual, existing mount point at your system, and then replace your /etc/fstab with that one (as root).

Note that the above does not take care of the issue of two swap drives, and to be honest I don't understand the reason to use FAT32 partitions anywhere- excluding pen drives. They could, and should be substituted by NTFS.

Edited by scarecrow

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...