Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
payasam

No audio, no video [a new problem]

Recommended Posts

I have just moved from a Pentium III machine to a Pentium IV one. MDV 2009.1 correctly recognises Intel 82801DB audio, but there is no sound from the speakers. When playing a music file, VLC's progress indicator moves -- but there is silence. When attempting to play a video file, VLC and MPlayer both show the screen just for a second before it disappears. The speakers are getting current and fiddling with the plug makes them crackle. Video not playing makes me think it cannot be a hardware problem.

Edited by payasam

Share this post


Link to post
Share on other sites

Check whether sound is not muted, through KMix for example.

Share this post


Link to post
Share on other sites

Thank you. Right clicked on speaker icon. Sound not muted there. However, I do not see why muted sound should prevent video from playing.

Share this post


Link to post
Share on other sites

Do you have the appropriate codecs installed for playing the audio and/or video files?

Share this post


Link to post
Share on other sites

Yes, arctic. All was well on the older machine, same installation on same HDD. I should say that I get no start-up sound either.

Share this post


Link to post
Share on other sites

Some computers, especially laptops have a hardware mute button. Make sure yours isn't muted.

 

Check your volume control settings, there are several. Star > Sound & Video > PulseAudio Volume Control. Star > Sound & Video > KMix Sound Mixer (or applet on taskbar). Configure Desktop > Multimedia.

 

Maybe disable pulse audio for a check. You can do this from MCC > Hardware > Sound Configuration.

 

Try some headphones to check sound output there.

 

http://wiki.mandriva.com/en/2009.1_Errata#..._Dimension_4550

Share this post


Link to post
Share on other sites

Not a laptop, David, and no hardware mute control. I've disabled Pulse without effect. Must scour the system now for other volume and mute controls that may have got activated by themselves. Have an earphone somewhere but can't find the damn thing.

Share this post


Link to post
Share on other sites

Some time ago, there was a kernel problem with the audio driver in some distros. See e.g. here: https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller

http://www.nabble.com/-Bug-49814--pulseaud...2991694i20.html

and here: https://bugs.launchpad.net/ubuntu/+source/l....22/+bug/131133

 

Maybe you ran into a persisting bug.

Share this post


Link to post
Share on other sites
When attempting to play a video file, VLC and MPlayer both show the screen just for a second before it disappears.
Try running mplayer from the command line, and see if it prints out an error message. That will probably help narrow down what its problem is. Also try with different videos, for example ones that you've made yourself. Or try to play a wav or ogg with mplayer, see what it says.

Share this post


Link to post
Share on other sites

Shut down every app that may use your soundcard (including gnome mixer on the tray- you are running Gnome, or not?), and in a root console run

alsaconf

You have three chances: 1. seeing your PC internal speaker as default sound device 2. your actual soundcard listed and 3.a prompt to search for ISA soundcards, as none was detected.

On which case of the above you are belonging?

Share this post


Link to post
Share on other sites
Some time ago, there was a kernel problem with the audio driver in some distros. See e.g. here: https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller

http://www.nabble.com/-Bug-49814--pulseaud...2991694i20.html

and here: https://bugs.launchpad.net/ubuntu/+source/l....22/+bug/131133

 

Maybe you ran into a persisting bug.

we have to check that because my notebook used to do that before I install the video codecs (it just happened in the video, sound worked fine) make sure your video card have the appropiate driver...have you test it? also make sure the audio drivers are fine using the troubleshooting options...

 

 

that's what I did

Share this post


Link to post
Share on other sites

Thank you, all. Yes, scarecrow, it's Gnome. I say again, in MCC the sound card is correctly recognised.

 

[EDIT] Running alsaconf is no good: I get a "command not found" message.

Edited by payasam

Share this post


Link to post
Share on other sites

Thank you, David. That was the obvious thing to do, so I did it. No luck.

Share this post


Link to post
Share on other sites
Running alsaconf is no good: I get a "command not found" message.

It's a separate package, named "alsaconf" which is installed by default. You should also have alsa-utils and alsaq-plugins-pulse-config installed by default.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×