Jump to content
Sign in to follow this  
neddie

Thinkpad won't wake up

Recommended Posts

I'm trying out 2009.0 live on a borrowed Thinkpad T41p, and it seemed to be working fine. I wanted to try out Skyping with two-way video to see if it's just my laptop which can't do it or if it's a general problem. So I got as far as installing Skype, disabling pulseaudio, testing the webcam, and making the test call, but then I left it alone for a few minutes and it went to sleep.

 

I've tried the Function - F4 (with the moon symbol), I've tried Ctrl-Alt-F1 to F7, I've tried Ctrl-Alt-Backspace and Escape and Fn and Ctrl-Escape and everything else I can think of, even shutting the lid and opening, pulling the power out and back in, tapping (but not holding) the power button. It reacts, making a noise when I unplug the power and adjusting the screen backlight for the function keys for brightness, but I can't get it to wake up. Any clues? Or is the only option forcing a reboot with the power button?

 

Assuming I do have to reboot it, is there a way to stop it going into this sleep mode if I know it won't be able to wake up again?

 

 

[moved from Hardware by spinynorman]

Share this post


Link to post
Share on other sites

Have you installed the configure-thinkpad package from the repos? It has settings for hibernate, standby, and suspend.

Share this post


Link to post
Share on other sites

Suspend and hibernation is done using three different methods: the kernel pm_suspend and pm_hibernate (least reliable, but also simplest- if it's working then there's no need to look further), uswsusp (useprspace utils, probably needs rebuilding the ramdisk) and tuxonice (most sophisticated, but it needs a kernel rebuild).

Do you know which method is used for suspending?

On my current laptop pm_suspend works perfectly right out of the box, while on the older one I had to use tuxonice (...and none of them was a Thinkpad).

Share this post


Link to post
Share on other sites

I would suggest to check the acpi scripts. For me, Mandriva 2008.0 installed a very basic collection of acpi scripts. Suspend-to-RAM, turning on and off the display, brightness controls and switching the external display on and off did not work. I cannot remember the details, but I fixed these problems using the information I found on thinkwiki. Maybe, installing configure-thinkpad would do the job, I did not try that package. I use pm_suspend scripts.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...