Jump to content

Frostwire won't start with the latest Java version

Recommended Posts

Guest ZekeMx
Has anyone got Frostwire to work on 2009.1 ? If so, how? What am I missing?



I've been able to install Frostwire many times.


At first it seems not to be compatible with java-1.6.0-sun but it actually is.


The problem is very strange, probably a path problem, and I had exactly the same problem with many mandriva installed Pcs.


I first removed java-1.6.0-sun because I suspected Frostwires was not compatible, if you already have java-1.6.0-openjdk, check if you have java-1.6.0-openjdk-plugin since this seems to create or install something that will make Frostwire work.. (I Know, I know, you don't believe me). But onces I installed java-1.6.0-openjdk-plugin then Frostwire started working. Like I said, it seems something is triggered or changed in the paths here.


BUT, after all this. If you remove java-1.6.0-openjdk & java-1.6.0-openjdk-plugin and install java-1.6.0-sun and all it's dependencies, frostwire continues to work.


Once I run Fronstwire from console this is what I get.


HOSTNAME IS localhost
Starting FrostWire...
Java exec found in PATH. Verifying...
Suitable java version found [java = 1.6.0_13]
Configuring environment...
Loading FrostWire:
CLASSPATH SET TO: :./jl.jar:./icu4j.jar:./log4j.jar:./jdic_stub.jar:./ProgressTabs.jar:./mp3spi.jar:./jaudiotagger.jar:./aopalliance.jar:./jogg.jar:./guice-1.0.jar:./jdic.jar:./vorbisspi.jar:./gettext-commons.jar:./onion-common.jar:./foxtrot.jar:./jorbis.jar:./httpcore-4.0-beta2.jar:./httpcore-nio-4.0-beta2.jar:./httpclient-4.0-alpha3.jar:./daap.jar:./junit.jar:./FrostWire.jar:./jflac.jar:./forms.jar:./commons-codec-1.3.jar:./onion-fec.jar:./themes.jar:./jython.jar:./lw-all.jar:./httpcore-niossl-4.0-alpha7.jar:./tritonus.jar:./clink.jar:./commons-logging.jar:./messages.jar:./looks.jar:./jmdns.jar:./jcraft.jar
****STARTUP DEBUG: Is this a supported windows or Mac? false
**OverlayAd.image() - OVERLAY AD, im going to load:file:///home/sergio/.frostwire4.18/overlays/frostclick_default_overlay.jpg
UpdateManager.scheduleUpdateCheckTask() - TimerTask.run()
UpdateManager.checkForUpdates() - Invoked
Trying to start chat panel...
initializing chat community...
Creating new IRC App...
Initializing new IRC App...
UpdateMessageReader.startElement overlay intro=true
UpdateMessageReader.endElement() - addOverlay
UpdateMessageReader.endElement() - addOverlay
UpdateMessageReader.startElement overlay intro=true
UpdateMessageReader.endElement() - addOverlay
UpdateMessageReader.endElement() - addOverlay
UpdateMessageReader.startElement overlay intro=true
UpdateManager.isMessageForMe() - Message was null
UpdateManager.checkForUpdates() - We have overlays to update.
UpdateManager.updateOverlays() invoked.
Smileys should be ACTIVE!
Initialized! new IRC App...
getting nick: Chat enabled?: true
Removing previous banners...
Getting banners from server...
Loading banners...
User-Agent: FrostWire/Linux/4.18.0




This are the steps that have worked for me to run Frostwire.


Remove Java






Run frostwire in console to see if it works.



If it didn't: Gob bless you my brother. In the name of the Father, the Son & the Holy Spirit. :P


In my case I wanted to have the Java from sun, so I removed: java-1.6.0-openjdk


And installed:










Link to comment
Share on other sites

Well after you posted here....I installed it here and was having the same problems you have but I did something I might regret later but solve my problem

I ran frostwire as root in the first time (I know is risky, and opens a big problem, that's why I said that I might regret later) then close it and open it as normal user and it worked...have you tried?

Link to comment
Share on other sites

Guest ZekeMx

Yes I did tried it before and it worked by runing it as root, the it worked fine as normal user.


But the last time I installed it, that was the most troubling, but I did remembered that the first times I had java-1.6.0-openjdk installed. I don't remember if I had java-1.6.0-opendjk-plugins.


It was until the last time that I had a lot of problems.. I lost half of my day researching on what could be the problem. That's when I did some test in 2 PCs with Mandriva and "prove" that after installing java-1.6.0-opendjk-plugins Frostwire worked fine.


I'll try it again this weekend on virtual machines.. hehe... This is just very strange.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...