Jump to content
AussieJohn

KDE4-Kmail [solved]

Recommended Posts

I have now setup Mandriva2009-Spring, with KDE4, as my main OS. I have most things working reasonably well. ( I have have kept my 2008-Spring fully functional on a smaller HDD as a backup OS)

I have been able to copy over all my received and sent mail from 2008-Spring and also my settings.

However despite all this, all new incoming mail is going into the Wastebin instead of the inbox to which is directed in the settings (I rechecked the settings so the problem is not from there). Fortunately I had not setup auto clearing of the wastebin upon closing Kmail.

 

Has any one else countered this or have a suggestion of how this might be overcome ???.

 

Cheers. John.

Edited by AussieJohn

Share this post


Link to post
Share on other sites
Guest yaayaa

It is probably the default filter (spam/antivirus).

Try to reconfigure them and watch the message. It should tell you you don't have the required progs (clamav, spamd, etc..).

Install the missing progs through urpmi.

 

I had the same problem and this solved my issue.

 

Regards,

 

Yaayaa

Share this post


Link to post
Share on other sites

Thanks Lexicon. I have always been aware of that one so that is not the problem, thanks for mentioning it though for other new members who may not understand that point.

 

Thanks YaaYaa. I just checked the Spam and Antivirus settings as you suggested and just noticed three of the tick boxes were not checked in the Antivirus (Which I usually do but must have missed this time) and it did indeed point to the wastebin. I have now ticked the boxes and will respond again when I next get some incoming emails.

 

I presume the following:-

Without the boxes ticked I think there was no checking of the emails and for safety sake and security, everything is shunted to the waste bin as a precautionary measure, where as if the emails are examined by the AntiVirus program then if the is no problem found, the mail is passed to the inbox as instructed. I will let you and everyone know if this proves to be the case because it will be handy for everyone to know for the future.

 

Cheers. John.

Share this post


Link to post
Share on other sites

A follow up.

I have downloaded emails three times so far, and they all keep getting dumped into Wastebin and none are labelled as Spam even though some obviously are. I keep checking the AntiVirus wizard and as you can see in the snapshot that the three boxes are ticked but if I open the wizard immediately after again, I find that the three boxes are unticked again. In other words it is not saving the settings.

The snapshot enclosed is virtually identical to the one in my 2008-Spring.

It appears that either or both of the anti-spam and anti-virus are not working properly.

 

Cheers. John.

Share this post


Link to post
Share on other sites

Could it be that the default setting for the wizard(s) is unselected John? I have just installed SpamAssasin and run the wizard. As you say the check boxes are unchecked even after checking them. However I checked .kde4/share/config/kmailrc and my selection was saved in the file. You could check your preferences are in that file. Why ALL your messages are being sent to the wastebin I don't know as mine never has. I haven't installed anitvirus to try that as I have never felt the need to. I may be tempting fate.

Share this post


Link to post
Share on other sites

Still no luck despite uninstalling Kmail, Spamassassin, and Clam and also deleting everything that "Find File" showed was a Kmail folder or email folder anywhere in the system, I found that upon reinstalling Kmail that all settings for kmail were already in place.

 

In other words, all the settings have been kept some where else in the system but I haven't been able to find it to delete it. I have a suspicion that there is something in those settings that is causing this problem. I cannot get a totally clean install of Kmail to check this theory.

 

Does anyone know where that file may be ???.

 

Cheers. John.

Share this post


Link to post
Share on other sites

Whatever John, i remember similar issue happened to my wifes' KMail.

Me myself i use Thunderbird, but my wife uses KMail for many years already.

Her posts arrived also into the Wastebasket, but we sorted it out somehow.

I have to dig into my memory to find out, for i didn't documentate.

There is a workaround, i am sure.

Let you know, whenever i get the right brainwave.

 

Meanwhile, maybe an idea to pop-up your question into the KDE-forum?

Edited by spinynorman

Share this post


Link to post
Share on other sites

Thanks isadora, I hope you do eventually remember how you solved the problem so I can hopefully make some headway too.

 

Cheers. John.

Share this post


Link to post
Share on other sites
In other words, all the settings have been kept some where else in the system but I haven't been able to find it to delete it. I have a suspicion that there is something in those settings that is causing this problem. I cannot get a totally clean install of Kmail to check this theory.

 

Does anyone know where that file may be ???.

 

Cheers. John.

 

Create a new account. All settings are in the Create a new account. All settings are in the directory example:

/home/lex/.kde4/share/apps/kmail

/home/lex/.kde4/share/config/kmailrc

 

Today a new version kmail4.2.3-0.5mdv2009.1 Reason?

 

* Tue May 19 2009 Nicolas Lécureuil <neoclust@mandriva.org> 2:4.2.3-0.5 mdv2009.1

+ Revision: 376799

- Fix requries

- [bugfix] Add some Requires (Bug # 50943)

- Fix obsoletes against old kdepim

- Add some suggests for default contact

- Fix usage mkrel

- New upstream tarball

- Update to KDE 4.2.3

Share this post


Link to post
Share on other sites
Thanks isadora, I hope you do eventually remember how you solved the problem so I can hopefully make some headway too.

 

Cheers. John.

Remember that i saw the inbox not before creating the mailaccount.

And there were some issues with the Spamassassin-settings.

Maybe run that Wizard one more time?

And also check the properties of your Inbox.

 

Excuses for not having detailed information present right now John.

 

Btw, do you have any Filters set up? See under the "Message" menu and disable any such filter.

Edited by isadora

Share this post


Link to post
Share on other sites

Thanks Lexicon. I too thought that all user settings were in the places you suggested, but when I deleted those Kmail folders entirely and logged out and back in again I found that kmail was still setup and ready to use. So deleting both kmail and kmailrc in /home/john/.kde4/share/apps/ made no difference and I deleted /home/john/.kde/share/apps/kmail as well just to be sure.

 

I just checked and that Kmail update does not seem to be in the update list yet. I will follow up on that one.

 

I really want to find out where that user setup data is hidden away because other than a fresh OS install, which I do not want to do and will not do, there seems no way to make a clean install of Kmail.

 

Thanks Isadora, I am going through all the filters and stuff to see if changing anything fixes the problem.

The Inbox settings are not the problem as shown by result being the same no matter how many time I delete the ....../home/john/.kde4/share/apps/ kmail ...........Folder and are the same as I use in 2008-Spring.

 

Cheers. John.

Share this post


Link to post
Share on other sites
Thanks Lexicon. I too thought that all user settings were in the places you suggested, but when I deleted those Kmail folders entirely and logged out and back in again I found that kmail was still setup and ready to use. So deleting both kmail and kmailrc in /home/john/.kde4/share/apps/ made no difference and I deleted /home/john/.kde/share/apps/kmail as well just to be sure.

 

I just checked and that Kmail update does not seem to be in the update list yet. I will follow up on that one.

 

I really want to find out where that user setup data is hidden away because other than a fresh OS install, which I do not want to do and will not do, there seems no way to make a clean install of Kmail.

 

Thanks Isadora, I am going through all the filters and stuff to see if changing anything fixes the problem.

The Inbox settings are not the problem as shown by result being the same no matter how many time I delete the ....../home/john/.kde4/share/apps/ kmail ...........Folder and are the same as I use in 2008-Spring.

 

Cheers. John.

It's in that filtering, i think. Just disable any. ;)

Share this post


Link to post
Share on other sites

Hi Isadora.

 

I carefully compared the settings for filters in 2008-Spring and found a lot of repeat filter listings in the 2009-Spring so I deleted all that weren't the same as 2008. This improved things a little bit in that if I click on an email and labelled it as spam then it immediately went to the wastebin. It didn't do that before but it is still not tagged as spam. All new incoming mail is going straight to the wastebin and I have to keep moving the stuff I want to the Inbox.

One other problem I have found is that although I keep setting the Local Folder for a Totals Column, it is not saving that instruction. Man this kmail version is really screwed up.

I still need to find where the user settings data is stored apart from in kmail.

 

Cheers. John.

Edited by AussieJohn

Share this post


Link to post
Share on other sites
Hi Isadora.

 

I carefully compared the settings for filters in 2008-Spring and found a lot of repeat filter listings in the 2009-Spring so I deleted all that weren't the same as 2008. This improved things a little bit in that if I click on an email and labelled it as spam then it immediately went to the wastebin. It didn't do that before but it is still not tagged as spam. All new incoming mail is going straight to the wastebin and I have to keep moving the stuff I want to the Inbox.

One other problem I have found is that although I keep setting the Local Folder for a Totals Column, it is not saving that instruction. Man this kmail version is really screwed up.

I still need to find where the user settings data is stored apart from in kmail.

 

Cheers. John.

 

 

John,

 

Probably this filter did the trick on my wifes' KMail:

 

1242989265-490.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...