Jump to content
neddie

Firefox looks awful under KDE3 [solved]

Recommended Posts

2009 Spring again, using KDE3, and Firefox looks awful - really clunky toolbars and buttons. Under gnome it looks fiine. Is there a way I can configure the gtk stuff under KDE3?

Previously I used gtk-qt-engine but that doesn't seem to work any more...

Edited by neddie

Share this post


Link to post
Share on other sites

Create a new account and see what is the difference?

 

bash-3.2$ rpm -qa | grep firefox

firefox-3.0.10-0.1mdv2009.1

firefox-pl-3.0.10-0.1mdv2009.1

Share this post


Link to post
Share on other sites
2009 Spring again, using KDE3, and Firefox looks awful - really clunky toolbars and buttons. Under gnome it looks fiine. Is there a way I can configure the gtk stuff under KDE3?

Previously I used gtk-qt-engine but that doesn't seem to work any more...

 

It must be something specific to your setup as Firefox looks just fine on my 2009.1/KDE3.5 install.

 

As lexicon said, try it with a brand new user to see whether it's related to some user setting.

Edited by tux99

Share this post


Link to post
Share on other sites

Well, I tried it with a new user and got a whole load of other problems (video-related, flashing screen, various strangeness) but indeed you're both right, Firefox looks fine.

 

So I tried "find .kde -name "*gtk*"" from my user and deleted those three files, now it looks fine again! Thanks both! :thumbs:

Share this post


Link to post
Share on other sites

On a similar note, does anyone know how to stop Firefox (3.0.10) making annoying "brring brring" noises whenever you download something?

Share this post


Link to post
Share on other sites

Update: seems to be some kind of system notification, as it makes these noises when I upload files too. And if I listen carefully, Firefox also makes a very quiet noise on minimize, and so do Thunderbird and Gimp.

KDE system notifications are disabled, and KDE apps like Kate, Konqueror, digikam etc all respect that and don't make noises.

 

Is this some kind of gnome or gtk configuration that I need to edit to switch these notifications off?

Share this post


Link to post
Share on other sites

From memory there was an option to mute system notifications in the Pulse audio sound prefs... not at my usual PC so can't tell you for sure!

Share this post


Link to post
Share on other sites

I had to disable pulseaudio in a (failed) attempt to get sound in Skype working, so that's not it.

But the annoying sounds are in Gimp too, which means I have to mute the whole system in order not to go crazy!

Share this post


Link to post
Share on other sites

Skype does not work natively with PulseAudio, but it's not unlikely someone having made a startup script for the issue (like they have done for Audacity, which also does not work with PulseAudio natively).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...