Jump to content

Trouble after upgrade to 2009.1 [solved]


Recommended Posts

ls -l /bin/su

-rwxr-xr-x 1 root root 38532 2009-03-05 22:32 /bin/su*


My permissions on su are different:


$ ls -l /bin/su

-rwsr-xr-x 1 root root 31696 2008-03-07 14:16 /bin/su*


The "sr" indicates that su perms are SUID. You can change the permissions on your /bin/su by logging in as root on a virtual console like you did before and running:


# chmod 4755 /bin/su


and then checking to make sure you have the same permissions as I do by running:


# ls -l /bin/su


It should change the permissions but su permissions and changes to them are usually done by security applications. The one mandriva uses is called msec which runs as a demon and it can reset any changed permissions that it doesn't like. The front end for msec is found in the mandriva control center>Security>Set up security level. I suspect that you may have setup msec at a very high security level; one which doesn't allow ordinary users to su to root and open other administrative applications. To check all this out, I would recommend you login to a gui root session by doing the following:


1. Reboot and when you get to the grub screen hit F3 and then "3" instead of "1" like you did last time;


2. That will take you to a command line login prompt. Login as root and run:


# startx


3. That should start your defalt gui(kde or gnome). You will have full root privileges from within this environment so be careful. Check out your security setting in mcc and see if anything looks off.

Link to comment
Share on other sites

Thank you, pmpatrick. I was about to come here to announce that my problems are over because I have re-installed 2009.1. As user remained the same and /home was not disturbed, I am in effect back to what I had made and not a thing is lost.


The security level I choose is always "normal", so that cannot have been the cause of the difficulty with the root password. I lost patience because of other difficulties: printer did not function, USB stick was not recognised, audio was dead, etc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...