Jump to content
mittfh

No sound in 2009.1 GUI [solved]

Recommended Posts

My soundcard is an SB Live! and worked fine in 2009.0

 

But since the upgrade to 2009.1, not a squeak or pip from the speakers. On the off-chance it was something to do with PulseAudio and the new mixer, I grabbed a terminal and ran "speaker-test -Dplug:surround40 -c4 -twav" - lo and behold the computer boomed out at me.

 

I've checked the volume levels in Sound Preferences - all nice and high. There's nothing worthwhile in PulseAudio Preferences, and according to MCC it's using the standard emu10k1 ALSA driver. Pulse Audio, Automatic Routing, User Switching and Glitch-Free Mode are all enabled.

 

EDIT: I've disabled Pulse, and sound is now working. However, as Pulse is tightly tied into Gnome 2.26, there are a few caveats...

a.) System volume control has disappeared

b.) Sound preferences doesn't work

c.) System sounds don't work.

 

Reading around, apparently the tight binding of Gnome's sound utilities with Pulse is a "feature" (ha ha) - as evidenced by the fact that if you attempt to uninstall Pulse, it will proclaim half of Gnome as dependencies...

 

Which would be great if Pulse could actually do the job it's designed for and route sound from applications to my speakers...

Edited by mittfh

Share this post


Link to post
Share on other sites

I would first check to see if pulse is running:

 

ps aux | grep pulse

 

 

 

 

if it runs try changing the volume in the apps themselves a bit, I have noticed the sound sometimes is muted even though volume is high. If this doesn't work, disable glitch free.

Share this post


Link to post
Share on other sites

It's a little bug reported yet.

It should be soon explained in Erratas

bugreport 48690

 

quite simple to workaround you only have to do this :

With pulseaudio enabled, launch "pavucontrol", click on the "profiles" tab, and

select "analog stereo" profile, to have a correct sound.

 

The default settings provide digital output....

Share this post


Link to post
Share on other sites

Off Pulse Audio in the MCC and configure the card there. Note the AC97 Play and Record.

SBLive! Card is a full-duplex and does not need any sound server ....Lex

Edited by Lexicon

Share this post


Link to post
Share on other sites

Edited the config as mentioned in the errata, and now sound works.

The SB Live is an unusual card in that it has two mixers - Sigmatel for all outputs and digital inputs, plus AC97 for analogue inputs.

Under 2009.0 and earlier, configuring the card to record from Line In or "Stereo Mix" required different mixer setups.

 

However, under 2009.1 / ALSA / Pulse, things are a lot easier. On my setup at least, just set both input and output to ADC Capture / Standard PCM Playback, and it will cope with both. Still trying to figure out how to record from Line In without recording whatever is playing on the system (so I can record an audio cassette via Line In but simultaneously play YouTube videos / digital audio etc. without recording their outputs!)

Share this post


Link to post
Share on other sites

As user in konsole

amixer -c 0 set Line unmute, record, 50%

amixer -c 0 set PCM norecord

 

Other method if PCM is wrong

 

amixer -c 0 set 'Wave Surround',0 norecord

 

See Naming under control

 

amixer -c 0 scontrols

 

Of course, to adjust to their needs. This is just an example.....Lex

Edited by Lexicon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...