Jump to content
Sign in to follow this  
newdog

Update nag (Solved)

Recommended Posts

Update update.png keeps nagging me to update 'libxulrunner1.9'

I have ok'd it several times but after downloading and installation it still insists that I should update it.

It pops up repeatedly.

How can I curb this persistent nagging?

Edited by newdog

Share this post


Link to post
Share on other sites

try to run the following command in a console as root user:

 

urpmi --replacepkgs libxulrunner1.9

Share this post


Link to post
Share on other sites
try to run the following command in a console as root user:

 

urpmi --replacepkgs libxulrunner1.9

 

Hi Tux99,

This is what I get:

[bob@localhost ~]$ su
Password:
[root@localhost bob]# urpmi --replacepkgs libxulrunner1.9
found package(s) libxulrunner1.9-1.9.0.3-1mdv2009.0.i586, libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586, libxulrunner1.9-1.9.0.6-0.1mdv2009.0.i586 in urpmi db, but none are installed

As you see it says "None are installed".

Yet when I follow the update nag, details says:

Version: 1.9.0.7-0.1mdv2009.0

Currently installed version: 1.9.0.7-0.1mdv2008.1

Group: System/Libraries

Architecture: i586

Size: 22675 KB

Medium: Main Updates

URL:

Do you think that urpmi is looking in the wrong place?

Share this post


Link to post
Share on other sites
Can you not right-click on the icon and select something along the lines of don't run at startup?

Hi daniewicz,

If I unticked "Always launch at startup" wouldn't that stop all notifications?

I may have to resort to that if it doesn't stop.

Share this post


Link to post
Share on other sites
If I unticked "Always launch at startup" wouldn't that stop all notifications?

Yes, but you can still choose to manually check for updates from MCC.

 

Another option is to add the offending program to the skip.list file. Edit the /etc/urpmi/skip.list file. File itself shows example of how to do this. Leave off the # symbol. The # symbol is used for comments.

Share this post


Link to post
Share on other sites

Hi medo,

This is the result:

[bob@localhost ~]$ su
Password:
[root@localhost bob]# urpmi --debug libxulrunner1.9
getting lock on urpmi
loading mirrors cache
using mirror ftp://ftp.mirrorservice.org/sites/carroll.cac.psu.edu/MandrivaLinux/official/2009.0/i586
using mirror ftp://ftp.mirrorservice.org/sites/carroll.cac.psu.edu/MandrivaLinux/official/2009.0/i586
using mirror ftp://ftp.mirrorservice.org/sites/carroll.cac.psu.edu/MandrivaLinux/official/2009.0/i586
using mirror ftp://ftp.mirrorservice.org/sites/carroll.cac.psu.edu/MandrivaLinux/official/2009.0/i586
using mirror ftp://ftp.mirrorservice.org/sites/carroll.cac.psu.edu/MandrivaLinux/official/2009.0/i586
using mirror ftp://ftp.mirrorservice.org/sites/carroll.cac.psu.edu/MandrivaLinux/official/2009.0/i586
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Main.cz]
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Main Updates.cz]
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Contrib.cz]
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Contrib Updates.cz]
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Non-free.cz]
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Non-free Updates.cz]
getting exclusive lock on rpm
search_packages: found libxulrunner1.9-1.9.0.3-1mdv2009.0.i586 matching libxulrunner1.9
search_packages: found libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586 matching libxulrunner1.9
search_packages: found libxulrunner1.9-1.9.0.6-0.1mdv2009.0.i586 matching libxulrunner1.9
found package(s): libxulrunner1.9-1.9.0.3-1mdv2009.0.i586 libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586 libxulrunner1.9-1.9.0.6-0.1mdv2009.0.i586
opening rpmdb (root=, write=)
chosen libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586 for libxulrunner1.9|libxulrunner1.9|libxulrunner1.9
selecting libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586
set_rejected: libxulrunner1.9-1.9.0.7-0.1mdv2008.1.i586
opening rpmdb (root=, write=)
getting graph of dependencies for sorting
sorting graph of dependencies
rpms sorted by dependence: libxulrunner1.9
selecting libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586
set_rejected: libxulrunner1.9-1.9.0.7-0.1mdv2008.1.i586
transaction valid: remove= update=libxulrunner1.9
scheduled sets of transactions:
remove=0= update=1=libxulrunner1.9

retrieving rpm files from medium "Main Updates"...
retrieving $MIRRORLIST media/main/updates libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm
'/usr/bin/aria2c' '--log' '/var/cache/urpmi/partial/.aria2.log' '--auto-file-renaming=false' '--ftp-pasv' '--follow-metalink=mem' '--metalink-enable-unique-protocol=false' '--max-tries=1' '--lowest-speed-limit=20K' '--timeout' '3' '--metalink-servers=3' '--uri-selector=adaptive' '--server-stat-if=/root/.aria2-adaptive-stats' '--server-stat-of=/root/.aria2-adaptive-stats' '--connect-timeout=6' '-Z' '-j1' '--allow-overwrite=true' '/var/cache/urpmi/.metalink'
aria2c:
$MIRRORLIST: media/main/updates/libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm
aria2c: 2009-03-29 14:43:10 NOTICE - ServerStat file /root/.aria2-adaptive-stats loaded successfully.
aria2c: [#1 SIZE:80.0KiB/6.9MiB(1%) CN:3 SPD:252.66KiB/s ETA:27s]
aria2c: [#1 SIZE:320.0KiB/6.9MiB(4%) CN:3 SPD:242.19KiB/s ETA:27s]
aria2c: [#1 SIZE:576.0KiB/6.9MiB(8%) CN:3 SPD:252.15KiB/s ETA:25s]
aria2c: [#1 SIZE:784.0KiB/6.9MiB(11%) CN:3 SPD:247.80KiB/s ETA:25s]
aria2c: [#1 SIZE:1.0MiB/6.9MiB(14%) CN:3 SPD:271.87KiB/s ETA:22s]
aria2c: [#1 SIZE:1.2MiB/6.9MiB(18%) CN:3 SPD:271.12KiB/s ETA:21s]
aria2c: [#1 SIZE:1.5MiB/6.9MiB(21%) CN:3 SPD:270.22KiB/s ETA:20s]
aria2c: [#1 SIZE:1.7MiB/6.9MiB(25%) CN:3 SPD:265.28KiB/s ETA:20s]
aria2c: [#1 SIZE:2.0MiB/6.9MiB(28%) CN:3 SPD:262.47KiB/s ETA:19s]
aria2c: [#1 SIZE:2.2MiB/6.9MiB(32%) CN:3 SPD:260.78KiB/s ETA:18s]
aria2c: [#1 SIZE:2.4MiB/6.9MiB(35%) CN:3 SPD:259.53KiB/s ETA:17s]
aria2c: [#1 SIZE:2.7MiB/6.9MiB(39%) CN:3 SPD:258.83KiB/s ETA:16s]
aria2c: [#1 SIZE:2.9MiB/6.9MiB(42%) CN:3 SPD:258.23KiB/s ETA:15s]
aria2c: [#1 SIZE:3.2MiB/6.9MiB(46%) CN:3 SPD:256.95KiB/s ETA:14s]
aria2c: [#1 SIZE:3.4MiB/6.9MiB(50%) CN:3 SPD:257.29KiB/s ETA:13s]
aria2c: [#1 SIZE:3.6MiB/6.9MiB(52%) CN:3 SPD:119.77KiB/s ETA:28s]
aria2c: 52% of 6.9MiB completed, ETA = 28s, speed = 119.77KiB/s
aria2c: 2009-03-29 14:43:26 ERROR - CUID#5 - Download aborted. URI=ftp://ftp.free.fr/mirrors/ftp.mandriva.com/MandrivaLinux/official/2009.0/i586/media/main/updates/libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm
aria2c: Exception: FTP server doesn't support resuming.
aria2c: [#1 SIZE:3.8MiB/6.9MiB(55%) CN:3 SPD:128.36KiB/s ETA:24s]
aria2c: [#1 SIZE:4.1MiB/6.9MiB(59%) CN:3 SPD:135.64KiB/s ETA:21s]
aria2c: [#1 SIZE:4.3MiB/6.9MiB(62%) CN:3 SPD:202.91KiB/s ETA:12s]
aria2c: [#1 SIZE:4.5MiB/6.9MiB(65%) CN:3 SPD:170.52KiB/s ETA:14s]
aria2c: [#1 SIZE:4.8MiB/6.9MiB(69%) CN:3 SPD:184.01KiB/s ETA:11s]
aria2c: [#1 SIZE:5.0MiB/6.9MiB(72%) CN:3 SPD:89.86KiB/s ETA:21s]
aria2c: [#1 SIZE:5.2MiB/6.9MiB(75%) CN:3 SPD:185.15KiB/s ETA:09s]
aria2c: [#1 SIZE:5.4MiB/6.9MiB(78%) CN:3 SPD:168.31KiB/s ETA:08s]
aria2c: [#1 SIZE:5.7MiB/6.9MiB(82%) CN:3 SPD:205.14KiB/s ETA:05s]
aria2c: [#1 SIZE:5.9MiB/6.9MiB(85%) CN:3 SPD:199.51KiB/s ETA:05s]
aria2c: [#1 SIZE:6.2MiB/6.9MiB(89%) CN:3 SPD:226.18KiB/s ETA:03s]
aria2c: [#1 SIZE:6.4MiB/6.9MiB(93%) CN:3 SPD:230.58KiB/s ETA:02s]
aria2c: [#1 SIZE:6.6MiB/6.9MiB(95%) CN:3 SPD:231.99KiB/s ETA:01s]
aria2c: [#1 SIZE:6.7MiB/6.9MiB(97%) CN:3 SPD:188.39KiB/s]9KiB/s
aria2c: [#1 SIZE:6.9MiB/6.9MiB(100%) CN:2]
aria2c: [#1 SIZE:6.9MiB/6.9MiB(100%) CN:2]
aria2c:
aria2c: 2009-03-29 14:43:42 NOTICE - Download complete: ./libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm
aria2c:
aria2c: 2009-03-29 14:43:42 NOTICE - ServerStat file /root/.aria2-adaptive-stats saved successfully.
aria2c:
aria2c: Download Results:
aria2c: gid|stat|path/URI
aria2c: ===+====+======================================================================
aria2c:   1|  OK|./libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm
aria2c:
aria2c: Status Legend:
aria2c:  (OK):download completed.(ERR):error occurred.(INPR):download in-progress.
retrieved $MIRRORLIST media/main/updates libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm
...retrieving done
verifying signature of /var/cache/urpmi/rpms/libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm
installing libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm from /var/cache/urpmi/rpms
starting installing packages
opening rpmdb (root=, write=1)
created transaction for installing on / (remove=0, install=0, upgrade=1)
trans: scheduling update of libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586 (id=9355, file=/var/cache/urpmi/rpms/libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm)
Preparing...					 #############################################
  1/1: libxulrunner1.9	   #############################################
error: unpacking of archive failed on file /usr/lib/xulrunner-1.9/dictionaries: cpio: rename failed - Is a directory
removing installed rpms (libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm) from /var/cache/urpmi/rpms
unlocking urpmi database
unlocking rpm database
EXITING (pid=9068)
[root@localhost bob]#

Share this post


Link to post
Share on other sites
Another option is to add the offending program to the skip.list file. Edit the /etc/urpmi/skip.list file. File itself shows example of how to do this. Leave off the # symbol. The # symbol is used for comments.

Thanks for that David, I didn't know about the skip list. I'll keep that in mind.

Share this post


Link to post
Share on other sites

don't use the skip list, especially not for xulrunner, this is an important security update, wait a while untill the other packages, which depend on xulrunner, get uploaded...

Share this post


Link to post
Share on other sites

The debug output is saying that an error occurred during unpacking.. So, either your computer can't unpack it because its a corrupted file or something on your computer is not working for unpacking.

 

Why don't you go get the file manually and manually install it? If its installed via RPM then its installed. You don't have to get it from that source necessarily. If you can't install it and get an error during installation,, then you can focus on why that is happening rather than skippig an update..

Share this post


Link to post
Share on other sites

Adding to what Cannonfodder suggests, here is how I would do it (you have to do it all in a console as root user):

 

1) Check if rpm sees libxulrunner1.9 as installed and if yes (it should), remove the currently installed libxulrunner:

rpm -qa|grep libxulrunner1.9
rpm -e --nodeps libxulrunner1.9

 

2) check that no downloaded packages are left over in the cache dir:

ls -la /var/cache/urpmi/rpms

if you see any libxulrunner related file in there, delete it.

 

3) download libxulrunner1.9 manually from any mirror, for example:

cd /var/tmp
wget \ ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/MandrivaLinux/official/updates/2009.0/i586/media/main/updates/libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm

 

4) install it:

rpm -ivh /var/tmp/libxulrunner1.9-1.9.0.7-0.1mdv2009.0.i586.rpm

 

Make sure you don't have Firefox or Seamonkey, or any other browser running that relies on libxulrunner, best is to have nothing running apart from the console, while doing this.

 

And don't use the skip list or don't disable the update checks as that's just a nasty workaround that hides the problem and it means you won't get notified of real updates anymore!

Edited by tux99

Share this post


Link to post
Share on other sites
And don't use the skip list or don't disable the update checks as that's just a nasty workaround that hides the problem and it means you won't get notified of real updates anymore!

Well, that's your opinion, but I don't fully agree with it. Depending upon one's connection speed, waiting for MdkOnline to complete can be a real pain.

 

Everyone keeps saying how secure Linux is - and if that is so, not applying an update the instant it is released should not matter that much. Checking every few days or once a month should be just fine (IMO). After all, that insecure MS software is only updated once a month except in a few circumstances.

 

Regarding security: Adobe Reader has been released as version 9, and a significant security update 'version 9.1' has also been released. Mandriva still only offers version 8.x. What's up with that???

 

Regarding putting this particular update, libxulrunner1.9, into the skip.list file: I guess it depends on whether the OP can get it to install or not. Of course the preferred solution would be to get the update.

Share this post


Link to post
Share on other sites
Well, that's your opinion, but I don't fully agree with it. Depending upon one's connection speed, waiting for MdkOnline to complete can be a real pain.

Well, if someone does that as a conscious decision, then fine, it's his/her system and he/she can do whatever he/she likes with it, and there are good reasons to do so in specific cases.

But suggesting it as a solution for this particular issue to someone who might not realise the implications of it, is not ideal, especially as this issue should be perfectly fixable.

 

Everyone keeps saying how secure Linux is - and if that is so, not applying an update the instant it is released should not matter that much.

 

True, but once update nagging is disabled, how many people will remember to check for updates?

And updates are not just for security issues but for bugfixes that improve the software too.

 

Regarding security: Adobe Reader has been released as version 9, and a significant security update 'version 9.1' has also been released. Mandriva still only offers version 8.x. What's up with that???

 

You are right, maybe mail Mandriva and ask them about it?

 

Regarding putting this particular update, libxulrunner1.9, into the skip.list file: I guess it depends on whether the OP can get it to install or not. Of course the preferred solution would be to get the update.

putting it into the skip list will likely create problems next time a Firefox upgrade comes up, as it usually get's updated with it and urpmi will likely refuse to update Firefox if it can't update libxulrunner.

Share this post


Link to post
Share on other sites

Thanks guys,

I followed Cannonfodder's suggestion and downloaded the file. (I got it from rpmfind.net)

First I tried installing it with the gui software installer.

A fter a reboot the nag was still there.

Then as su in a console I moved it to /var/tmp and installed it as per tux's code.

After a reboot it has been over an hour now and not a sign of a nag.

Thank you, thank you, thank you. :D :D

 

Now if I could figure how to mark this thread title as 'Solved' I would do it. ;)

Edited by newdog

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...