Jump to content
Sign in to follow this  
Guest phugoid

Ctrl-w maybe intercepted by KDE, need it for emacs

Recommended Posts

Guest phugoid

I just noticed that the combination Ctrl-w is not triggering "kill-region" in emacs as expected. This is true if I open "emacs -nw" in Konsole, in Eterm, or if I allow it to open its own GUI window. I'm running Mandriva One 2009 with KDE 4.1.

 

If I bring up the list of all key-bindings in emacs (Ctrl-h b), C-w is indeed listed as bound to kill-region. But if I do Ctrl-h Ctrl-w to get help for a key combination, emacs doesn't receive the sequence. That last bit works fine for other sequences.

 

If I try it in a virtual console (Ctrl-Alt-F3), the Ctrl-w key binding works fine in emacs.

 

There is a big difference between the xev outputs generated by Ctrl-y (which works fine) and Ctrl-w, as below:

 

Ctrl-y

KeyPress event, serial 34, synthetic NO, window 0x3e00001,
   root 0x2ed, subw 0x0, time 1176552699, (66,571), root:(721,594),
   state 0x10, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
   XLookupString gives 0 bytes:                                       
   XmbLookupString gives 0 bytes:                                     
   XFilterEvent returns: False                                        

KeyPress event, serial 34, synthetic NO, window 0x3e00001,
   root 0x2ed, subw 0x0, time 1176553056, (66,571), root:(721,594),
   state 0x14, keycode 29 (keysym 0x79, y), same_screen YES,       
   XLookupString gives 1 bytes: (19) ""                            
   XmbLookupString gives 1 bytes: (19) ""                          
   XFilterEvent returns: False                                     

KeyRelease event, serial 34, synthetic NO, window 0x3e00001,
   root 0x2ed, subw 0x0, time 1176553149, (66,571), root:(721,594),
   state 0x14, keycode 29 (keysym 0x79, y), same_screen YES,       
   XLookupString gives 1 bytes: (19) ""                            
   XFilterEvent returns: False                                     

KeyRelease event, serial 34, synthetic NO, window 0x3e00001,
   root 0x2ed, subw 0x0, time 1176554134, (66,571), root:(721,594),
   state 0x14, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
   XLookupString gives 0 bytes:
   XFilterEvent returns: False

 

Ctrl-w

KeyPress event, serial 34, synthetic NO, window 0x4000001,
   root 0x2ed, subw 0x0, time 1176787194, (165,-11), root:(820,12),
   state 0x10, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
   XLookupString gives 0 bytes:
   XmbLookupString gives 0 bytes:
   XFilterEvent returns: False

FocusOut event, serial 34, synthetic NO, window 0x4000001,
   mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 34, synthetic NO, window 0x4000001,
   mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 34, synthetic NO, window 0x0,
   keys:  4294967277 0   0   2   32  0   0   0   0   0   0   0   0   0   0   0
          0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

KeyRelease event, serial 34, synthetic NO, window 0x4000001,
   root 0x2ed, subw 0x0, time 1176787466, (165,-11), root:(820,12),
   state 0x14, keycode 25 (keysym 0x77, w), same_screen YES,
   XLookupString gives 1 bytes: (17) ""
   XFilterEvent returns: False

KeyRelease event, serial 34, synthetic NO, window 0x4000001,
   root 0x2ed, subw 0x0, time 1176787735, (165,-11), root:(820,12),
   state 0x14, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
   XLookupString gives 0 bytes:
   XFilterEvent returns: False

 

I'm not sure what that means or where to look next. I would like to prevent Ctrl-w from being intercepted so that I can use it in emacs.

I'd be very grateful if you could point me in the right direction.

Share this post


Link to post
Share on other sites

He's running Mandriva One 2009 with KDE 4.1 (from first paragraph, third sentence). Although I've no idea on why, I use neither emacs nor KDE - so sorry can't help any more than that.

Share this post


Link to post
Share on other sites

Can't you just go into the KDE preferences/settings for keyboard shortcuts, and remove/change the offending combination ?

 

I had a similar thing years ago while using GTK Radiant, and that's what I did. That was KDE3 of course, I guess it should be the same or similar with KDE4, don't know, I haven't been able to bring myself to use it for long enough yet, it's still to lacking for me.

Share this post


Link to post
Share on other sites
Guest phugoid
Can't you just go into the KDE preferences/settings for keyboard shortcuts, and remove/change the offending combination ?

 

I had a similar thing years ago while using GTK Radiant, and that's what I did. That was KDE3 of course, I guess it should be the same or similar with KDE4, don't know, I haven't been able to bring myself to use it for long enough yet, it's still to lacking for me.

 

Thanks for the tip. I tried now opening kcontrol (which I must open from the command line, since it's not available in the desktop menu system). Under Regional & Accessibility, I can't find anything that would affect Ctrl-w. I've tried disabling "KHotKeys daemon", to no effect.

Share this post


Link to post
Share on other sites
Thanks for the tip. I tried now opening kcontrol (which I must open from the command line, since it's not available in the desktop menu system). Under Regional & Accessibility, I can't find anything that would affect Ctrl-w. I've tried disabling "KHotKeys daemon", to no effect.

I use KDE 3.x, there is no problem here. I know that Ctrl-W closes windows/tabs in Firefox. Also Kate, Kedit and alike associate Ctrl-W with the "Close file" function. Your experience suggests that KDE4 has made this conflicting shortcut a standard across all applications. I would suggest to try Gnome.

Share this post


Link to post
Share on other sites
Guest phugoid
I use KDE 3.x, there is no problem here. I know that Ctrl-W closes windows/tabs in Firefox. Also Kate, Kedit and alike associate Ctrl-W with the "Close file" function. Your experience suggests that KDE4 has made this conflicting shortcut a standard across all applications. I would suggest to try Gnome.

 

Well, the reason I went with KDE 4.x is to have an updated system that runs Konqueror. I will use some of the automation and scripting capabilities of Konqueror to make a GUI for an application I'm writing - this will be running on a stand-alone machine dedicated to the application.

 

I still think there's a chance to learn something from this keybinding intercept problem, if anyone out there has some tips to help diagnose the cause...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...