Jump to content
Sign in to follow this  
linux_challenged

laptop battery life

Recommended Posts

Hi all...

 

I just purchased a long life battery for my dell i6400 lappie and have a question.

 

I am dual booting xp pro and mandriva 2008.1 on this puter and there is a discrepancy regarding how much time is left under battery power. The windows side shows twice as much time left as the mandriva side.

 

Is there a setting I need to adjust so that the time left is maximized?

 

I don't want to have to switch back to the dark side just because of a faulty power indicator...

 

thanx in advance

Share this post


Link to post
Share on other sites

Do you have frequency scaling enabled?

 

open a konsole window and type the following 3 commands (each followed by enter/return):

 

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

 

and post the output here

Edited by tux99

Share this post


Link to post
Share on other sites

1. When on batteries make user your laptop uses the Powersave CPU frequency policy, as tux99 said,

2. Check which services are running (Mandriva Control Center -> System->Services). Stop and disable for good those that you don't use. In particular, turn off file indexing.

3, Turn off/disable bluetooth, fingerprint reader, etc.

4. Turn down the screen brigtness.

 

Edit: run the powertop command and try the suggested improvements.

Edited by coverup

Share this post


Link to post
Share on other sites
Do you have frequency scaling enabled?

 

open a konsole window and type the following 3 commands (each followed by enter/return):

 

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

 

and post the output here

 

@tux99

 

thanx for your reply...

 

following is the output for the three commands - they are in the order you indicated...

 

1733000 1333000 1067000 800000

 

acpi-cpufreq

 

ondemand

 

Please tell me what these responses are indicating - I am still in the learning curve phase with linux

 

thanx again

Share this post


Link to post
Share on other sites
following is the output for the three commands - they are in the order you indicated...

 

1733000 1333000 1067000 800000

 

acpi-cpufreq

 

ondemand

 

Please tell me what these responses are indicating - I am still in the learning curve phase with linux

 

The output you got looks good. The row of numbers is the frequencies your cpu supports (1.7Ghz, 1.3Ghz, 1.06Ghz and 800Mhz) and you have the acpi-cpufreq ondemand scaling active, which means your cpu should slow down to 800Mhz when idle (to use less power) and ramp up to 1.7Ghz when busy.

 

What this tells me is that your battery life problem is not, due to non functioning cpu scaling, so the problem must be somewhere else.

 

I'm wondering, have you actually tried out how long the battery lasts under Linux and under Windows, as in, fully charged it and then used the laptop continuously until the battery runs out of power while measuring the time with a watch?

I'm wondering if it's just the indicator that's not correct or if in fact the laptop runs out of power quicker with Linux for some reason.

This would be useful to know in oder to find the cause of the problem.

Edited by tux99

Share this post


Link to post
Share on other sites

I haven't used the laptop under battery power until it actually dies but I am wondering if it will actually die or keep running until the battery is truly out of juice...

 

I will try it tonite or tomorrow and post back with the results...

 

thanx for your help!!!

Share this post


Link to post
Share on other sites
1. When on batteries make user your laptop uses the Powersave CPU frequency policy, as tux99 said,

2. Check which services are running (Mandriva Control Center -> System->Services). Stop and disable for good those that you don't use. In particular, turn off file indexing.

3, Turn off/disable bluetooth, fingerprint reader, etc.

4. Turn down the screen brigtness.

 

Edit: run the powertop command and try the suggested improvements.

 

 

I ran the powertop command and it came back with several suggestions - can I cut and paste the commands from the list into a terminal window? I have read several online articles but no indications of how to physically apply the suggestions.

 

Cut and paste is more accurate for me :D

 

I also went into MCC and checked that I didn't have anything running that isn't needed, so I am hoping the powertop suggestions help.

 

I am also going to physically monitor the battery life as was suggested by tux99...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...