Jump to content

Mandriva mirrors [solved]


Recommended Posts

Hi all,

since my install is now how I would like it I have been trying to update. I can add and easily update the PLF medias.


I had trouble downloading the Official medias last night. I thought it might be my internet connection, so I left it. Tonight, still troubles downloading updates. So I removed the medias, readded the PLF medias with out trouble.

I cannot add the official medias. Is anyone else having trouble????


The message I get is:


Failure when adding medium


There was a problem adding medium:

Could not find a mirror from mirror list http://api.mandriva.com/mirrors/basic.2009.0.$arch.lst

Link to comment
Share on other sites

There's a file in /var/urpmi I think it goes by the name mirrors.list or something. You can delete this, and then try to add mirrors again, and it'll download a new one and be up-to-date. Either that, or just rename/copy it to another place in case I'm wrong, but I'm pretty sure I did this before when I had problems with mirrors updating.

Link to comment
Share on other sites

this is from using Easy urpmi:


unable to add medium, errors reported:


...retrieving failed: aria2 failed: exited with 1

problem reading synthesis file of medium "contrib"


This is from using the code line from easy urpmi:

http://api.mandriva.com/mirrors/basic.2009.0.i586.list: media/main/release/media_info/20090216-062133-synthesis.hdlist.cz

...retrieving failed: ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/o...hesis.hdlist.cz (7more)

http://api.mandriva.com/mirrors/basic.2009.0.i586.list: media/main/updates/media_info/20090219-132715-synthesis.hdlist.cz

http://api.mandriva.com/mirrors/basic.2009.0.i586.list: media/contrib/release/media_info/20081003-221855-synthesis.hdlist.cz

...retrieving failed: ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/o...hesis.hdlist.cz (7more)

...retrieving failed: http://ftp.isu.edu.tw/pub/Linux/Mandriva/o...hesis.hdlist.cz (7more)

...retrieving failed: aria2 failed: exited with 1

problem reading synthesis file of medium "Contrib"

Edited by xboxboy
Link to comment
Share on other sites

1-delete all mirrors you downloaded

2- go to easy urpmi

3- dont use the command line

4- just press on the button of adding official mirrors

5- a download dialogue appear to you

6- chose to open it with add urpmi media then press ok

7- do the same thing to plf media

8- open configure you computer then chose configure media source

9- then mark the enable check box if it didnt update the media source press the edit button then chose wget from the downloader list box

Link to comment
Share on other sites

Try adding a specific mirror, open the Mandriva control centre>s/w management>configure media sources, press Ctrl+A.


This is what I did, worked perfect, went through a Japanese mirror (I'm in Australia). Some 500mB of downloads, and I'm upto date.


So I think it was purely a bad mirror or server. Seems all fine now. Thanks all.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...