Jump to content
Sign in to follow this  
Guest paul8paul

Firefox desktop shortcut [solved]

Recommended Posts

Guest paul8paul

Hello

Im sure this probably has a very obvious solution but Im used to windows and just cant figure it out in Mandriva.

 

Basically Im using the most recent Mandriva with KDE4 desktop and the most recent firefox. I had a nice big firefox shortcut on my desktop which I managed to mess up some how (Doh!). So I uninstalled firefox and reinstalled it using the software management package. Now I can open firefox by using Dolphin and going into root/usr/lib/firefox-3.0.5.

 

My problem is I cant get the firefox icon shortcut back on the desktop and firefox is no longer in the KDE applications menu.

 

Again Im sure this is a stupidly simple question but Im a complete Linux newbie and would really appreciate any help with this.

 

Cheers

Paul

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

If there is yet in the menu try making a drag and drop form the icon to your desktop [if does not exist in the lde menu, logon in gnome and look over there], if this does not work make a right click in your desktop > New Link/Shortcut and in the properties look for application field and enter firefox.

Share this post


Link to post
Share on other sites
Guest paul8paul

Thanks a million Isamu

 

That was very helpful. I didnt seem to have the gnome option but was able to fix it by logging back in to the older KDE desktop.

 

Thanks again

Paul

Share this post


Link to post
Share on other sites

New to KDE4 but here is what I have figured out.

 

I don't think you can have an icon directly on the desktop without creating a folder view widget.

 

To get your menu entry back try this (from my settings. Yours may vary):

 

Right click on the menu button and select 'Menu Editor'. (Mine is on the bottom left)

 

Left click on 'Internet' and then select the 'New Item' button at the top.

 

Type if 'Firefox Web Browser (Web Browser) and hit the ENTER key.

 

In the right hand panel enter the following:

 

Description: Web Browser

Comment: Browse the Web

Command: firefox %u

 

 

Right click on the icon button at the top right of the right hand panel and select "other icons' and browse to /root/usr/lib/firefox-3.0.5/icons/mozicon128.png.

 

In the menu view you can drag your new entry around to where you would like it to appear in the menu.

 

Then left click the save button at the top of the menu editor window to save and update the menu. You should now have your menu entry back.

 

Hope this helps.

 

Edit: seems I found a way to get a desktop firefox icon. If you have an application launcher widget on your desktop (mine is in upper left corner) you can navigate application/internet/firefox and right click and select 'add to desktop'. Your widgets have to be unlocked for the 'add to desktop' option to appear. You can then position the widget as you like. There may be other ways to do it.

Edited by angst

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...