Jump to content
coverup

Unmounted SATA HDD is still visible

Recommended Posts

Hi there,

 

I recently added a secondary SATA HDD to my old Mandrake 10.1 desktop. The drive is recognized as /dev/sda1 and is formatted as ext3 filesystem. MDK was unable to mount it properly on start up, and I added the following entry to /etc/fstab

 /dev/sda1 /backup ext3 umask=0,user,iocharset=iso8859-1,sync,kudzu,codepage=850,noauto,exec,users 0 0

Despite that, the drive was painfully slow until I manually unmounted and mounted it with a command

mount -t ext3 /dev/sda1 /backup

After that I could read and write to the HDD OK. The problem is that I have to mount the drive manually after every reboot. If I don't, then

 

1. ls lists a different list of files on the drive from what should be there! I suspect those files were put there while the drive was not mounted properly

 

2. Why can I see anything at all on the partition /backup after it has been unmounted?

 

Here is what I mean

# mount
/dev/hda1 on / type ext3 (rw)
none on /proc type proc (rw)
none on /proc/bus/usb type usbfs (rw)
none on /sys type sysfs (rw)
/dev/hda6 on /home type ext3 (rw)
none on /mnt/floppy type supermount (rw,sync,dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,codepage=850)
# ls /backup
a-Fri.tgz  a-Sat.tgz  a-Thu.tgz  a-Wed.tgz
a-Mon.tgz  a-Sun.tgz  a-Tue.tgz

Note that the partition /backup and device /dev/sda1 are not on the list of mounted partitions, yet ls /backup shows there are files on it! Where can I find those files? They disappear after the HDD is mounted manually.

Share this post


Link to post
Share on other sites

There's a /backup directory under your root partition. I expect you see whatever's there when the drive is unmounted. Then when you mount the drive under /backup, you see in /backup whatever's on the drive.

Share this post


Link to post
Share on other sites

Ah, you are right! And I was wondering why / partition was nearly full! Thanks!

 

Now, can anybody tell what's wrong with the fstab entry? The drive does not mount on boot.

Share this post


Link to post
Share on other sites

I tried removing noauto, and replacing with auto or with nothing. Both ways, I get an error:

mount: special device /dev/sda1 does not exist

How can this be fixed?

Share this post


Link to post
Share on other sites

Quick and easy solution might be to put the mount command in /etc/rc.d/rc.local (and add back the noauto option in fstab).

 

Jim

Share this post


Link to post
Share on other sites
Quick and easy solution might be to put the mount command in /etc/rc.d/rc.local (and add back the noauto option in fstab).

 

Jim

In fact, I did try this method, but the drive did not mount anyway - don't know why....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...