Jump to content
Sign in to follow this  
IcoBgr

Problem with panel in KDE4 and using 3D

Recommended Posts

Hi, when I use 3D and for example start to watch a movie and set the player to fullscreen mode, my desktop Panels became over the video screen and hides part of the video. If I set to panels that other windows can cover them when I maximize any window, it covers them. But I do not like this. I want only when I use fullscreen mode for some application to cover the panels, but not maximization. For example when I start TORCS in fullscreen mode the panels start to blinks because both want to be on top of other.

 

So, is anybody know any resolution about this problem?

 

Regards,

 

 

Hristo Hristo

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

Common problem with compiz which AFAIK will be fixed some time spring 2009.

 

What you can do is to if KDE;

kwin --replace

 

if Gnome

metacity --replace

 

Then launch the game.

 

 

If it works you can build a script to turn off compiz, launch the game, when exiting the game it will start compiz up again.

Another solution is to use fusion-icon, not sure if it works in KDE, but it works in Gnome.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...