Jump to content

Wireless networking in MSI Wind


Recommended Posts

Getting Linux wireless connectivity in my Wind has been my only gripe and some of you might have already read about it in this thread.


With the official release of 2009.0, i decided to download the two CDs and reinstall mandriva. I configured the sources from the easyurpmi site because the official update api site keeps on throwing me to a site that fails to add (maybe its in the middle of a synchronization process).


Anyway, I configured the wireless card using the network center instead of going straight to drakconnect. It downloaded all the prerequisite software to use the native drivers (rtls8187se), installs everything properly (assumed since i did not see any error) and at the end it detects the correct signal. I configured it with the correct passkey (please see wifi-config.png, i changed it for the screenshot :) ) but nothing happens when I press connect except this message in the console


 SIOCETHTOOL: Operation not supported


i tried executing dhclient and dhcpcd in the cli since i was able to do that in my fujitsu laptop but i didnt get any offers. dhcpcd just fails. below is the output of the various commands that I tried:


[root@localhost /tmp]# ifconfig												 
eth0	  Link encap:Ethernet  HWaddr 00:1D:92:58:4F:32						 
	  inet addr:  Bcast:  Mask:	  
	  inet6 addr: fe80::21d:92ff:fe58:4f32/64 Scope:Link					
	  RX packets:2129 errors:0 dropped:1374996811 overruns:0 frame:0		
	  TX packets:1495 errors:0 dropped:0 overruns:0 carrier:0			   
	  collisions:0 txqueuelen:1000										  
	  RX bytes:1848620 (1.7 MiB)  TX bytes:109616 (107.0 KiB)			   
	  Interrupt:16 Base address:0x4000									  

lo		Link encap:Local Loopback  
	  inet addr:  Mask:
	  inet6 addr: ::1/128 Scope:Host	 
	  UP LOOPBACK RUNNING  MTU:16436  Metric:1
	  RX packets:22 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0							
	  RX bytes:1100 (1.0 KiB)  TX bytes:1100 (1.0 KiB)	 

wlan0	 Link encap:Ethernet  HWaddr 00:1D:92:C6:6C:35  
	  inet6 addr: fe80::21d:92ff:fec6:6c35/64 Scope:Link
	  RX packets:5 errors:0 dropped:844 overruns:0 frame:0
	  TX packets:287 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000						  
	  RX bytes:645 (645.0 b)  TX bytes:10775 (10.5 KiB)	 
	  Interrupt:17 Memory:f8bf8000-f8bf8100				 

[root@localhost /tmp]# dhcpcd wlan0
Error, wlan0: timed out			
Error, wlan0: lease information file `/var/lib/dhcpcd/dhcpcd-wlan0.info' does not exist																		 
Warning, wlan0: using IPV4LL address							  

[root@localhost /tmp]# dhclient wlan0										   
Internet Systems Consortium DHCP Client V3.0.7								  
Copyright 2004-2008 Internet Systems Consortium.								
All rights reserved.															
For info, please visit http://www.isc.org/sw/dhcp/							  

Listening on LPF/wlan0/00:1d:92:c6:6c:35
Sending on   LPF/wlan0/00:1d:92:c6:6c:35
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 4
DHCPDISCOVER on wlan0 to port 67 interval 4
DHCPDISCOVER on wlan0 to port 67 interval 4
DHCPDISCOVER on wlan0 to port 67 interval 9
DHCPDISCOVER on wlan0 to port 67 interval 15
DHCPDISCOVER on wlan0 to port 67 interval 8
DHCPDISCOVER on wlan0 to port 67 interval 10
DHCPDISCOVER on wlan0 to port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

[root@localhost /tmp]# iwconfig
lo		no wireless extensions.

eth0	  no wireless extensions.

wlan0	 802.11b/g linked  ESSID:"kaboom"  
	  Mode:Managed  Frequency=2.437 GHz  Access Point: 00:13:46:41:D2:62   
	  Bit Rate=54 Mb/s													 
	  Retry:on   RTS thr:off   Fragment thr:off							
	  Encryption key:off												   
	  Power Management timeout:0us  mode:All packets received			  
	  Link Quality=94/100  Signal level=-156 dBm  Noise level=6 dBm		
	  Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0			 
	  Tx excessive retries:0  Invalid misc:0   Missed beacon:0			 

[root@localhost /tmp]# iwlist wlan0 scanning
wlan0	 Scan completed :
	  Cell 01 - Address: 00:13:46:41:D2:62
				Protocol:IEEE 802.11bg
				Encryption key:on
				Bit Rates:54 Mb/s
				Extra: Rates (Mb/s): 1 2 5.5 9 11 6 12 18 24 36 48 54
				Quality=94/100  Signal level=-173 dBm  Noise level=17 dBm
				IE: WPA Version 1
					Group Cipher : TKIP
					Pairwise Ciphers (1) : TKIP
					Authentication Suites (1) : PSK
				Extra: Last beacon: 44ms ago

[root@localhost /tmp]# ifup wlan0

Determining IP information for wlan0... failed.
[root@localhost /tmp]#


any other suggestions on how to proceed? just this thing and my wind will finally be windows free when i am not using it for work. :)






Edited by ramfree17
Link to comment
Share on other sites

the gui drakconnect hits the same "blank" wireless network list[1] so i switched to using the console mode. everything went according to the expected screens and i got a congratulatory remark at the end. the wireless card is still unable to get any IP address from the server and the only errors in the console is the SIOCETHTOOL: Operation not supported message. :(



Link to comment
Share on other sites

its showing the same output. i read about iwconfig and wpa_supplicant thinking that maybe i can force it manually but found out that wpa_supplicant is already running as a daemon and the configuration for my AP is correctly entered in the wpa_supplicant configuration file.


if there are no other option to try then over the weekend i am thinking of downgrading my access point to WEP since nobody near our house seems to use any computer so its fairly "safe". if that fails then i will try the ndiswrapper route again. :(



Link to comment
Share on other sites

I think it may need ndiswrapper :\. Sounds like maybe there's a bug in the driver.


It would be interesting to run wpa_cli as root while it's trying to connect, and see what it says is going on (it's an interactive interface to wpa_supplicant, it will print out some status messages on what wpa_supplicant is doing).

Link to comment
Share on other sites

here iis the wpa_cli output whever i configure/connect the wireless interface

Selected interface 'wlan0'

Interactive mode

> <2>CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
<2>CTRL-EVENT-TERMINATING - signal 15 received
'PING' command timed out.
Connection to wpa_supplicant lost - trying to reconnect
Connection to wpa_supplicant re-established
<2>WPA: Key negotiation completed with 00:13:46:41:d2:62 [PTK=TKIP GTK=TKIP]
<2>CTRL-EVENT-CONNECTED - Connection to 00:13:46:41:d2:62 completed (auth) [id=0 id_str=]


there isnt any activity posted when i try to get a new DHCP offer though. i am using a DLink router so i tried disabling the Turbo G enhancements but the results are the same. i downgraded the encryption to WEP and now i can connect wirelessly (posting it while inside the bedroom, :) ). i think i will hold off using ndiwsrapper untill i can find another WPA access point to isolate that the problem is really with the driver and not my access point.


any further suggestions would be welcome though. :)



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...