Jump to content

normal user no longer can create at jobs 2009


Recommended Posts

at worked fine in 2008.1 broken, broken after upgrade to 2009:


[m0loch@pokin ~]$ at 09:30

warning: commands will be executed using (in order) a) $SHELL c) login shell c) /bin/sh

Cannot create atjob file /var/spool/at/a0001a01375f0e: Permission denied



[m0loch@pokin ~]$ sudo ls -lah /var/spool/at

total 16K

drwx------ 3 daemon daemon 4.0K 2008-10-18 09:01 .

drwxr-xr-x 11 root root 4.0K 2008-10-15 23:33 ..

-rw------- 1 daemon daemon 6 2008-10-18 09:55 .SEQ

drwx------ 2 daemon daemon 4.0K 2008-10-18 09:01 spool

[m0loch@pokin ~]$


anyone know a fix?

root can create at jobs, and normal user can sudo

Link to comment
Share on other sites

Does a file /etc/at.allow exist and have your name in it? the at.allow and at.deny files can be used to lock down access to at


no, /etc/at.allow does not exist /etc/at.deny does exist and is an empty file - according to the man page this should allow access to all users

Link to comment
Share on other sites

This may be related to your default security settings which you can set in draksec. For level 4 and 5 (higher & paranoid), users will not have access to cron & at, unless you grant access via at.allow (or override the default for enable_at_crontab for that level in /usr/share/msec/level.4 or level.5.


If that doesn't explain it then I am out of options..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...