Jump to content
Sign in to follow this  
RVDowning

/dev/cdrom vs /dev/dvd on 2009.0

Recommended Posts

On 2009.0 I was trying to restore a file from backup and I had to tell mondorestore that my dvd was at /dev/dvd. It seems in the past that it was /dev/cdrom.

 

Also, I kicked off a backup yesterday which balked when it came time to write the files to dvd. I looked in the script and it was referencing /dev/cdrom. So, I changed the "cdrom" to "dvd" and kicked it off again this morning when I left for work. I won't know if it worked until I get home.

 

I see that /etc/fstab also is showing /dev/cdrom.

 

Also, when I put a dvd in the system, I no longer get a popup asking me what I want to do with it.

 

So, has there been some intentional change regarding how a dvd device is actually referenced in /dev?

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

This doesn't matter, what matters is how many drives you have in your system and how they are referenced. For example, my laptop has one CD/DVD drive, and so:

 

[ian@esprit ~]$ file /dev/cdrom
/dev/cdrom: symbolic link to `sr0'

[ian@esprit ~]$ file /dev/dvd
/dev/dvd: symbolic link to `sr0'

 

they are both linked to the same place. Therefore, for me /dev/cdrom or /dev/dvd should have worked without a problem. The popups can be turned off, I usually have them turned off in Gnome because they annoy me, but you can turn them back on. If you're using KDE, I'm unsure as I don't use it, but you should also be able to do the same. Just look for an option regarding removable device preferences.

Share this post


Link to post
Share on other sites

Ok, I have some confusion here. Prior to my changing the mondo/mindi backup command it referenced /dev/cdrom and would not write to the dvd. I changed the command to reference /dev/dvd and it did write to the dvd. I'll try another backup this way it is to see if it still works, and then change it back to see if it stops again. I swear, I think that sometimes the same application doesn't seem to act the same way twice.

 

It is almost like sometimes an application is accessed in a "kde3" way and sometimes in a "kde4" way if that makes any sense. I kind of wonder if kde3 and kde4 are in some way co-mingled on my system.

Share this post


Link to post
Share on other sites

They are both linked to the same place though on your system? I think I remember having something similar once with acidrip in Mandriva 2006, but I'm not sure.

Share this post


Link to post
Share on other sites

[rvd@localhost ~]$ file /dev/cdrom

/dev/cdrom: symbolic link to `sr1'

[rvd@localhost ~]$ file /dev/dvd

/dev/dvd: symbolic link to `sr0'

 

Seems this may have been the culprit. It just so happens that I have a cdrom and a dvd.

 

This is the only related entry in /etc/fstab:

/dev/cdrom /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0

Share this post


Link to post
Share on other sites

Yep, that'll be why it was failing. It seems that the DVD is the master driver in your system, and the CD-ROM is the slave, hence the DVD being sr0 and CD being sr1.

 

You don't need fstab entries for them, since hal will be taking care of mounting etc.

Share this post


Link to post
Share on other sites

Indeed, the fstab entries aren't used but from old programs that aren't hal-aware, and wine.

You could (should?) remove them completely, or just comment them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...