Jump to content

2009 Died [solved]


Recommended Posts

Last night I did some updates that enabled the 2.6.27 kernel to work with the Nvidia graphics card. They worked, and although I had a bit of trouble with 'nvidia-settings' freezing while I was trying to configure, I eventually got it to work as it did with the previous kernel (ie. pretty well). This morning I booted again and after waiting about 5 minutes for that damned splash screen to go away (something really has to be done about that) I got the following error:


Checking Root Filesystem.

etc/rc.d/rc.sysinit : line 669: 2712 segmentation fault


You then get the usual screen about entering the root password for maintenance. I did this and ran e2fsck with the -fp options and it completed with no errors.


Any other ideas as to what I might do? I doubt very much I would be able to tell what the error was in rc.sysinit (it has over 1000 lines). I could replace it, but where would I get a replacement from? I could reinstall an image from about a week ago but that is only a last resort really as I will lose so many updates.


Any ideas?


EDIT. I just had a look at rc.sysinit from another distro. this is what it looks like:




fsck $*



if [ "$rc" -eq "0" ]; then



elif [ "$rc" -eq "1" ]; then



elif [ "$rc" -eq "2" -o "$rc" -eq "3" ]; then

gprintf "Unmounting file systems\n"

umount -a

mount -n -o remount,ro /

gprintf "Automatic reboot in progress.\n"

reboot -f



Line 669 is the opening curly bracket after the line with 'fsck'. Is there something wrong with that? (it does have a corresponding closing bracket way down at line 711)

Edited by viking777
Link to comment
Share on other sites

You have downgrade kernel and start from kernel-2.6.26. In MCC remove all servers except DVD. Add new stability servers (mcc add automatictly), but from MCC. Uninstall new 2.6.27 kernel. If You have old kernel, start from this. ....Lex


If You nave'nt net instert disc DVD Mandriva Coocker and upgrade system. Automaticly installed old default kernel.

Edited by Lexicon
Link to comment
Share on other sites

Thaks for that Lex, but I already have kernel 2.6.26 installed and it doesn't boot either - exactly the same error.


Out of interest I copied rc.sysinit from Mandriva 2008.1 and booted with that instead. (Don't try this at home kids!! :lol2: ) The boot failed at exactly the same section - ie the fsck section (although on the 2008.1 file this is line 676 not 669 although the coding looks very much the same to my untrained eyes).


I don't know if that means anything to anyone.


I will probably have to end up reinstalling my disk image again, but I will leave it open for a few days just to see if anybody comes up with anything.

Link to comment
Share on other sites

maybe it has some problems mounting your root filesystem


what does your fstab look like and your menu.lst ?




you could try to chroot (su && chroot <mdv partition mountpoint> ) into the partition from another distro and do the updates sometimes you need to edit /etc/resolve.conf though to get the connection working (copy booted distros resolve.conf to mdv /etc directory)

Link to comment
Share on other sites

If system started and GRUB loaded press section with name of kernel not section ex. "linux". If you have konsole login (press ESC) type


uname -a



Link to comment
Share on other sites

Well I just don't know what to say about this.


I liked the idea of ffi's suggestion to use chroot, so I did. I then tried to run 'urpmi --auto-update' but all I got was 'no connection' even after I transferred the 'resolv.conf'. I gave up on this, tried booting again and it came up straight away :huh: ??.


So I guess this is solved, although I really have no idea how, and I am almost prepared for it to fall over again next time I reboot!


Anyway thanks for your help.

Link to comment
Share on other sites

Looks like I am not the only one then. Although is running well for me now despite the fact it has KDE4 on it. (it did survive a reboot)!


An interesting fact that I have just found out is that I problably did have internet access through the chroot platform, but in fact the repositories I was using in urpmi.cfg were off line - i found this out when I tried to update it using MCC from within the distro. I changed repositories and this resulted in it pulling in quite a few updates one of which was but now this won't boot!! Anyway enough for one day, I'll stick with 5.1 for the time being.


Thanks again ffi.


EDIT. Correction 5-2.1 does work - I just had a typo in menu.lst.

Edited by viking777
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...