Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sunwatcher

Laptop dvd drives won't mount [solved]

Recommended Posts

I have an HP Omnibook vt6200 with several drive modules: a cdrw drive, a single-layer dvd, and a double-layer dvdrw. I managed to install Mandriva Powerpack 2008 on it with the dvd drive in the slot, but since then I cannot get Mandriva to recognize either of my dvd drives. The laptop powers the dvd drives and spins discs, but they won't mount. The cdrw seems to work fine. Any suggestions?

Share this post


Link to post
Share on other sites

If it's DVD's then install the libdvdcss packages to read movie DVD's. If they are just data DVD's then they should mount fine normally. Otherwise, please post the results from an:

 

lspci

 

so we can see your hardware installed and go from there, as well as:

 

dmesg | grep -i cd

Share this post


Link to post
Share on other sites

I assume that the CDRW is the "main" drive in the OmniBook?

 

My experience is that the main drive is the one that the OS will link the mountable directories to. What I mean is that the CDRW is likely found at /dev/hda or /dev/hdc whereas the DVD drives follows as /dev/hdd or /dev/hde. Most automount utilities or applications will mount the "premier" drive to the /dev/dvd or /dev/cdrom devices. This means that everytime you want to access these devices the PC will almost always go directly to your CDRW.

 

You can modify your /etc/fstab file to point the mount point to your desired optical drive, or you can point the "generic" device name to the device you want. This can be done by something like:

 

umount /dev/dvd (unmounts old device)

ln -sf /dev/hdd /dev/dvd (links your desired dvd device to the generic dvd device link)

 

 

Hope this helps.

Share this post


Link to post
Share on other sites

There are absolutely no fstab entries needed for removable devices anymore... hal will take care of all of them (under /media). Only legacy/ancient applications and a few emulators (like wine) will need these entries.

Whenever you insert a medium, blank or not, the DE notification daemon will popup a warning, and you can pick your action (normally mounting the medium). Since audioCD's are not mountable, you can only mount them using a virtual filesystem, but for all other disk types (coasters excluded) mounting just by having hal running and its rules not screwed is entirely possible.

When you say you have three drive modules you mean hot-swappable ones, which mount in the same laptop bay?

Share this post


Link to post
Share on other sites

Thanks everyone for the suggestions so far. I apologize the late response -- vacation during August. Here are the posts for "lspci" and "dmesg | grep -i cd":

 

[george@localhost ~]$ lspci
00:00.0 Host bridge: ALi Corporation M1671 Super P4 Northbridge [AGP4X,PCI and SDR/DDR] (rev 02)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
00:06.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:09.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01)
00:0a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
00:0b.0 Communication controller: ESS Technology ES2838/2839 SuperLink Modem (rev 01)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY

 

[george@localhost ~]$ dmesg | grep -i cd
hdc: QSI DVD-ROM SDR-081, ATAPI CD/DVD-ROM drive
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
Uniform CD-ROM driver Revision: 3.20
ohci_hcd 0000:00:02.0: OHCI Host Controller
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:02.0: irq 10, io mem 0xe0000000
ide-cd: cmd 0x28 timed out

 

These are with the DVD module installed in the laptop. I installed the latest version of openSUSE, and this read the drives without problems. I would prefer to get Mandriva working though. I am running Mandriva Powerpack 2008.0.

Share this post


Link to post
Share on other sites

It looks like the DVD drive is /dev/hdc. So what you could do is put a CD/DVD in the drive, and then you could do:

 

mkdir /mnt/cdrom
mount /dev/hdc /mnt/cdrom

 

and then take a look in /mnt/cdrom to see if any files are listed. If so, then it's mountable OK, and it's just not auto-mounting properly.

Share this post


Link to post
Share on other sites

Many thanks to the advice so far, but since I had nothing really invested in the Powerpack installation I downloaded and installed Mandriva Spring 2008.1. All drives seem to work now. So my problem is solved, but I do wonder about my Powerpack 2008.0 version. I have it running on several machines with no problems. Anyway, thanks again all.

Share this post


Link to post
Share on other sites

Versions Power Pack differ a bit . You get softwares free but they are with them often problems so I command advanced users or to use from forum .....Lex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×