Jump to content
Sign in to follow this  
BertoldK

PCI:device 00:1f.1 ... resource collision

Recommended Posts

I have successfully installed (clean) Mdk 9.0 on my new PC (Mobo ASUS P4B533-V), and it seems to run properly.

 

But on startup, the first line I get is

 

PCI:device 00:1f.1 not available because of resource collision.

 

Lateron, I cannot see that anything goes wrong.

 

Does anybody know what this device 00 is, and what this message could mean?

Share this post


Link to post
Share on other sites
Guest zete

I am having the same problem on the Asus P4GE-V motherboard (which is the later version of the P4B533-V). I get the exact same error, but my onboard sound does not work. I believe the two boards use a different onboard sound chip.

 

Does your onboard sound work with the error? I am thinking it is an Asus error, and maybe their tech support can help.

 

What other PCI devices are you running? I have a Modem in one slot and a Pinnacle TV Tuner in another. Everything else is onboard (VGA, sound, lan, usb).

 

Zete

 

PS - Anyone else having a similar problem on Asus mobo's?

Share this post


Link to post
Share on other sites

Thanks for your answer.

 

Everything seems to work (at least I could not identify a malfunction), including sound.

 

Does anybody have a clue what this

 

PCI:device:00:1f.1

 

means?

 

Tech support from Asus: I sent them a message and got back a pre-canned answer promising a detailed answer later. Weeks later, nothing more.

 

Does anybody know how to contact Asus to get an answer?

Share this post


Link to post
Share on other sites

You should look at your motherboard manual for the way interrupts are shared between PCI slots and other devices. Unlike ISA boards, most all PCI boards share interrupts with other devices. This sharing goes across all hardware andmost peripherals, such a hypothetical PCI/USB sharing. Whether or not this is your problem, I can't be sure but it is where I would look first.

 

Counterspy

Share this post


Link to post
Share on other sites

Counterspy, thanks for the hint. Indeed, interrupts are shared, this is indicated during the boot process, and the manual has a list of IRQ assignments, some markes as used, some marked as shared. Unfortunately, this is beyond my knowlegde so that I cannot make sense out of it. As everything I need is on board, all 6 PCI slots are empty.

 

Any idea what I could try?

Share this post


Link to post
Share on other sites

I would try to put each of your cards in different slots on their own interrupts where this is possible. Other devices can safely share interrupts but this tends to be a bit of a guessing game. If you have Windows installed, the system information list from the Control Panel can tell you where Windows puts them. The same setup should work with Linux. You could also post what is said in your mobo manual and we may be able to make sense out of it for you. We would need a list of your system in more detail than you have so far in your posts.

 

There is an asus motherboard newsgroup you can post to with this problem as well.

 

Counterspy

Share this post


Link to post
Share on other sites
Guest cinders

One way to free up resources is to disable what you dont use in the BIOS.

eg: If your board is an all-in-one, you probably dont use your serial ports, you may not be using your USB ports, or even your parrallel port, if you dont have a local printer.

Just make certain you dont use them before you disable them. Also in the PNP section of the BIOS, make sure "PNP O/S INSTALLED" is set to "NO", that way you will be presented with all the options.

If you are not comfortable with fiddling with the BIOS, get someone else to help.

Share this post


Link to post
Share on other sites
Guest mad_penguin

Actually, I have the exactly same error message on my Dell dimension 4550 with mandrake 9.0. "PCI: Device00:1f.1 not available because of resource collisions." In addition to this error message, I can't install Maxtor PCI ATA100 card. If I do, my machine goes into Kernel Panic. Relating to this, when I was installing MDK9.0, it complained it can't find the CDROM drive even though I was booting from CDROM drive for installation. It assigns maxtor pci card as hda and didn't find any other drives including CDROM and HDs. So I removed pci card with zip drive and the installation went fine. But I get that error message about the resource collision and I can't install pci ide card.

Share this post


Link to post
Share on other sites

This is bizarre. I have exactly the same error message after upgrading my motherboard/cpu to an Intel D845EBG2/P4(2.53GHz). It must be something in the 845E chipset. I think the Asus board uses this Intel chipset as do most other P4 motherboard manufacturers. I also had identical symptoms as mad_penguin when I tried to use my Promise Ultra 100 PCI controller card. Mandrake 9.0 installer didn't see the on board Intel IDE controller that my CD drive and my CD burner were on. Wound up pulling the card and putting everything on the on board IDE controller and the install went fine except for the resource collission message. I had no problems with Mandrake 9.0 using the Promise card on my P3 motherboard.

Share this post


Link to post
Share on other sites

Did a little further investigation and this is what I found:

 

1. Checked the hardware profile in Mandrake Control Center. The following device is listed as located on the bus at 0:1f:1 - "8280DB 8456/GL Chipset ISA Bridge". The IDE/ATA controller is located on the bus at 0:1f:1;

 

2.Checked the data transfer rate of the hard drives using hdparm -t /dev/hdx and got a low rate of around 5MB/sec. With my old P3 motherboard and the same drives, I used to get over 20MB/sec;

 

3.Checked whether DMA was enabled with hdparm -v /dev/hdx and it wasn't on either drive. DMA was set to zero on both;

 

4. Now comes the wierd part. Tried to enable DMA with hdparm -d1 /dev/hdx and got the following error message;

 

dev/hdb:

setting using_dma to 1 (on)

HDIO_SET_DMA failed: Operation not permitted

using_dma = 0 (off)

 

Has anyone with the collision of resources error message gotten similar results and does anyone have any suggestions on how to enable DMA?

Share this post


Link to post
Share on other sites
Guest mad_penguin

Before I install MDK9.0 , I tried Redhat8.0 and didn't have the same problem on my Dell. So it must be something to do with MDK. I can't find the link anymore but somewhere in Mandrakeexpert, I read someone downloaded and compiled a fresh 2.4.19 Kernel and the problem went away. I 'm guessing he downloaded generic kernel, not mdk kernel ??

Share this post


Link to post
Share on other sites

Thanks for the tip. Checked Mandrake Expert and found the post you referred to. The kernel which fixed the problem is 2.4.19.18. The Mandrake 9.0 kerenel is 2.4.19-16mdk. I beleive Redhat 8.0 is 2.4.18 something. Are you sure dma is enabled in the earlier Redhat kernel with the 845E chipset? Please check using

 

#hdparm -v /dev/hdx

 

I'd like to know before I bother with trying to install Redhat.

 

Thanks for your help.

Share this post


Link to post
Share on other sites
Guest mad_penguin

I actually don't have Redhat 8.0 anymore. I erased it when i installed mandrake 9.0 . But with Redhat 8.0, I was able to install the PCI IDE card. I'm not sure if dma can be enabled in redhat 8.0 though. check out http://www.linux-ide.org/ , it may be useful.

Share this post


Link to post
Share on other sites

When entering URL's in the text of a post, make sure there is a space between the last character of the URL and any punctuation marks. Without the space, the punctuation mark becomes part of the URL and will not access the site. Thank Mystified for this information.

 

Counterspy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...