Jump to content

Recommended Posts

So...apparently even though alsa is (apparently) installed and configured, wine can't see it.

 

OSS isn't providing any sound through wine, and the wine wiki doesn't help at all.

 

Any thoughts about what I can do here? Sound is kinda important to the games I play through wine.

 

Whenever I try to test the sound with the OSS driver, it says sound test failed. Alsa isn't listed at all, and a urpmi of Alsa wants to upgrade my kernel, which I will do if it will help.

Share this post


Link to post
Share on other sites

Make sure you have the task-pulseaudio and libalsa-plugins-pulseaudio packages installed. Open your wine configurator and in the audio tab check if ALSA is being used, then hit the 'test sound' button. If you have no sound, then I would suggest that you disable PulseAudio and try again. Many users have had to disable Pulse to get sound working with wine apps.

Share this post


Link to post
Share on other sites

That's the problem...Alsa's not even listed in the Wine config.

 

Though, with the other problems I've had, I think getting Wine working right is the least of my concerns.

Share this post


Link to post
Share on other sites

After running winecfg, set your driver to either alsa or OSS (whatever available), and under direct sound/hardware acceleration set it as "emulation".

Any better now?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...