Jump to content

ktorrent for kde4


Recommended Posts

anyone gotten a torrent client to work in KDE4?


did the update last night, and the FIRST time I tried to run BitTorrent, the proper ICON ws on the desktop, the application started to load, looked ok, but didnt have my torrent that I'm downloading.


I started to open up the tirrent and an error was generated (something about a file missing from ...\KDE4\.... the app closed and the OCON turned to a ? mark.


So I went to MCC looked, saw one JUST for KDE4 installed it and now it doesnt load at all.


I've uninstalled, rebooted, reinstalled, rebooted, no go


checked the ktorrent site and downloaded the source for their beta ktorrent for KDE4 and when i attempted to use their instructions to build it, got an error that cmake wasnt supported.


anyone gotten this or any other torrent client working in kde4?





Link to comment
Share on other sites

i honestly haven't had the same problem.


KDE 4 was, the last time I checked, still remarkable not functional for me at the time. I hope that will drastically change. I just looked on their site and they just announced the 4.1 alpha1 version. Regardless of release styles for KDE, "alpha" still means early. It does look awesome, but I've had to resist the urge to swap over while I'm finishing some important work.


Will KDE 3 apps compile under KDE 4?



Link to comment
Share on other sites

Will KDE 3 apps compile under KDE 4?

from what i can tell some will some wont.


everything EXCEPT ktorrent seems to work just fune.


interesting sie note, I rebooted last night and up pops ktorrent in all it's glory!


but since i had some work to do under 3.5 I logged out and didnt go back, i'll go back again tonight when i get home.


so far the only thing about KDE4 that I dont care for is the default "Seseme Street" stle icons that come up when you 1st login.


again, I';m sure w/ a little poking around i can change that but, just about everything else works just fine, and quick too!

Link to comment
Share on other sites

What's wrong with ktorrent? The new one runs quite well. It's included in the latest kdemod4 snapshot I was using, dunno about Mandriva, but I guess it should be somewhere there.

You may also give Qbittorrent and Deluge a spin, and of course Azureus.

Link to comment
Share on other sites

Ktorrent just wouldnt LOAD, double click, hourglass for 10 seconds then nothing


launch from root, nothing happens.


then I rebooted and all of a sudden it works./


reboot again, and it doent, rebopot again and......


as long as it works next time I'll try and stick w./ it, otherise i might try qtorrent,


the disk your using, is it the one from LinuxPro magazine?


I have it, just havent loaded it yet.

Link to comment
Share on other sites

Ummm, no. You wont find it in any mag.

Kdemod is an unofficial Arch Linux KDE hack, which includes a modular, bleeding edge KDE4. Most things are working fine right now (including ktorrent), but I cannot really tell which kde4 snapshots they have packaged- they do work a lot with it, and always release whichever snapshot is usable.

QbitTorrent is a fine app, based on a very solid backend (Rasterbar libtorrent). Give it a try.

Edited by scarecrow
Link to comment
Share on other sites

thanks for the reply, I'm still getting inconsistent results inder kde4 and bittorrent.


I have a copy of LinuxFormat 104 and they included a DVD w/ a "bootable" kde4 installation.


but i understand with publishing lead times etc it was probably put together in january.


I'll have to look for qbittorrent, it didnt show in repositories

Link to comment
Share on other sites

mindwave: I've merged your latest post into this thread, as it's a continuation of the same discussion. :)



thanks, hopefully it will generate some more responses.


because NOW, I get the error that I last posted, BUT if I clear the error Bitorrent SEEMS to load, EXCEPT that the search function genrates an error (sorry i didnt catch that one before I left this am).


I havent actually tried dloading a torrent yet, that may come this weekend.



Link to comment
Share on other sites

FYI qbittorrent does have an unofficial Mandriva repo:

urpmi.addmedia qbittorrent http://hydr0g3n.free.fr/qbittorrent/mandriva with hdlist.cz

Just checked, and it's not in the regular Mandriva repos, while the above unofficial repo still has packages only for 2008.0

You might compile it from source, but it's not that trivial (for Mandriva, anyway).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...