Jump to content
Sign in to follow this  
Fanless

Sysinfo does not work any more

Recommended Posts

Hi,

 

I don't know following wich operation, but since a while the sysinfo command does not work any more on my mandriva 2008.

 

Here is the message (sorry, in French, I have not the translation)

Un problème s'est produit lors du chargement de sysinfo:/ :

Le processus traitant le protocole sysinfo s'est arrêté de façon inattendue.

I tried to install again KIO-sysinfo package, but doing that a large amount of packages were uninstalled (amarok, kde, and so on), and I spent a lot of time to restore my computer in a working situation.

 

But after that, sysinfo is still not working.

 

is there any log file where sysinfo could tell me more about what is missing or wrong ?

Share this post


Link to post
Share on other sites

What are you trying to do exactly? What results are you looking for? If we know what you're trying to achieve, maybe we can suggest alternatives.

Share this post


Link to post
Share on other sites

sysinfo has been working at the beginning I installed mandriva on this machine, it's not a vital part of the machine, but I don't like having something having worked but no more working, meaning that something is wrong in the configuration (or in my actions)

sysinfo is supposed (I don't remember the screenshot) to give informations on the machine (processor, speed, memory amount and so on)

 

it's not exactly alternatives that I would like, I would be happy to know why it does not work ...

 

:huh: if sysinfo does not work, maybe other things will not work in the near future ...

Share this post


Link to post
Share on other sites

an approximate translation (I do not know french, I used an online translator) of the error message:

A problem occurred during the loading of sysinfo: /:

The process treating the protocol sysinfo stopped in an unexpected way.

I would suggest uninstalling and reinstalling the sysinfo package to see if that resolves the problem.

Share this post


Link to post
Share on other sites

Ok for translation.

I already installed again sysinfo package (KIO-sysinfo if I believe) but it's the same message, it does not work better.

Share this post


Link to post
Share on other sites
I already installed again sysinfo package (KIO-sysinfo if I believe) but it's the same message

Are you sure that the app you're having problems with is not KinfoCenter? It is located at Tools > System tools > KinfoCenter. You should be able to check it with the cli using

kinfocenter

Share this post


Link to post
Share on other sites

no, kinfocenter works well, all the menu commands work.

sysinfo command is called with konqueror : sysinfo:/

(it's a linux system function too, the purpose is to show the memory statistics as says the help for 'sysinfo')

Share this post


Link to post
Share on other sites

I understand now. With Konqueror closed, in a terminal (as user) try

kfmclient openURL %u application/x-sysinfo

You will probably receive an error message at first, but in a few seconds it should open for you. Let us know if that works?

Share this post


Link to post
Share on other sites

hi Greg,

when I launch the command as you describe in a terminal as user, it says, in a konqueror window :

Un problème s'est produit lors du chargement de file:///home/jean-luc/%u :

Le fichier ou le dossier /home/jean-luc/%u n'existe pas.

which can be translated as :

A problem occurred during the loading of file:///home/jean-luc/%u :

File or directory /home/jean-luc/%u does not exist.

(if I execute it as user, /home/jean-luc is replaced by /root but the result is the same)

and after a few seconds, another message comes, the same as the one I gave in may first post.

the terminal window shows:

kio_sysinfo: *** Starting kio_sysinfo

kio_sysinfo: (/org/freedesktop/Hal/devices/volume_uuid_db24d686_6636_4b9b_bfe4_9870c444ef62,sda1,97G Media,,true,/dev/sda1,/,ext3,true,,media/hdd_mounted,,---)

kioslave: ####### CRASH ###### protocol = kio_sysinfo pid = 6356 signal = 11

I tried the same thing under KDE4, but it's the same.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...