Jump to content

Dell Inspiron volume buttons

Guest nortononsax

Recommended Posts

Guest nortononsax

I'm running Mandriva 2008.0 on a Dell Inspiron 6000, and want the volume buttons to work. I've got the mute button working, but the volume up and down buttons change the Master MONO in KMix, not just the Master Volume-- and that just doesn't do anything.


Any ideas on how I can get these buttons set up with the correct function?

Link to comment
Share on other sites

Well, I get the lovely broken 0% stuck-on-screen volume OSD with kmilo and klaptop, so I had to set things up myself. Here's what I did to get these 3 keys working on my Inspiron 5100:


1) Use xev to find the keycodes. Run the command, mouseover the box, and press the keys.

2) Make those keys known with xmodmap. Here's my $HOME/.Xmodmap file, though your codes may differ:

! Volume Up
keycode 176=F20
! Volume Down
keycode 174=F21
! Volume Mute
keycode 160=F22

3) Add a little $HOME/.kde/Autostart script to set the keys. Make sure to mark it executable. Run it to ready the keys; KDE will then run it on start from now on.

#! /bin/sh

if [ -f $HOME/.Xmodmap ]; then
/usr/bin/xmodmap $HOME/.Xmodmap

4) Go into KMix -> Settings -> Global Shortcuts and set your keys there.


Voila. Working volume fn-keys made from scratch. :)


Idealy, all this would work by default... but that ain't happening at this rate.

Edited by DaveG
Link to comment
Share on other sites

I had almost the exact same problem. And I did a much easier solution. All I did was switch the main audio channel to "PCM" (right click kmix, select master channel, click PCM). DIdn't change anything right away, but I'm pretty sure that is what fixed it because my next restart the volume buttons changed the PCM instead of mono, and PCM is like your global wave sounds or whatever, so it works great.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...