Jump to content

Latest version of Opera problem


Recommended Posts

I just installed Opera 7.11 and everything on the screen is really small and hard to read. I tried both the static and the shared version. I didn't have this problems with the beta or any previous release of Opera. Any ideas?

Link to comment
Share on other sites

hmm, funny, i had this problem with the 7.11 B2 version.


I first had to set the minimum font size in Opera to 12 or 14, file --> preferences --> fonts and colours.

After that to copy some ms fonts (arial, verdana, geogia) to my mandrake fonts directory, initialising these fonts in kde control center. And now it looks fanatastic.


Didn't tried the final yet, sorry that I can't help more ...

Link to comment
Share on other sites

Thanks! Unfortunately though I haven't been able to resolve the problem. The browser window is easy enough to fix but it's the toolbar that's giving me headaches. I'm back to using the beta version but that's okay cause it works fine for me! :)

Link to comment
Share on other sites

  • 2 weeks later...

Here's a potential fix published by a fellow on alt.opera.linux (Helmar Wieland)


How i solved the small fonts problem:


* Traditionally X assumes that your monitor has 75dpi.

* Windows standard, and thus most monitors follow it, is 96dpi.

* Find out your settings with: "xdpyinfo|grep dots"

* If your settings are around 75x75, XFree 4.x offers a nice

  way to correct this:

* Add (or change) the following entry in "/etc/X11/XF86Config-4",

  Section Monitor: "DisplaySize 365 272"

* The values are your physical screen size in millimeters (xxx 

yyy), the

  above are for my 19inch monitor.

* Save and restart X.

* If you want you can check the new dpi setting of X

  ("xdpyinfo|grep dots")


Since i added this option my fonts look perfect.



Link to comment
Share on other sites

Yes, the 75dpi fonts are a joke, I always use the 100dpi fonts (17" monitors and up have a physical resolution of greater than 100dpi). Here are the physical dimensions of my 17" monitor that I use in XF86Config-4 file:


# ViewSonic P775

   DisplaySize 320 240


Note that this is my actual physical viewing area and doesn't include the black borders of the tube. Also note that now if I zoom to 100% in a document in staroffice, that the ruller will just about match a physical ruler that I hold up to the screen (my screen measurements are not that precise).


One word of caution is in order. After you make the switch, all your fonts may default to A.D. Mono (A truly horrible looking font) since the 75dpi font settings are no longer valid and that is the first font on the list. You will have to reselect all your fonts if this happens.



Link to comment
Share on other sites

Kind of interesting... I checked my info and it was 72 x72 then I added in the screen size as suggested and restarted X. With the new settings from my Viewsonic E53 monitor manual I got 71 x 71!!! :roll: So I went back to my old settings. What's up with that I wonder?


This is a 15 in. monitor and to make things decent, I stuck with 800 x 600 resolution. It doesn't looks as sharp as I would expect though. My 15 in laptop screen is way better looking. :-)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...