Jump to content

1920x1200 Screen Resolution in Gnome?


Recommended Posts

Using the Screen Resolution Preferences control panel (System->Preferences->Screen Resolution) I'm not able to configure the Gnome screen resolution to match the resolution of my Dell 2407WFP-HC flat panel monitor (1920x1200). The Screen Resolution Preferences control panel only offers...

  • 1024x768
  • 800x600
  • 640x480

...though the X.org control panel (Mandiva Control Center->Hardware->X Server) recognizes the nVidia GPU and configures X.org to support 1920x1200 resolution:


Section "Monitor"
Identifier "monitor1"
VendorName "Dell"
ModelName "Dell 2407WFP (Digital)"
HorizSync 30.0-83.0
VertRefresh 56.0-76.0

# Monitor preferred modeline (60.0 Hz vsync, 74.0 kHz hsync, ratio 16/10)
ModeLine "1920x1200" 154 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync

# Edited for clarity

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"
Driver "nvidia"
Option "DPMS"
Option "RenderAccel" "false"
Option "AddARGBGLXVisuals"
Option "IgnoreEDID" "1"

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
	Depth 8
	Modes "1920x1200" "1680x1050" "1600x1000" "1440x900" "1280x800"

Subsection "Display"
	Depth 15
	Modes "1920x1200" "1680x1050" "1600x1000" "1440x900" "1280x800"

Subsection "Display"
	Depth 16
	Modes "1920x1200" "1680x1050" "1600x1000" "1440x900" "1280x800"

Subsection "Display"
	Depth 24
	Modes "1920x1200" "1680x1050" "1600x1000" "1440x900" "1280x800"

FWIW: Though the nVidia control panel (System->Administration->nVidia Display Settings, ver. 1.0-9639) recognizes the GPU and the monitor correctly, it only offers three more display settings than the Gnome Screen Resolution Preferences control panel:

  • 1280x1024
  • 1280x960
  • 1280x800

How can I make Gnome use the corect resolution?


Link to comment
Share on other sites

Can you set your resolution at 1920*1200 using


If you can run it and set up your display like that, then all you need to do to have 1920*1200 at next login is put at your Gnome startup applications the following:

nvidia-settings --load-config-only

The Gnome admin modules have never been terribly reliable.


BTW your xorg configuration looks OK- just get sure that there's nothing activating DRI in there.

Edited by scarecrow
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...