Jump to content

Bluetooth Internet via mobile phone [solved]


Recommended Posts

I recently bought a new mobile phone (SonyEricsson k610i) which is bluetooth enabled and I would like to use it as a modem for my laptop, but I can't seem to get it working. I can transfer files using bluetooth and I can even use the mobile as a remote control for certain apps like media players - neither of these I have the remotest interest in doing, but getting the modem functionality is something I would dearly love to do and I can't.


Drakconnect correctly identifies the device and I have set up the correct apn, username and password. When I press connect, I get a popup on the phone saying the computer is trying to use the phone as a modem and will I allow it. I press 'yes' there is a pause of a few seconds whilst it attempts a connection and then the bluetooth drops out and that is the end of it, I can't get any further.


Does anyone have any ideas?


PS I forgot to say that I have purchased a top up to allow me to use mobile broadband and I have 1Gb of data allowance waiting for me to use, and also I have an acceptable signal where I am (I can surf the internet via the phone).

Edited by viking777
Link to comment
Share on other sites

Since the phone is recognizing the connection it can only be a setting error. Are you dialing the right command? On my network it is *99# which is quite common, but they have additional points set up at *99***1# and so on.


Also, set your computer as a trusted device on the phone. This means you won't have to authorise the connection every time and it might iron out the initial connection problem too.


You could also try alternative dialers, such as wvdial which I have found works very well.


The modem script might be a problem too. Have you Googled around about your exact phone and its use in Linux?

Link to comment
Share on other sites

Thanks for the reply SoulSe. I don't think the settings are wrong because I use them on another device (same provider) and they work OK there, and I have already tried setting the phone as a 'trusted' device and that doesn't make any difference. I must admit I was trying to avoid the likes of wvdial as it is such a pain to set it up correctly, but I have used it in the past so I suppose I could again if I get desperate enough! Drakconnect is one of the best features in Mandriva, one of the reasons I use it as my default distro, and since it has worked with USB connected modems then I think it should with Bluetooth ones as well.


Yes I have Googled, of course, and one of the lines of enquiry that I am thinking about now came from that source. Apparently there are several services that need to be running to make a bluetooth connection work, two of which are 'dund' and 'pand' (dialup networking and personal area networking for bluetooth). Both of these services exist on my system but neither of them will start, either automatically on boot, or manually from a terminal and I think this is why I can't get a connection. Unfortunately, so far I haven't worked out how to make them start. You wouldn't have any ideas on that would you?

Link to comment
Share on other sites

If I knew how to I would mark this thread as solved. The solution was much easier than I expected and as SoulSe suggested it was just to do with phone settings. This is how I solved it in case anyone is interested.


Go to sonyericsson.com/support, choose your region and then choose your mobile model. Click the link that says 'Mobile Internet(WAP)' ,then enter your country, operator, phone model again, and finally your telephone number. Then wait. It took 7 hours before I got a response (which is probably why it didn't work the first time I tried it - I gave up to soon). It doesn't say this and I don't know it for sure, but I think you need to leave your mobile on during that time. Eventually a new set of settings will be uploaded to your mobile. You don't get the chance to read these only to apply them or not, but since you asked for them I would say it is pretty safe to apply them which is what I did. I then searched through the phones settings to see what had changed. It quickly became clear that under the heading 'Data Accounts' I now had two entries where before there was only one. I selected the second entry (called 3UK instead of just 3) and tried the connection with kppp using the settings that I have been using all along and the connection worked straight away. :thumbs: :thumbs: , I am using it to post this.


Strangely though it wont (as yet) work with drakconnect only kppp. This again must mean that there is a setting somewhere that is wrong in drakconnect. I know for sure that every time I configure the connection in drakconnect it changes the phone number in etc/sysconfig/network-scripts/chat-ppp0 to the wrong one, but no matter how many times I alter it to the right one it changes it back again. TBH I am not sure where else drakconnect gets its settings from (it cant be wvdial because the settings there are correct). Anyway that is small beer, the main thing is that I now have a bluetooth modem and I can start using up some of the credit that I bought for it!!


Happy bunny :D

Link to comment
Share on other sites

Now it really is solved, I thought Mandriva wouldn't let me down. I had an incorrect init string, all I needed to do was to remove the line causing the error from etc/sysconfig/network-scripts/chat-ppp0 (and change the telephone number - again) and now it connects with drakconnect as well.


I haven't dared reboot it yet though :lol2:

Link to comment
Share on other sites

Just a word of warning in case anyone else should happen upon this post and find it useful. After a couple of days of perfect operation I switched on this morning and got absolutely nothing, no connection at all. A bit of investigation into this led me to find out that for some reason the device node for the mobile phone modem - (which Mandriva creates automatically when the dongle is plugged in :thumbs: ) had changed from /dev/rfcomm0 to dev/rfcomm1, necessitating a brief reconfigure of wvdial.conf in order to get a connection. I have no idea why it has done that or if it might change back again in another couple of days but it is one thing to check if you suddenly lose a connection. You can check the node created by typing


rfcomm -a

in a terminal.


If you are unfortunate enough to be using a less capable distro you can create your own node with


rfcomm bind rfcomm0 00:1B:18:28:42:33 1


Substitute your own modem address for the one above and the '1' on the end assumes that your phone modem uses channel 1 to communicate on. I have to say though that using this method (ie on Ubuntu which for reasons best known to itself does not create the nodes automatically) I have not had much success.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...