Jump to content
Sign in to follow this  
vinnywright

auto mounting

Recommended Posts

Well I got MCNlive-toronto installed after 3 try's ( the boot loader wouldent take.) and most every thing seams ok so far. I had to add my NTFS partition to fstab,mtab befor I could acses it. but now it's under /mnt/windows.

 

when pluging up a USB or puting a cd in I get the eror

 

Cannot create link /etc/mtab~ Perhaps there is a stale lock file?

 

humm the cd just mounted the 2'ed time (not usb) but now I get this when trying to unmount.

 

umount: /media/cdrom is not mounted (according to mtab)

 

and hears 1 more querk I ejected the cd manualey and placed a diferent cd in the tray. The cd was acsesabl but the name of the cd stays with the preveus cd?????????????? that is the name of the cd icon in Konqueror!!!

 

 

eney Ideas??

 

 

VINNY

Share this post


Link to post
Share on other sites

well I looked around the forum a bit and used the MCC to set the NTFS partition as user acsesable (A little hard to diside how this was done and it turned out to be the partitioning tool that did it ) and after a reboot. All is well. :D

 

Some how the auto mounting problems disapeard after the reboot?????????? :unsure:

 

:) Be back with more as I get in trouble :P -----------

 

 

 

 

VINNY

Share this post


Link to post
Share on other sites

Well I found an update tool in MCC and it sead thare were 193 update's wating for me so I sead ok. :)

 

I gess it wint ok :unsure: it was to easey for a linux update------ :lol2:

 

VINNY

Share this post


Link to post
Share on other sites

OK I give how do I change root password?-------------------------------------------

 

and it seams as though adding a user create's some problems. xine wouldent work for the user.--------a root wusent on the list of users one can modafy.

 

O and how do you give cdrecord root permitions K3B sead it neands to run as root.???

 

 

 

VINNY

Share this post


Link to post
Share on other sites

To change password for root, simply open a root console and type in

passwd

Rest is self-explicable.

Whenever you create a new user by "adduser foo" you need to include that user in certain groups ( e.g. audio, cdrom, storage, hal, mpd, wheel... you can name some more here) to grant him permissions for using block devices, optical drives, and certain type of hardware AND software/commands. Else, access to them is disabled by default, for security reasons. After adding the user to any of these groups, you need to log him out and then back in to make changes valid and permanent.

Edited by scarecrow

Share this post


Link to post
Share on other sites

OK all passwords set

 

However k3b is still complaning about cdrecord not having root privaleg--------hear is the eror----------------

 

cdrecord will be run without root privileges

It is highly recommended to configure cdrecord to run with root privileges. Only then cdrecord runs with high priority which increases the overall stability of the burning process. Apart from that it allows changing the size of the used burning buffer. A lot of user problems could be solved this way. This is also true when using SuSE's resmgr.

 

on the other distro I use k3b has a setup to fix this. is this an older relece of k3b????

 

O and yes now the user acount is acting beter after adding some grops (all of them) and a reboot ;)

 

 

VINNY

Share this post


Link to post
Share on other sites

The k3b error message can be SAFELY ignored, as long as your user belongs to the "cdrom" group in Mandriva (in other distros it has a different name). Some time ago running cdrecord with non-root proviledges was meaning reduced performance, and for that reason K3B was creating a special "burning" group. However, you do NOT have to do anything currently- just ignore that message.

Actually this error message has been removed in the last K3B versions as default when compiling.

If you want to "disable" it, you CAN set cdrecord running suid root, but this is definitely not a very clever thing to do!

Edited by scarecrow

Share this post


Link to post
Share on other sites

Logically they are installed, but just in case:

urpmi cdrkit cdrdao dvd+rw-tools

Now open "kuser" and get sure your current user belongs to the "cdrom" group. If it isn't, put him in, and then logout and back in.

If that message bothers you that much, open K3B settings and pick cdrdao as default for burning CD's (although it can't be used for DVD's).

Share this post


Link to post
Share on other sites

nope the urpmi line ubove reterned ( allreadey installd )

 

my user is in the cdrom group and still no burning joy.

 

perhaps this ver. of k3b dosent like my burner my coppy of toronto is using k3b-1.0.1svn on KDE-3.5.6

 

The distro on my baner below ultimalinux8.3 was using k3b-1.0.4 on KDE-3.5.8 ----and it worked fine !!!! in fact it's wat I burned the MCNlive toronto .iso with. so eather this ver of k3b dosent suport my burner OR somthing's not quite set right yet.

 

VINNY

Share this post


Link to post
Share on other sites

"k3b-1.0.1svn" means it is a beta release (actually- not a release at all, just a subversion snapshot).

This shouldn't be included into ANY "production-ready" release. Why it was included? better ask the MCNLive developer...

Share this post


Link to post
Share on other sites

Humm well aaaa it would apear as though the problem with k3b was actualey a problem with my old a** hardware :unsure: I tryed to burn somthing agin after coming home from an outing with the motherinlaw (bingo) and it burnt fine. :P

 

perhaps it was fealing sorey for me :lol2: ---------------- after thinking about it for a wile (3 howers of bingo) I seam to remember this drive being tempermental befor!!!------------------------------------ witch is why it was on the shelf to begin with.

 

I just put this box together from 3 old boxes and some spare parts for testing diferent OSes and sutch.

 

and speeking of testing this one isent to bad even for a noob like me. ---MCNLive-toronto that is every thing seams to work ok I'm kind of likeing it. :D

 

it's runing ok on a old 533MHz PIII katmai with 320Meg's of RAM and a ATI 3D rage 128 vid card. :lol2: :lol2:

 

 

VINNY

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...