Jump to content

problems w/phpwebsite


Recommended Posts

ok, i've tried both downloading the "source" (tar.gz) file and installing that, and also doing the command line:

lynx -source http://phpwebsite.appstate.edu/install | sh

and i get this error when i attempt to access <web address>/admin/ to set things up:

Warning: file_exists() [function.file-exists]: SAFE MODE Restriction in effect. The script whose uid is 0 is not allowed to access /var/www/html/conf owned by uid 72 in /var/www/html/index.php on line 136

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/index.php:136) in /var/www/html/index.php on line 141

After checking file permissions, I see that the conf dir is owned by apache, but this is intended. changing it to root allows me to do certain things, but I still run into other issues which I think may all come from this one point. anyone out there work w/phpwebsite and get past this point successfully? *looks in the direction of paul*

Link to comment
Share on other sites

i did this:

sh setup/NONROOT_secure_phpws.sh setup

because you have to choose either setup or run, and from the instructions I want setup.


I got this:



Note: This script is for those without root access to their web servers.

If you have root access, use the other script. It is more secure.


chmod: failed to get attributes of `*.sh': No such file or directory

chmod: failed to get attributes of `../conf/': No such file or directory

chmod: failed to get attributes of `../images/': No such file or directory

chmod: failed to get attributes of `../files/': No such file or directory

Permissions set! Ready to run phpwebsite setup!


doesn't seem quite right. now, i tried running NONROOT_secure_phpws.sh from withing the setup directory, but I still am having issues. I'm half tempted to just give up.

Link to comment
Share on other sites

Thank goodness.. I thought it was just me who cannot install this program. If I did it as root at least I can go to the menu but it doesn't want to save. If I did it as user, it has that same permission problem.


Too bad though, since I wanted this one better than phpnuke. It seems to be better organized.

Link to comment
Share on other sites

well untarred the phpwebsite .tar.gz then I created the db then I run the NON_ROOT setup script from within the phpws dir and it worked .....

do those directories exist?

maybe you haven't un tarred in the correct place or something

Link to comment
Share on other sites

untarred everything into /var/www/html


even if i manually modify and create all the directories, in the end when i try to open index.php it sets there for a while and eventually tells me the document contains no data.

Link to comment
Share on other sites

Add another user that can't get this to run.


Have apache, mysql, php, all up and running fine with other sites.

Have untarred the files in /var/www/html/mub/

Have installed php-pear.

Tried running both scripts mentioned here.


I am thinking maybe something else needs to be installed (like mod_pear or something) or a line needs to be added/changed to php.ini. I got half way through searching the forum at sourceforge went they went down for maintenance today.


My problem is I can't connect to database after filling in the config setup page. I have setup a new mysql database using webmin.


Any ideas here?

Link to comment
Share on other sites

WooHOO, I finally got this to run. After searching for ideas on a sourceforge bb, here's what I did. Remember that I already had apache 2.0.44, mysql 4.0.11a, php 4.3.1, and webmin successfully running on my machine.


1. Untar file phpwebsite-0.9.1-full.tar.gz archive into your web directory (Ex: /var/www/html/mub2) (I use subfolders to separate each website at my IP).


2. Create new mysql database using webmin (without any data or tables). (I named this "mub2")


3. Copy /docs/sample.config.php to /conf/config.php and edit for your setup. My config has these lines (exactly as shown):

	$dbversion = "mysql";

$dbhost    = "localhost";      /* Database Host */

$dbuser    = "root";  /* Database User Name*/

$dbpass    = "";  /* Database Password */

$dbname    = "mub2";     /* Database Name */

// $table_prefix = "phpws_";

$source_http = "";

$source_dir = "/var/www/html/mub2/";


4. Set permissions for all files to "777"

cd /var/www/html

chmod 777 -R ./mub2


5. Hopefully you can now access your new phpwebsite in a browser and it will ask you to set up your admin's user account.


6. Set permissions again for a more secure site by running script in /setup.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...