Jump to content

Help - symbol lookup error [solved]

Recommended Posts

I haven't been able to Google my way out of this one. Instead of duplicating it here, please read my post on Mandriva Club forum:




Let me know if you have any ideas or need more info. Anything might help. Many thanks!


Update: Did some more research and posted a little more diagnostic info. To anyone reading this, thanks for checking this out.

Edited by Crashdamage
Link to comment
Share on other sites

An 'undefined symbol' error usually means that you are trying to use an incompatible binary. Some of the most recent software that you have installed is not compatible with your system. It was built with a different version of gcc and or compiled against a different version of glibc... It won't work. Maybe you can update, or compile a compatible version of libssl, I'm not sure?

Link to comment
Share on other sites


I've got stuff installed from who-knows-where. I never had any problems this serious before because I was just careful with rpm and urpmi. Always did --test, etc. Didn't get stupid with updating glibc or other core system files. Never ran auto updates. A dirty little Linux secret is like Windoze, updates are not always a Good Thing. Messages boards are always full of borked installations from updates. Worked great too keep the latest versions of stuff like OpenOffice, Firefox, etc installed for years. I'm borked now, but I may still find a way out. I can't believe it's a big deal to fix if I can just figure out the exact problem.


In the meantime, I can still do 90% of what I need and I've got my laptop for the rest. Most stuff works as good as ever and I'm not worried about losing anything. So I'll let this ride for a while and see if I can come up with a save.



Most times I'd agree with you and hang my head in shame. But read the post I just added in the Club forum. The problem seems somehow connected to the openssl package, but I've never changed it. Besides, everything should be back as it was, but obviously *something* isn't. Question is what...

Link to comment
Share on other sites

Whether you intended to or not, you've inadvertantly upgraded OpenSSL. Just downgrade to the last available OpenSSL RPM for 10.1 (not sure of the name, it'd either be libopenssl or just openssl)


Whether or not you think you've changed an openssl package, the .so library from it has been changed and needs to be reverted. It's the only common denominator between the affected packages. mutt definitely doesnt even link to X, let alone one of freetype/gtk/pango.

Link to comment
Share on other sites



Actually, you're partially right. While I hadn't changed openssl in a long time, a better look showed that in Feb 2005 I had upgraded to a 10.2 versions for both libopenssl and openssl (and libopenssl-devel). I didn't change them when I did the attempt at Firefox3 so I didn't think that was it, but you were right they'd been updated.


So what the heck, I figured worth a try since those packages and libcrypto seem to be somehow involved in this. I --force installed 10.1 versions for all those packages and made sure none of the newer package files got left behind. No help. In a fit of ugly Win-ape behavior I even did another reboot to make sure all stars were properly aligned, I guess. No good, same symbol error. Earlier I'd tried manually replacing all the files from those packages from backups. No good. At least nothing else seems to have broken fooling around.


Something else is causing this illness and apparently a none of the doctors have a correct diagnosis. I've got hints from people that have steered me in a general area but no cure.


A good thought. But no prize. Thanks anyway.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...