Jump to content

Can't hibernate laptop


Recommended Posts

Ok, I initially asked for help on Mandriva's official forum, but I've been waiting for some sort of help for three and a half weeks now, so I thought I might as well try here.


Link to other thread


Here's the gist:

  • Mandriva 2008 One install on a Dell Inspiron 5100 Laptop. (multi-boot with Linux, Windows, and Dell diagnostics all listed in GRUB)
  • Currently using kernel with the virtualbox and fglrx modules.
  • KPowersave is installed and seems to function, however the power button, suspend button (fn+F1), and lid close sensor all don't work. (I've hacked the volume fn keys into working with Xmodmap)
  • KLaptop does not work. Installing it causes the volume to try to fade to 0, and forces the OSD onscreen at all times.
  • "Suspend to RAM" does not work. It stalls trying to resume. (may be an fglrx issue; don't really care about this one working or not)
  • "Suspend to disk" does not work. It seems to suspend ok, skips GRUB on boot, but does not resume.
  • I always get the following in the boot log:
    No resume device specified
    Trying userspace resume from suspend.conf file
    No resume device in suspend.conf

  • Via a websearch and /usr/share/doc/suspend/HOWTO I'm told that in /etc/suspend.conf "resume device" should be set to my swap partition. (/dev/hdc6 in my case) This destroys my swap partition, and requires me to reformat it to get it working again.
  • Boot-up and shut-down times are not that bad, but I would just like to be able to hibernate this thing like a sane person again...

I'm trying to get a straight answer: What are my /etc/suspend.conf settings supposed to be?


If you had to jump through hoops to get this working, what hoops were they? If your install has working "suspend to disk", what are the contents of your /etc/suspend.conf file? If "resume device" is in fact supposed to be the swap, then what the hell is going on here?


If any of this is somewhere out there and I just don't know where to find it, please post a link.



[moved from Software by spinynorman - welcome aboard :)]

Link to comment
Share on other sites

Hey DaveG,


You're not the first person out there with tons of suspend issues. I've got a Latitude D620 that doesn't work the way I want it to. :-(


What is the hardware in your computer? Certain hardware combinations don't always work well and kernel boot options often help this immensely. You may be running software that you don't need. My wife's older 5150, for instance, doesn't require the CPU throttling software since the P4's at that time didn't have the ability to run at slower speeds.


You can always try 'pm-suspend' from terminal and see if your machine suspends. Shut the lid and then see if it un-suspends when you open the lid. It should! There may also be particular Hal 'suspend quirks' for your model. You should definitely go take a look at http://people.freedesktop.org/~hughsient/quirk/ and see if there are ways to fix your lappy. Another good place to look is http://linux-laptop.net/. There is probably someone out there with your exact problem and exact laptop who may have already fixed it.


Kpowersave is great for me while the computer is running. It really helps to squeeze every ounce of life from my battery. KLaptop is KDEs interface to daemon modules (ACPI) and is now obsolete. Kpowersave is their replacement. It reliably handles CPU throttling, monitor brightness, and hard disk speed for me. KLaptop never did. Suspend to disk doesn't work well for a lot of Dell owners (in particular from what I've read, anyone can correct any of this at will!). Whenever I suspend to disk, it's a complete disaster resulting in me just rebooting my machine anyways.


Good luck with all of this and keep us posted. We all try to chip in from time to time, but it's not always easy, so just stick around. This is a really great and helpful board.

Link to comment
Share on other sites

[dave@localhost ~]$ lshal | grep system.hardware
 system.hardware.primary_video.product = 19543  (0x4c57)  (int)
 system.hardware.primary_video.vendor = 4098  (0x1002)  (int)
 system.hardware.product = 'Inspiron 5100'  (string)
 system.hardware.serial = '14GQ831'  (string)
 system.hardware.uuid = '44454C4C-3400-1047-8051-B1C04F383331'  (string)
 system.hardware.vendor = 'Dell Computer Corporation'  (string)

My graphics card is an ATI Radeon Mobility 7500 with 16 MB of VRAM. I have 512 MB of RAM in this thing; 1024 MB on a good day, if it feels like detecting the other stick...


I've been trying out the Sleep Quirk Debugger with no luck. Via pm-suspend or KPowersave's menu, I get the same result; stall on resume. (which, as I said, may be an ATI/fglrx issue, and I don't really care if this works, though it should) I've noticed that my 20-video-quirk-pm-dell.fdi file was missing my model, so I updated it and rebooted, but when I "lshal | grep quirk" I get nothing. I don't think it's using the fdi files... On the more pessimistic side of things, linux-laptop.net has a bunch of install reports saying that no one has gotten suspend/hibernate to work on this thing.


On a side-note, KPowersave seems to work quite well, and says it's throttling the CPU speed just fine. Though, I'm usually plugged in, so battery life isn't really an issue, but heat very much is, and anything that can lower its strain is a good thing for me. Also, monitor brightness works fine natively via the fn-keys, with no need for configuration. That at least seems to be directly handled by my BIOS.


Now, I'm already getting more to go on here, which is great, but I still don't have a concrete answer on what my suspend.conf settings should be. Should my "resume device" really be set to my swap partition? I need to know if the error is in the settings or in how the settings are used.



Thanks for moving this to the appropriate forum.

Edited by DaveG
Link to comment
Share on other sites

yes, the resume device should be your swap partition; at least if you want to have a working Suspend-to-Disk, for Suspend-to-RAM you don't need such a thing

Link to comment
Share on other sites

that is a good question, this is definitely not normal


I did not need to configure anything on my notebook


normally you just have to make sure that your swap partition is at least the size of your physical RAM (afaik recommended is 30 % more than physical RAM) for Suspend-to-Disk

Link to comment
Share on other sites

I've finally fixed it!


I got around to futzing with this again today, and I've finally found the solution. Basically, the "resume device" parameter in /etc/suspend.conf is crap; it must be specified in /boot/grub/menu.lst instead.


only enabled options /etc/susped.conf:

compress = y
splash = y

relevant entry in /boot/grub/menu.lst:

title Mandriva Linux
kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=Mandriva_Linux root=/dev/hdc5 splash=silent vga=791 resume=/dev/hdc6
initrd (hd0,4)/boot/initrd.img

(where vmlinuz and initrd.img are symlinks to the files for my kernel, in this case, and my swap partition is hdc6)


After booting into the above GRUB entry, I can then hibernate via KPowersave's "suspend to disk" without any issues. My swap partition is not damaged with this setup.


I do notice some graphical glitches on resume, just before the password prompt, however they don't seem to be of any consequence. Also note that specifying "compress = y" in /etc/suspend.conf is a definite must, as it noticeably speeds up the resume time.


Oh, and "suspend to RAM" still doesn't work, but I don't use it so I don't care.

Edited by DaveG
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...