Jump to content

Problem with Installing PHPBB


Recommended Posts

I've run into a roadblock installing phpbb on my machine. I'm running Mandrake 9 and have webmin, apache, mysql v3, php installed. While I know linux a bit, I'm a newbie when it comes to messing with servers.


1. I downlaoded PHPBB and installed it into /var/www/html/phpbb.

2. I created a database mub with mysql and granted my user mryan all access rights to *.*.

3. I go to https://localhost/phpbb/install.php (note the https) and fill out the form, clicking Install

4. I get the following message...


phpBB : Critical Error


Could not connect to the database


The values I used to fill out the form are:


Default board language: English

Database Type: MySql 3.x

Choose your installation method: Install


Database Server Hostname / DSN: localhost

Your Database Name: mub

Database Username: mryan

Database Password: password

Prefix for tables in database: phpbb_


Admin Email Address: highnoon@rochester.rr.com

Domain Name: spookhouse.com

Server Port: 443

Script path: /phpbb/

Administrator Username: cannonfodder

Administrator Password: password

Administrator Password [ Confirm ]: password


Any clues? Want to get going on learning PHP, but need it working first..

Link to comment
Share on other sites

out of curiosity try running this:

(save as whatever.php)


$link = mysql_connect('localhost','mryan','password') OR die(mysql_error());

$mysql_select_db('mub',$link) OR die(mysql_error());



I dont know how descriptice phpBB errors are, that should tell you more if your user can actually connect, or if it is the db not being selected

Link to comment
Share on other sites

While logged in as root, I tried this.. and got the following:


Warning: Access denied for user: 'mryan@localhost' (Using password: YES) in /var/www/html/phpbb/whatever.php on line 2


Warning: MySQL Connection Failed: Access denied for user: 'mryan@localhost' (Using password: YES) in /var/www/html/phpbb/whatever.php on line 2

Access denied for user: 'mryan@localhost' (Using password: YES)


I just tried adding mryan to groups apache and mysql, but get the same result.. Last of all, I tried messing around with the grant all command but still no change..

Link to comment
Share on other sites

I dont think it matters what you are logged in when you run the script as the script probably runs as nobody when accessed through the browser.


Instead of using grant and grant all, you can also try inserting it with mySQL insert syntax. which you can find examples of here: http://www.mysql.com/doc/en/Adding_users.html


I should add the users for mysql are separate from the regular users so it should not matter what group etc it belongs, you actually do not have to create the user in that way. All this user is a user for mysql that is it.


Should also probably add I have only added users in this way twice so I am not super experianced in it, I normally do it online with things like C-Panel

Link to comment
Share on other sites

That did it! :P


I pulled up the mysql user database with webmin and took a peek. I had a few records there for mryan. I deleted these and then went into mysql and did a full grant using the sample from the web page you gave me. This time my install worked.


Thank you very much, big help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...