Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
DevStr1ng

Installing OpenOffice 2.3.0.7 [solved]

Recommended Posts

Hi. I have succesfully installed all KDE-rpms, and have 3.5.8 as well.

 

But when i tried to install OpenOffice Package, OO-draw get message about missing libjpeg.so

 

Qt3-devel package also installed.

 

How fix this problem?

 

 

Thanx

Share this post


Link to post
Share on other sites

It probably means you need to install libjpeg package.

Share this post


Link to post
Share on other sites

Packages already installed:

libjpeg62-6b-41mdv2008.0.i586.rpm

libjpeg62-devel-6b-41mdv2008.0.i586.rpm

 

And:

 

[root@Matrix lib]# ls -la | grep libjpeg
-rwxr-xr-x   1 root root	  470 2007-08-29 17:00 libjpeg.la*
lrwxrwxrwx   1 root root	   17 2007-11-18 13:50 libjpeg.so -> libjpeg.so.62.0.0*
lrwxrwxrwx   1 root root	   17 2007-11-18 13:43 libjpeg.so.62 -> libjpeg.so.62.0.0*
-rwxr-xr-x   1 root root   134500 2007-08-29 17:00 libjpeg.so.62.0.0*

 

I have checked this before creating this topic.

 

 

Also i found similar problem in cooker-x86:

www.nabble.com/-Bug-35354--openoffice.org,-NEW:-openoffice. org-draw-cannot-be-installed-t4759408.html

 

:(

Share this post


Link to post
Share on other sites

Does it give you the actual version of libjpeg that it's looking for when you try to install openoffice draw? Are you installing it from rpm? We're obviously hitting a dependency problem either that the package version cannot be met through the repo, or that if you have the rpm locally, it's realising the version isn't what it wants to have installed.

Share this post


Link to post
Share on other sites

When i tried to install over MCC -> Software updates, i get following:

 

scree01ts2.th.jpg

 

If i check OpenOffice.Org package:

 

scree02ep7.th.jpg

 

When i check OpenOffice.org-KDE - i get same message.

 

 

Also i download rpms locally and when i try to install (no matter was, openoffice.org-2.3.0.7-1mde2008.0.i586.rpm

or even openoffice.org-writer-2.3.0.7-1mde2008.0.i586.rpm) i get:

scree04re0.th.jpg

 

Here is no info about libjpeg version.

 

Where i can looking about lib version, that need for office? Thanks.

 

P.S. Sorry for my bad english language. :)

Edited by DevStr1ng

Share this post


Link to post
Share on other sites

About the problem you had about missing libjpeg only mean that you dont have mandriva main repository added to your urpmi database.

 

As posted in http://www.mde.djura.org/index2008.0.html:

The repositories main, contrib, plf-free and plf-nonfree have frequently needed

rpms, so if you intend to use urpmi or rpmdrake dont forget to add them.

Share this post


Link to post
Share on other sites
Guest gkokmdam

Where does one get those OO packages? Can you point me to the URPMI rep., please?

 

wkr,

gkokmdam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×