Jump to content
Guest BigDez

How do I save to USB outside of loop?

Recommended Posts

Guest BigDez

Linux newbie, I am using a scandisk 4 gb USB and love it. I have used the max loop image of 2GB which is fine, but I can't save files like kwrite, etc to the USB. I have over a 1.4 of free space but it says.

 

Not possible to save to file:///mnt/win_d/testfile

I created a folder on the USB by logging in as root using Konqueror with these commands

 

xhost +

su -

konqueror &

 

but I couldn't give "guest" permissions after creating the folder. Obviously something I am doing wrong and could use your help.

 

BigDez

Share this post


Link to post
Share on other sites

sounds to me (and i am n00b) that you need to either change permissions of that directory so anybody can use it or create the directory as guest.

 

su and give root password, then do: chmod -R 0777 /mnt/win_d/

 

that should do it, if it doesnt then you can change the ownership of the directory.

 

su and give password, then do: chown -R guest:guest /mnt/win_d

 

if the first one fails, try the second, if the second fails, see if you cant just open a kinqueror window and create the directory as user or as guest or as the defualt login person. then if all of that fails then i would guess that there is something else thats beyond me (again, i am n00b).

 

good luck

Share this post


Link to post
Share on other sites

what is /mnt/win_d? Is this a Windows partition? If so, what filesystem is it?

 

 

edited after re-reading original post

Share this post


Link to post
Share on other sites

I would suggest that the problem lies in the fact that you are working with a read-only file system, both on your USB (where you have your running live distro) AND the mounted hard disk(s).

 

You need to unmount "/mnt/win_d" ("umount /mnt/win_d"), then remount it as a read-write filesystem ("mount -t ntfs-3g /dev/hdb1 /mnt/win_d"). I am assuming that "win_d" is a second hard disk and is ntfs formatted, if it is a second partition on your C: drive then replace "hdb1" with "hda2". This should enable you to write data to "win_d".

 

Regards, Phydeaux.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...