Jump to content

Changes to sysctl.conf don't stick - help!


Guest genepool
 Share

Recommended Posts

Guest genepool

Please help me try to solve a problem that I can't seem to find an answer for. I have been trying to stop the kernel from logging martian source packets by changing the /etc/sysctl.conf file to have net.ipv4.conf.all.log_martians = 0 but everytime I restart the network (or reboot) the sysctl.conf file reverts to it's unedited condition. How can I stop martian source packets from being logged and what script is changing the sysctl.conf file? Thanks.

Link to comment
Share on other sites

It shouldn't be doing that. What I tend to do is edit /etc/sysctl.conf and then I run:

 

sysctl -p

 

and it will activate the settings you've just put in /etc/sysctl.conf. You shouldn't need to restart the network for it. Try what I've said, and then check that your martian parameter is set correctly.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...