Jump to content
Sign in to follow this  
strunal

Trying to install some software

Recommended Posts

This is the error! any help?

 

 

[root@localhost user]# cd /home/user/domino-0.4

[root@localhost domino-0.4]# ./configure

checking build system type... i686-pc-linux-gnu

checking host system type... i686-pc-linux-gnu

checking target system type... i686-pc-linux-gnu

checking for a BSD-compatible install... /usr/bin/install -c

checking for -p flag to install... yes

checking whether build environment is sane... yes

checking for gawk... gawk

checking whether make sets $(MAKE)... yes

checking for kde-config... /usr/bin/kde-config

checking where to install... /usr (as returned by kde-config)

checking for style of include used by make... GNU

checking for gcc... gcc

checking for C compiler default output file name... a.out

checking whether the C compiler works... yes

checking whether we are cross compiling... no

checking for suffix of executables...

checking for suffix of object files... o

checking whether we are using the GNU C compiler... yes

checking whether gcc accepts -g... yes

checking for gcc option to accept ISO C89... none needed

checking dependency style of gcc... gcc3

checking how to run the C preprocessor... gcc -E

checking for g++... no

checking for c++... no

checking for gpp... no

checking for aCC... no

checking for CC... no

checking for cxx... no

checking for cc++... no

checking for cl.exe... no

checking for FCC... no

checking for KCC... no

checking for RCC... no

checking for xlC_r... no

checking for xlC... no

checking whether we are using the GNU C++ compiler... no

checking whether g++ accepts -g... no

checking dependency style of g++... none

checking whether gcc is blacklisted... no

checking whether g++ supports -Wmissing-format-attribute... no

checking whether gcc supports -Wmissing-format-attribute... yes

checking whether g++ supports -Wundef... no

checking whether g++ supports -Wno-long-long... no

checking whether g++ supports -Wno-non-virtual-dtor... no

checking how to run the C++ preprocessor... /lib/cpp

configure: error: C++ preprocessor "/lib/cpp" fails sanity check

See `config.log' for more details.

[root@localhost domino-0.4]#

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

i build this a while ago without any probls and made an rpm using checkinstall, if you have a site i could upload it to i could do that, alternatively show config.log (probably in /home/user/domino) to analyse what went wrong....

 

btw i am using gcc 4.2.2, 4.3.0 also seems available

Edited by ffi

Share this post


Link to post
Share on other sites
i build this a while ago without any probls and made an rpm using checkinstall, if you have a site i could upload it to i could do that,

 

thanks for the fast reply-

well that would be a big help, although i only know of commercial upload sites like yousendit.com as i have no site of my own.

 

alternatively show config.log (probably in /home/user/domino) to analyse what went wrong....

 

The C preprocessor is installed and

i have looked at the config file but can't see what the root of the error is, i suspect it's something that needs to be installed.

Edited by strunal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...