Jump to content

Wireless connection lost every reboot


Guest Stylish Lemur
 Share

Recommended Posts

Guest Stylish Lemur

Hello

I am from Thailand and

I am very new to linux and mandriva. let say I just install mandriva last 2 days.

I have able to learn from google and try to set something i want except wireless with ndiswrapper. Please help and bear with me here. I might not follow with some details you guys help me but i will try my best. Thanks in advance.

 

here is the situation. I just install Mandriva 2008 and I use Ndiswrapper for a driver for my USB wireless using WINXP driver. It brands "TP-link" taiwanese brand model TL-WN321G

It working find until I restart the my linux. it won't recognise this device anymore.

 

I have to repeat everything again by drakconnect .... then it works. but when I restart the same problem persists.

 

I try to search for solution to this issue and found here

 

https://mandrivausers.org/lofiversion/index.php/t42231.html

 

I thought i have similar problem but I could not solve by follow the link above.

I asked mpatrick who help another friend in that topic solve his problem. he suggest me to try follow command to find out whether is it a timing problem

 

$ su

<enter root password>

# modprobe -r ndiswrapper

# modprobe ndiswrapper

 

After I tried, seem problem persists.

Please help me

Link to comment
Share on other sites

Check /etc/modprobe.preload and add ndiswrapper to this. I had similar problems, but when I added ndiswrapper to it, it started to work OK. All you do, is add it to the file like this:

 

ndiswrapper

 

but on a completely new line from anything else in this file.

 

If you're using security, then what is it? WEP? WPA?

Link to comment
Share on other sites

Guest Stylish Lemur

I have already add

ndiswrapper

 

in the /etc/modprobe.preload

 

Still problem did not get solved.

I am using WPA?

Where should we look next?

Link to comment
Share on other sites

Whats your config for wpa_supplicant? There will be a file, I think /etc/wpa_supplicant.conf. Remove your password when you post the contents here for security reasons.

 

First of all though, I would ensure you get it working successfully without security first. Therefore turn security off on your wireless access point/router, and then try to use your machine to connect. If you then find that it connects completely fine every time you restart your computer, then we know it is wpa_supplicant that is causing your problem.

 

If it does work, then post your wpa_supplicant.conf file here, and we can then take a look in case it has a bad configuration.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...