Jump to content
pelusa

core dump even if ulimit -c gives 0?

Recommended Posts

Hi,

I have a weird behavior just within the last hours. I will get core dums written on my external hard drive occasionally between 3 to 10 times an hour each 100MB large. Checking ulimit -a as user as well as root gives:

 

[user@####### ~]$ ulimit -a

core file size (blocks, -c) 0

data seg size (kbytes, -d) unlimited

file size (blocks, -f) unlimited

max locked memory (kbytes, -l) 32

max memory size (kbytes, -m) unlimited

open files (-n) 1024

pipe size (512 bytes, -p) 8

stack size (kbytes, -s) 8192

cpu time (seconds, -t) unlimited

max user processes (-u) 4024

virtual memory (kbytes, -v) unlimited

 

 

[root@###### user]# ulimit -a

core file size (blocks, -c) 0

data seg size (kbytes, -d) unlimited

file size (blocks, -f) unlimited

max locked memory (kbytes, -l) 32

max memory size (kbytes, -m) unlimited

open files (-n) 1024

pipe size (512 bytes, -p) 8

stack size (kbytes, -s) 8192

cpu time (seconds, -t) unlimited

max user processes (-u) 4024

virtual memory (kbytes, -v) unlimited

[root@##### user]#

 

I am using Mandriva 2006. I cannot upgrade as this is the only distro which runs Labview 8.2 with all its drivers without problems.

Hope someone can help me with this problem, as I do not want to stay up and always delete all these core files. I don't know what to do with them anyway (I am not really familiar with linux just apply it)

Thanks

Pelusa

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

If you cd to the directory with the core files in and type:

 

file core.5837 (change the number to the file you want to look at)

 

you should be able to find out what's causing them.

Share this post


Link to post
Share on other sites

Maybe not ideal, but create an hourly job to remove them, provided that they are always written to the same directory. I have no idea why it creates them, but maybe recompile kernel without kernel dump support as another solution.

Share this post


Link to post
Share on other sites
Maybe not ideal, but create an hourly job to remove them, provided that they are always written to the same directory. I have no idea why it creates them, but maybe recompile kernel without kernel dump support as another solution.

yeah thats what I am planing to do. I know now that labview causes these dumps, its weird as the program is still running and collecting data as it is supposed to. Also, labview calls via system calls c-programs which run as supposed, meaning no seg faults are at least obvious. Well I will dig deeper in order to get to the root.

Thanks for your help

pelusa

Share this post


Link to post
Share on other sites

I'm not exactly sure what is meant by this, but there are often "hard limits" set that take precedence over "soft limits". (I read this on a site about AIX). Example:

My ulimit -c returns 0, but ulimit -H -c returns unlimited. You can set the hard limits by using the -H flag with the setting:

 

ulimit -H -c 0

 

Of course, you'll have to put this in your /etc/profile to remain in effect for all users upon reboot.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...