Jump to content

Wine 'unhandled page fault on read access'


Recommended Posts

so I'm trying to run wine, it won't work at all. Everything I try gives me this same error:

[urza9814@localhost ~]$ winecfg
wine: Unhandled page fault on read access to 0x00000000 at address 0xb7d3b463 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0xb7d3b463).
Register dump:
CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
EIP:b7d3b463 ESP:0033ee3c EBP:0033ee58 EFLAGS:00210246(   - 00	  -RIZP1)
EAX:00000000 EBX:b7dfaff4 ECX:00000000 EDX:7e0b00a0
ESI:00000033 EDI:00000000
Stack dump:
0x0033ee3c:  b7d3b175 00000000 00000000 0033ee58
0x0033ee4c:  7e2a6b6c 00000033 00000000 7e2ad914
0x0033ee5c:  7e263a20 00000000 00000076 000000d4
0x0033ee6c:  00000001 7c04a968 7c04a400 00000084
0x0033ee7c:  7e0ec503 000000d4 7c03a1d0 00000076
0x0033ee8c:  00000000 0033ef84 0033ef98 0033ef9c
=>1 0xb7d3b463 strlen+0x33() in libc.so.6 (0x0033ee58)
 2 0x7e263a20 in winex11 (+0x43a20) (0x7e2ad914)
 3 0x00000000 (0x7c04a400)
 4 0x7c0184c8 (0x00000000)
0xb7d3b463 strlen+0x33 in libc.so.6: movl	   0x0(%eax),%ecx
Module  Address				 Debug info	  Name (56 modules)
ELF	 7bf00000-7bf03000	   Deferred		<wine-loader>
ELF	 7d182000-7d18b000	   Deferred		librt.so.1
ELF	 7d18b000-7e0bb000	   Deferred		libgl.so.1
ELF	 7e0bb000-7e0c1000	   Deferred		libxdmcp.so.6
ELF	 7e0c1000-7e1c0000	   Deferred		libx11.so.6
ELF	 7e1c0000-7e1cf000	   Deferred		libxext.so.6
ELF	 7e1cf000-7e1d4000	   Deferred		libxxf86vm.so.1
ELF	 7e1d4000-7e1ed000	   Deferred		libice.so.6
ELF	 7e1ed000-7e1f6000	   Deferred		libsm.so.6
ELF	 7e215000-7e2ae000	   Export		  winex11<elf>
 \-PE  7e220000-7e2ae000	   \			   winex11
ELF	 7e302000-7e434000	   Deferred		libxml2.so.2
ELF	 7e434000-7e463000	   Deferred		libfontconfig.so.1
ELF	 7e463000-7e4db000	   Deferred		libfreetype.so.6
ELF	 7e4db000-7e50f000	   Deferred		uxtheme<elf>
 \-PE  7e4e0000-7e50f000	   \			   uxtheme
ELF	 7e50f000-7e5a2000	   Deferred		winmm<elf>
 \-PE  7e520000-7e5a2000	   \			   winmm
ELF	 7e5a2000-7e5b4000	   Deferred		libresolv.so.2
ELF	 7e5d3000-7e5f2000	   Deferred		iphlpapi<elf>
 \-PE  7e5e0000-7e5f2000	   \			   iphlpapi
ELF	 7e5f2000-7e650000	   Deferred		rpcrt4<elf>
 \-PE  7e600000-7e650000	   \			   rpcrt4
ELF	 7e650000-7e6fd000	   Deferred		ole32<elf>
 \-PE  7e660000-7e6fd000	   \			   ole32
ELF	 7e6fd000-7e734000	   Deferred		winspool<elf>
 \-PE  7e710000-7e734000	   \			   winspool
ELF	 7e734000-7e7fd000	   Deferred		comctl32<elf>
 \-PE  7e740000-7e7fd000	   \			   comctl32
ELF	 7e7fd000-7e849000	   Deferred		advapi32<elf>
 \-PE  7e810000-7e849000	   \			   advapi32
ELF	 7e849000-7e8f0000	   Deferred		gdi32<elf>
 \-PE  7e860000-7e8f0000	   \			   gdi32
ELF	 7e8f0000-7ea42000	   Deferred		user32<elf>
 \-PE  7e910000-7ea42000	   \			   user32
ELF	 7ea42000-7eaa0000	   Deferred		shlwapi<elf>
 \-PE  7ea50000-7eaa0000	   \			   shlwapi
ELF	 7eaa0000-7ebad000	   Deferred		shell32<elf>
 \-PE  7eab0000-7ebad000	   \			   shell32
ELF	 7ebad000-7ec50000	   Deferred		comdlg32<elf>
 \-PE  7ebc0000-7ec50000	   \			   comdlg32
ELF	 7ec50000-7ecba000	   Deferred		winecfg<elf>
 \-PE  7ec60000-7ecba000	   \			   winecfg
ELF	 7edda000-7ef10000	   Deferred		kernel32<elf>
 \-PE  7edf0000-7ef10000	   \			   kernel32
ELF	 7ef10000-7ef37000	   Deferred		libm.so.6
ELF	 7ef37000-7ef3a000	   Deferred		libxau.so.6
ELF	 7ef41000-7ef54000	   Deferred		libz.so.1
ELF	 7ef56000-7f000000	   Deferred		ntdll<elf>
 \-PE  7ef70000-7f000000	   \			   ntdll
ELF	 b7ccc000-b7cd0000	   Deferred		libdl.so.2
ELF	 b7cd0000-b7dff000	   Export		  libc.so.6
ELF	 b7dff000-b7e13000	   Deferred		libpthread.so.0
ELF	 b7e16000-b7e20000	   Deferred		libnss_files.so.2
ELF	 b7e32000-b7f48000	   Deferred		libwine.so.1
ELF	 b7f49000-b7f63000	   Deferred		ld-linux.so.2
process  tid	  prio (all id:s are in hex)
00000008 (D) c:\windows\system32\winecfg.exe
	00000009	0 <==


running mandriva 2007.1 on a 64-bit AMD processor, I've tried wine both from urpmi and the latests version from their website.



[moved from Software by spinynorman]

Link to comment
Share on other sites

I guess you are running the x86_64 Mandriva version...

Wine runs either like crap on it, or not at all. You obviously belong to the second category.

x86_64 still has many regressions... if you don't explicitly need it, consider switching to oldfashioned AND working 32-bit environment.

Link to comment
Share on other sites

No, actually, I'm running the 32 bit version because my wifi card wouldn't work right on the 64 bit version.


Funny story though. I just shut down to check out the CD I used to install, make sure it was 32 and there wasn't some weird ndiswrapper thing that it just worked after my last install (fairly recently), and I decided while it was down I'd try plugging in my other 300 gig hard drive that's just kinda been sitting there disconnected. So anyways, I do that...and it won't boot up. So I unplug the drive...and it still won't boot up. The bootloader won't even start. So I go to rescue, restore bootloader...no luck. So I end up running the installer, telling it to not format anything, not change anything pretty much, just letting it run the bootloader install part...boot up...and now wine works.


Computers are so damn weird sometimes...lol

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...