Jump to content

Issues with NFS [solved]


Recommended Posts

I am not able to have NFS working on Mandriva Spring 2007. I get nothing out of:

service nfs start/status/stop

nor do I get from portmap or nfslock.

Link to comment
Share on other sites

I assume you are root when you give the service command?

yes of course, it doesnt even work from drakxservices.

if I was a regular user I will get something like command not found.

Link to comment
Share on other sites

Have you tried the init.d scripts directly

/etc/init.d/nfs**** start|stop ?

and same for portmap?


Have you rechecked the packages are installed?



Yes I did all that, however everything was there yet nothing was working. The service command was defoinetly working so it wasn't an issue regarding the 'service' or init.d manager.


I end up solving it by removing the whole stack (nfs-utils nfs-utils-client and portmap) and reinstalling.


I also check the errata and saw sme nfs bugs but nothing like I experienced.

Link to comment
Share on other sites

you know which log file will tell me these, unfortunately messages didn't help much. I dont get the exact output from a linux start up on the logs from what I can see.


All I get is:

Jul 18 17:55:13 genius kernel: NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory

Jul 18 17:55:13 genius kernel: NFSD: starting 90-second grace period

Link to comment
Share on other sites

My experience with mandr* over the years has been that urpmi is great for non-server type apps but falls down significantly over server stuff... hard to explain without saying when you do this in Debian its all set up and the services running after install.... wheras Mandy tends to install and leave the config....


I also find because of this its not starting a default service... so it never actually checks the detail and the "is it actually running"...

This doesn't really happen in Deb because the dpkg actually starts the service and tests its running... if not it will tell you it failed.. details depending opn your verbosity level....


In most cases Mandy is 99% there.... BUT it from my experience often has that 1% missing which turns out to be trivial... such as a missing symlink or init entry... perhaps it didn't try or perhaps the file couldn't be written etc. and it usually just takes searchin through logs to see what part if any failed or what might have been forgotten in the urpmi script... check the package list and check it was all copied etc. etc.

Link to comment
Share on other sites

So I wont let people just bash mandriva in tipica trol fashion. I have never experienced this before and I dont think I would of generalized that the distro is any less valuable because of a simple re-install service.


I have ran mandriva/mandrake for many years as a server and found utilities such as the policy management far supiror than other distros. I know hardcore server guys that use mandriva on the government and organization as a server with no issue.


As for urpmi, I heard that smart has became a better solution in the mandriva world.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...