Jump to content
jbuckley2004

Firefox and CNN

Recommended Posts

Yesterday I could few videos on CNNs main page using Firefox 2.0.0.4 and iirc, mplayerplugin (after a settings tweak). Today they re-designed their pages, and it looks like their script uses a version of the adobe flash player for videos. All I get now is a black screen in the applet.

 

Has anyone gotten it to work? Care to share?

Thanks!

Share this post


Link to post
Share on other sites

I too was saddened to find that I can no longer view video from the CNN website. It does appear that they are now using adobe flash player, much like USAToday.

 

To answer dexter11's question

Yes, I can view the video using W2K with either Firefox or IE

 

I spent some time yesterday on the web looking for a solution, but I have not found one yet. My Shockwave Flash 9.0 r31 is working fine, and I suspect there is a problem with the script CNN is using to determine the flash installed on a viewer's computer.

 

What comes to mind is a useragent override, but I have not pursued this yet.....

Share this post


Link to post
Share on other sites

I just checked CNN, and they have changed to Adobe Flash. However I can still watch it with both the Firefox2.0.0.1(Mandriva 2007), and Iceweasel2.0.0.4 (Debian Etch) using the Adobe Flash player plugin 9.0.31.0 without any problems.

Share this post


Link to post
Share on other sites

Well Greg2, since you have things working it looks like I have some work to do. I had dismissed the problem as being CNN's and not mine. You have shown me this is not true.

 

I will get to work on this and report back.

 

Thanks.

Share this post


Link to post
Share on other sites
Well Greg2, since you have things working it looks like I have some work to do.

My secret, that no one believes:

 

Move or copy your flashplayer.xpt from your plugins directory to your /mozilla/components, or /mozilla-firefox-xxxx/components directory... as per mozdev.org. :)

Share this post


Link to post
Share on other sites

Greg2:

 

This flashplayer.xpt location issue has confused me for a long time. If flashplayer is installed by downloading the .tar.gz file from adobe and running the script flashplayer-installer then libflashplayer.so is placed in ~/.mozilla/plugins but flashplayer.xpt is not placed anywhere? I have always placed a copy in ~/.mozilla/plugins manually.

 

At any rate, I now have flashplayer.xpt in both ~/.mozilla/plugins and my components directory. Flash videos play fine on USAToday. On CNN's site, I can watch the commercial immediately preceeding the video fine. But when the commercial finishes the video does not play.

Share this post


Link to post
Share on other sites
On CNN's site, I can watch the commercial immediately preceeding the video fine. But when the commercial finishes the video does not play.

 

Same here. The video plays the commercial, but then the slider just stops and the video screen stays at the last frame of the commercial.

 

If it helps, I am using 2007 Spring 64 Bit, but had to install Firefox 32 bit in order to view flash, because Adobe doesn't do a 64 bit version for Linux (and also because Java apparently only works in 32 bit, too).

Share this post


Link to post
Share on other sites

Thanks Steve. I take some comfort in knowing others are having this problem too. Now I know I am not doing something stupid.

Share this post


Link to post
Share on other sites

I take comfort in the fact that the advertisement plays. That should mean the plugin is working. Why it stops, I have no idea. Maybe there is some method the plugin calls that is not supported in the Linux version.

 

Hmmmm...I should start Firefox from a console and see if there are any errors. BRB.

 

I got this over and over:

Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

 

So, I stopped Firefox and did export G_FILENAME_ENCODING="UTF-8"

and didn't get the warning, but the video still stops.

Edited by Steve Scrimpshire

Share this post


Link to post
Share on other sites
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

 

I see this each time a flash video is played, successfully (USAToday) or otherwise (CNN). I don't think this error is a serious one.

Share this post


Link to post
Share on other sites

Check your not getting anything blocked by ad-blocking software too. I've found sometimes my adblock plus is blocking some innocent content and I cannot view things.

Share this post


Link to post
Share on other sites

Ian:

 

I had add-blocking material in my userContent.css that I had to remove to make the USAToday videos work properly. This material has been removed, but that didn't fix the problem with the CNN video.

 

Are you able to view the CNN flash videos successfully?

Share this post


Link to post
Share on other sites

I had to allow popups for CNN.

 

My flashplayer plugin location

[greg@halfway ~]$ cd /usr/lib/mozilla-firefox-2.0.0.1/plugins
[greg@halfway plugins]$ ls |grep flash
libflashplayer.so*
[greg@halfway plugins]$ cd /usr/lib/mozilla-firefox-2.0.0.1/components
[greg@halfway components]$ ls |grep flash
flashplayer.xpt*

I've played with CNN a bit this morning. I've seen about 10 different commercials, and the only one that won't continue to the video clip for me is the HBOvoyeur.com.

 

I would suggest that you click on the CNN Video Feedback, and leave them a message explaining your problems. I had to do that several times with CBS, and it works now with Linux.

 

Alternatively you can install IE6 and use flash player 9.0.45.0 with wine, using these instructions.

 

I just tried it on CNN, it skips a frame or two, but it works. :)

 

Sorry, I can't offer any more suggestions or help. :sad:

Share this post


Link to post
Share on other sites

Found a fix, which I got from this link on the ubuntu forums

 

I had the same problem as others reported - video would stop after the ad played.

 

The fix that worked was to download the firefox User Agent Switcher add-on and set it to 'Netscape 4.8 (Windows Vista)'. After that the cnn.com video worked perfectly.

 

There was a report that the user agent needed to be set back to default to get fox news video to work. So you may need a different setting for different sites. Changing the User Agent is a quick 'Tools -> User Agent Switcher' selection from the firefox menu, so it's no big deal to switch it to other settings if you need to.

 

I installed this firefox add-on on both ubuntu feisty and mandriva 2007.1 and after that cnn.com video worked. It was not working on either one before this change.

 

When I get a chance I'm gonna try it on my fedora 7 install as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...