Jump to content
PurpleGuitar

apache+php not working after upgrade to 2007.1

Recommended Posts

Greetings all

 

I had Moodle installed on my machine running Mandriva 2007 Free, and it had no problems. After upgrading to 2007.1 Spring Free, it doesn't work correctly. Any php page I access, the browser tries to download the php file instead of processing it and giving me the resulting html.

 

I have installed the latest versions of apache httpd and apache-mod_php.

 

Can someone point me in the right direction?

 

Many thanks!

Share this post


Link to post
Share on other sites

What php packages do you have installed?

 

rpm -qa | grep -i php

 

normally now there is no mod_php package, and so you need to install the php package.

Share this post


Link to post
Share on other sites

Installed php packages:

php-json-1.2.1-3mdv2007.1
php-xmlwriter-5.2.1-1mdv2007.1
php-gettext-5.2.1-1mdv2007.1
php-sysvshm-5.2.1-1mdv2007.1
php-xml-5.2.1-1mdv2007.1
php-iconv-5.2.1-1mdv2007.1
php-ftp-5.2.1-1.1mdv2007.1
php-zlib-5.2.1-4.2mdv2007.1
php-tokenizer-5.2.1-1mdv2007.1
php-hash-5.2.1-1mdv2007.1
php-session-5.2.1-1mdv2007.1
php-timezonedb-2007.3-1mdv2007.1
php-mbstring-5.2.1-1.1mdv2007.1
php-domxml-20030407-15mdv2007.1
php-filter-5.2.1-0.1mdv2007.1
php-ctype-5.2.1-1mdv2007.1
php-ini-5.2.1-2mdv2007.1
php-suhosin-0.9.18-4mdv2007.1
php-gd-5.2.1-1.1mdv2007.1
apache-mod_php-5.2.1-4mdv2007.1
libphp5_common5-5.2.1-4.2mdv2007.1
php-mysql-5.2.1-1mdv2007.1
php-simplexml-5.2.1-1mdv2007.1
php-sysvsem-5.2.1-1mdv2007.1
php-openssl-5.2.1-4.2mdv2007.1
php-posix-5.2.1-1mdv2007.1
php-xmlreader-5.2.1-1mdv2007.1

Share this post


Link to post
Share on other sites

I'm actually missing seeing the main php package in your list, called php-5.2.1 or something. This is probably why.

Share this post


Link to post
Share on other sites

When I issue the innocent "urpmi php" command, I am asked whether I want php-cli, php-cgi, or php-fcgi. No matter which of these I choose, php files still download instead of being interpreted. I played with "urpmi php --fuzzy" and browsed for packages that looked top-level (through the massive lists of php-* stuff), but nothing was called simply "php-5*".

 

Any other ideas or directions, or maybe specific package names?

Share this post


Link to post
Share on other sites
I'm actually missing seeing the main php package in your list, called php-5.2.1 or something. This is probably why.
Can't find that in the Mandriva repos, Ian. Are you sure about that?!

 

PurpleGuitar, did jboy's link fix your problem? It seemed to be suggesting to install an awful lot of packages, did it do the trick?

Share this post


Link to post
Share on other sites
PurpleGuitar, did jboy's link fix your problem? It seemed to be suggesting to install an awful lot of packages, did it do the trick?

 

I installed the whole list from that site, many of which I didn't have. After a few httpd restarts and browser cache clearings, it worked again. Although I'm glad it worked, I cannot say exactly where the problem was.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...