Jump to content

Gentoo $PATH problem [solved]

Recommended Posts

I'm trying to install the linux drivers for my Belkin UPS and I get the following:

localhost Bulldog_v2_Linux # sh setup_console.bin
No Java virtual machine could be found from your PATH
environment variable.  You must install a VM prior to
running this program.


I have blackdown-jre installed and I know it works. My path to java-vm is /opt/blackdown-jre- and java_vm is there. I tried adding it to my .bashrc but that didn't work. Any suggestions?

Link to comment
Share on other sites

I agree with iph, I think you should install Sun java for this to work properly.


To source your blackdown do


then you shouldn't need to solve the NUT thread. :)

Link to comment
Share on other sites

Thanks but I already tried that and it didn't work.
Tried what? There are at least 2, if not 3 (depending on how you count), suggestions posted here...which ones did you try that didn't work?
Link to comment
Share on other sites

I set the $PATH and it worked fine. But then I got another error which I googled and gooled and could fine no solution to. The thing that came up the most was that it was a corrupted download. So I tried downloading it 2 or 3 times and still had no luck. Which is why I just decided to try nut.

Link to comment
Share on other sites

Ok, a nut developer explained to me that there is a problem because my UPS is so new and the driver won't work.


So, here's where I'm at with the Bulldog software

localhost Linux # sh setup_console.bin
Exception in thread "main" java.lang.NoClassDefFoundError: com/zerog/lax/LAX


And I switched to Sun.


I know this isn't a corrupt download because I copied it all from the install cd. The reason I can't use the install cd is because it has java on it but when I try to run the setup script it says permission denied for the java.


I already called Belkin and they told me they had no linux users so they couldn't help me! :wall:


Any ideas?

Link to comment
Share on other sites

I already called Belkin and they told me they had no linux users so they couldn't help me! :wall:

Well that's not true, what about Ian? :D


Anyway, I've found that Gentoo does many things differently then I'm accustomed to doing them. That said, I can only tell you to check that you have configured your vm and set your CLASSPATH as per config virtual machine...

and give me the link to the setup_console.bin so I can check it and perhaps rewrite it for you.

Link to comment
Share on other sites

Well hopefully I won't have to worry about it. The nut developer came back with a fix. I don't understand all of it yet so I had to ask some more questions but he told me they would provide support until I get it working. Fingers crossed!


Edit: I just saw that last part. I did set up my vm according to the Gentoo doc you linked too. And I really appreciate the offer.

Link to comment
Share on other sites

I haven't done mine yet. I'm still meant to get the belkin software installed, but I don't want to do it remotely in case it borks the server. Then I've got to get a plane to the UK to fix it!


But I will do it, probably sometime in July/August.


I've never had to add java to the path, because it's always put links in /usr/bin or whatever when I've installed them. Even on Solaris. If you type:


java -version


what do you get?

Link to comment
Share on other sites

mystified@localhost ~ $ java -version
java version "1.5.0_11"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
Java HotSpot(TM) Client VM (build 1.5.0_11-b03, mixed mode)

Link to comment
Share on other sites

Going by my Lotus Notes 7 install, which is java-based:




this is what you're getting from the error in running the bin file. I would be tempted to do this:


slocate com/zerog/lax/LAX


and if no results come back, then this doesn't exist on your system. If it does, then whatever the directory is:


export CLASSPATH=/wherever/to/com/zerog/lax/LAX


however, you might need to just have the path to the main directory where com/zerog/lax/LAX exists, and not append this to the line like I have. I've not tried this, but this is where I would start. Either that, or the package you've downloaded doesn't have it within it. As normally, it should download and install and run fine. But I haven't looked to find out what the requirements are in the documentation for it.

Link to comment
Share on other sites

I've just been checking what I've downloaded, and I've downloaded something different and not the binary file. Maybe this will work better for you. All it asks to get it installed from this is to run:




so I think maybe this is a better one to use than the one you're using. Mine is v3.01.18 from what I've got here, and I downloaded the tar file. Of course, make sure this will work with your UPS.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...