Jump to content

KDE root password no longer accepted


Recommended Posts

I'm really impressed with the help that I've had on this forum. Thank you all very much. This is one of the things that motivates me towards migrating to Linux: It isn't just a software but a philosophy. It shows what people can do when they get together and help and co-operate with each other. It's in stark contrast with the tide of the world at the moment, where a handful of super-rich corporations dominate the planet.

Anyway, enought of that! Here's the print screen you asked for Silversurfer. This is the dialogue box that refuses my password:



Link to comment
Share on other sites

  • Replies 59
  • Created
  • Last Reply

Top Posters In This Topic

Mandrivsen, can you clarify something for me? You told me in your last post to write the command chmod 666 /tmp/my-saved-passw in root. Do I then log out of root and enter the command echo "my-passwd" > /tmp/my-saved-passw in the konsole as a user or do I need to stay root to do this?

Link to comment
Share on other sites

Mandrivsen, can you clarify something for me? You told me in your last post to write the command chmod 666 /tmp/my-saved-passw in root. Do I then log out of root and enter the command echo "my-passwd" > /tmp/my-saved-passw in the konsole as a user or do I need to stay root to do this?

chmod 666 makes the file readable and writeable for everyone, so you don't need to be root to echo to it.


Maybe you already have said something about it, but have you tried to copy and paste your password into the dialogue box?

Edited by Mhn
Link to comment
Share on other sites

Ok, that's all worked out fine. I followed Mandrivsen's instructions and, this time, the password appeared twice when I entered the comand cat /tmp/my-saved-passw. The two are identical. I also tried writing my password in Writer and pasting it in the dialogue box asking for my password. Still incorrect password. I think we can definitely assume that the keyboard set is being properly interpreted.

Link to comment
Share on other sites

Ok, that's all worked out fine. I followed ... o o o ...
I am still not 100% sure, that your diagnosis is correct. Are you sure you have entered them in different places i.e. GUI and text-based screen? What about running the command cat /tmp/my-saved-passw in both places. Do you notice a difference.


One ultimate test you can do to be absolutely sure that the two environments output use the same Key-Codes is the following:

  • In GUI terminal enter
    dumpkeys > /tmp/g-kcodes

  • In text (<Ctrl+Alt+Fn>) terminal enter
    dumpkeys > /tmp/t-kcodes

  • In any terminal, better GUI so you can use Cut-n-paste, enter the following
    diff  /tmp/*-kcodes
    echo "Error=$?"

    exactly as I spelled (note asterisk (*) before -kcodes. Be careful with spaces.

  • Observe the output of the above diff command. If you get Error=0, and if you have saved the output of the two environments in question, only then we can be sure that your earlier assumption is correct!


It is important that you do not enter or do anything between the last two commands, even better would be to enter the above in a single line as in the following:

diff  /tmp/*-kcodes || echo "Error=$?"

Edited by mandrivsen
Link to comment
Share on other sites

Oooops, above I made a mistake earlier (damn Cut-n-paste) and corrected it just now. There should be no greater sign between diff /tmp/*-kcodes, as I had posted in my original, since corrected post. Perhaps you should now repeat the above slightly different and enter:

diff /tmp/*-kcodes && echo "differences (Error=$?)" || echo "no differences (Error=$?)"

This should tell you more verbally, whether the two files differ or not.


Again, the message "no differences (Error=0)" (with the Error code equal to zero), confirms that you were right in concluding that keyboards behave correctly in both environments.

Edited by mandrivsen
Link to comment
Share on other sites

Another question Jimtim did you have a reboot or something whilst installing katapult? If you did then you may well have a still lock on drakconf.real or something.

It's possible to shutdown without clearing locks you see.

Edited by SilverSurfer60
Link to comment
Share on other sites

Hey Jimtim~


long time since i've seen "Ivor the engine & Jones the steam" nice touch there chap.


Well done for perservering ~ what a mystery!


In light of nothing new, lets get some basics out of the way here...

what are your o/s & system specs; [bash@localhost ~]$ uname -a


I notice from your libs you are running a 64bit box, which i have zero experience with, but the katapult file you "downloaded separately", would seem to sugest, to me anyway, a 32 bit from the file name you mentioned initially. But i dont know how to check that out for sure! Does anyone else know if the packages are 32 & 64 bit inclusive now? S'about time!




katapult- - belongs to Mandriva 2007 - source:rpmbone


Yes, the "katapult-" Download could be significant. It is better to install using the Software installer, when u can, and not from a download as there may be other files (dependancies) it requires to install properly. The software installer will also check the integrity of all the packages, compute all the dependancies, download all the packages and install all of them for you without any hassle at all.


If your using ML 2007 Katapult should be installed from the packages list and not from a folder of downloads. I do this all the time, at work, and it plays havoc with the IRS computers.


Which method did you use?


Personally, as a last resort and/or if time is tight here, I would consider the plan of re-installing the main o/s and keeping the home directory out of the disk format after "backing it up". 4 easy hours tops, adsl, plenty of tea and tell everyone its gonna be 2 days of hard work for 'their' benefit and demand something nice for yourself. :)


Otherwise just the juicy bits Jimtim please...

Link to comment
Share on other sites

Glad you noticed Ivor! I spent my early years in Wales and so I've always looked back on Ivor the Engine with nostalgia for the land of my childhood. Couldn't understand it half the time though 'cause it was often aired in Welsh!


Anyway, down to business. When I do "uname -a", I get:

Linux localhost 2.6.17-5mdv #1 SMP Wed Sep 13 14:32:31 EDT 2006 i686 Intel® Celeron® CPU 2.60GHz GNU/Linux


I usually use URPMI to install programmes where I can (I prefer using the terminal as it's faster but sometimes the MCC is easier through its user-friendliness). But, as I was going to add in the ongoing discussion about URPMI, not all apps can be found there - Java for instance. I couldn't find Katapult in URPMI, and decided to install it as an experiment to see if I could get my head around manual installations - that's the best way to learn! I was thrilled when it worked - and it DID work - very well in fact. It's a cool application - should definitely be on the next Mandriva release. But it has apparently caused a few problems for some people - perhaps because they can't find it in URPMI!


I have considered re-installing the OS - but that won't tell us what the problem is! I think that's how Linux advances - through the resolution of this sort of problem However, I haven't ruled that out, and I think I'll do it as a last resort once the Spring edition of Mandriva is officially available. I'd like to be able to find the cause of all this though.

Link to comment
Share on other sites

Jimtim, one humble request. Please do not use screenshots to display your output. Instead wrap the cut-n-paste into code (#). There are more reasons for avoiding images in forums, the two of which are {a} security (I am not clicking any image anymore!), and {b} it is impossible to cut-n-paste, your answer on the reader's side which in this case is my side.


Please post the cut-n-paste again, if you wish me to continue working with you.

Link to comment
Share on other sites

Sorry, this is the first time I've ever been on a forum anywhere.

Here is a copy of the screen:

"no differences (Error=$?)"


< keycode 3 =

< shift keycode 3 = two

< altgr keycode 3 = dead_tilde

< control keycode 3 = nul


> keycode 3 = U+00e9 two dead_tilde nul


< keycode 8 =

< shift keycode 8 = seven

< altgr keycode 8 = dead_grave

< control keycode 8 = Control_underscore


> keycode 8 = U+00e8 seven dead_grave Control_underscore


< keycode 10 =

< shift keycode 10 = nine

< altgr keycode 10 = dead_circumflex


> keycode 10 = U+00e7 nine dead_circumflex


< keycode 11 =

< shift keycode 11 = zero

< altgr keycode 11 = at


> keycode 11 = U+00e0 zero at


< keycode 12 = parenright

< altgr keycode 12 = bracketright

< control keycode 12 = Control_underscore


> keycode 12 = parenright U+00b0 bracketright Control_underscore


< keycode 18 = +e +E

< control keycode 18 = Control_e

< altgr control keycode 18 = Control_e

< alt keycode 18 = Meta_e

< control alt keycode 18 = Meta_Control_e


> keycode 18 = +e +E U+20ac Control_e Control_e Meta_e Meta_Control_e


< keycode 27 = dollar

< control keycode 27 = Control_bracketright


> keycode 27 = dollar U+00a3 U+20ac Control_bracketright


< keycode 40 =

< shift keycode 40 = percent


> keycode 40 = U+00f9 percent


< keycode 41 =


> keycode 41 = U+00b2


< keycode 43 = asterisk


> keycode 43 = asterisk U+00b5


< keycode 53 = exclam


> keycode 53 = exclam U+00a7

no differences (Error=1)

[james@localhost ~]$

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...