Jump to content
Sign in to follow this  
zero0w

Anti-aliased fonts

Recommended Posts

Just installed Mdk 9.1.

 

I have to admit it takes some time to get used to the anti-aliased fonts. It's okay (or even better) for English fonts, but the Asian fonts became too small and 'slim' when anti-aliased; even though anti-aliased Asian fonts are prettier, it's no point when it became too difficult to read them, say when browsing websites.

 

What do you think?

Share this post


Link to post
Share on other sites
Guest joehill

I learned from this board:

 

Sometimes it is better to turn it off...

part of /etc/X11/XftConfig

match any size > 7 any size < 15 edit antialias = false;

match any pixelsize < 17 any pixelsize > 7 edit antialias = false;

match any weight == bold edit antialias = true;

match any slant == italic edit antialias = true;

 

I personally hate ALL anti-aliased fonts on Linux, they're just a hackjob.

 

This worked on 9.0, I would assume the same configuration is used.

Share this post


Link to post
Share on other sites
Guest ndeb

Anti-alias fonts have gotten better in Linux. Redhat-8.0 had really good out-of-the-box AA fonts. I am using texstar kde-3.1 RPMS with AA fonts on mandrake-9.0 and they look nice. You should choose the fonts that look best and also ensure that the font size does not become too small (less than 8 ). I have found Sans 11 and Nimbus Sans 11 to be quite good.

Share this post


Link to post
Share on other sites

Also, what happened to the fonts of GTK 1.2+ applications?

 

They seems to be pretty ugly, unlike that of Mdk 9.0 which is pretty good.

Share this post


Link to post
Share on other sites
Guest joehill

should be the same quality for both.

 

however, you can tweak the fonts your gtk1.x apps use by editing your .gtkrc file or .gtkrc1.2-gnome2 maybe, in your home dir.

 

[/u]

Share this post


Link to post
Share on other sites

Ok, I fixed the GTK 1.2+ font problem.

 

I suspect the ext3 filesystem has not been completely debugged yet....

The font settings and data were a mess.... I suspect it's because of data corruption....

 

Switching to XFS as filesystem, it seems to be more stable for me and the GTK 1.2+ fonts are looking normal (same as Mdk 9) again now. Well it could be just my system not working good with ext3... but 9.0 is ok, and it's been known 2.4.20 kernel has data corruption with ext3....

Share this post


Link to post
Share on other sites
Guest joehill
This worked on 9.0, I would assume the same configuration is used.

 

Nope.

 

you mean there's no etc/X11/XftConfig?

Share this post


Link to post
Share on other sites

Nope.. read etc/X11/XftConfig.README-OBSOLETE

I guess that because XFree 4.3 incorporates Xft inside.

Share this post


Link to post
Share on other sites
Guest joehill

crikey, but I can still disable AA through the method you provided, thanks for that.

 

Cheers mate!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...