Jump to content
Sign in to follow this  
Guest Danno

Can't Compile Dazuko

Recommended Posts

Guest Danno

Hi,

 

I compiled a special kernel for dazuko called '2.6.17-6dazuko' on 2007.0 PWP i586. Here are snippets of my /boot/config file:

 

#

# Automatically generated make config: don't edit

# Linux kernel version: 2.6.17-6mdvcustom

# Sat Dec 16 20:34:49 2006

#

.....

# Security options

#

CONFIG_KEYS=y

CONFIG_KEYS_DEBUG_PROC_KEYS=y

CONFIG_SECURITY=y

CONFIG_SECURITY_NETWORK=y

CONFIG_SECURITY_NETWORK_XFRM=y

CONFIG_SECURITY_CAPABILITIES=m

 

As you can see my kernel has the proper settings for dazuko. But when I try to complile dazuko this is what I get:

 

[jeff@nx9010 dazuko-2.3.2]$ ./configure

checking host system type... Linux

checking for make utility... ok (make)

checking for C compiler... ok (cc)

kernel source in /lib/modules/2.6.17-6dazuko/source... yes

kernel build source in /lib/modules/2.6.17-6dazuko/build... yes

acquiring Linux kernel code configuration... ok

checking if Linux is RSBAC patched... yes (use --enable-rsbac to activate RSBAC API)

checking if devfs is enabled... no

discovered host system... Linux (2.6.17)

checking if security module support is enabled... no

error: security module support must be enabled in your kernel

[jeff@nx9010 dazuko-2.3.2]$

 

So how can I fix this?

 

Thanks,

Danno

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites
Guest Danno
Did you try configuring without RSBAC?

( ./configure --disable-rsbac )

 

[jeff@nx9010 dazuko-2.3.2]$ ./configure --disable-rsbac

checking host system type... Linux

checking for make utility... ok (make)

checking for C compiler... ok (cc)

kernel source in /lib/modules/2.6.17-6dazuko/source... yes

kernel build source in /lib/modules/2.6.17-6dazuko/build... yes

acquiring Linux kernel code configuration... ok

checking if Linux is RSBAC patched... yes (use --enable-rsbac to activate RSBAC API)

checking if devfs is enabled... no

discovered host system... Linux (2.6.17)

checking if security module support is enabled... no

error: security module support must be enabled in your kernel

[jeff@nx9010 dazuko-2.3.2]$

 

Am I correct in assuming that '/boot/config' always applies to the currently running kernel? Just curious since I compiled the kernel to support dazuko according to the instructions.

Share this post


Link to post
Share on other sites
Guest c51rider
[jeff@nx9010 dazuko-2.3.2]$ ./configure --disable-rsbac

.........

checking if security module support is enabled... no

error: security module support must be enabled in your kernel

[jeff@nx9010 dazuko-2.3.2]$

 

Am I correct in assuming that '/boot/config' always applies to the currently running kernel? Just curious since I compiled the kernel to support dazuko according to the instructions.

 

Hi there... did a search as I had the same problem and saw this. I see it may be too late for you, but maybe for others like me looking for an answer here is what worked for me.

I noticed the line : checking if Linux is RSBAC patched... yes (use --enable-rsbac to activate RSBAC API)

So I tried:

./configure --enable-rsbac

 

very quickly the configure script mentioned it was done.

 

[root@garage dazuko-2.3.4]# ./configure --enable-rsbac

checking host system type... Linux

checking for make utility... ok (make)

checking for C compiler... ok (cc)

kernel source in /lib/modules/2.6.17-13mdv/source... yes

kernel build source in /lib/modules/2.6.17-13mdv/build... yes

acquiring Linux kernel code configuration... ok

checking if Linux is RSBAC patched... yes

checking if devfs is enabled... no

discovered host system... Linux (2.6.17)

configure: creating Makefile

configure: creating library/Makefile

configure: creating example_c/Makefile

 

./configure successful

 

=======================

Configuration summary

=======================

 

module events = ON_OPEN ON_CLOSE ON_EXEC

devfs support = no

rsbac support = yes

stacking support = yes

module debug = no

library 1.x compatibility = yes

 

 

Note: For RSBAC you should copy the contents of this directory to:

/lib/modules/2.6.17-13mdv/source/rsbac/adf/daz

and recompile the kernel. Also make sure that the DAZ module

has been enabled in the kernel configuration.

 

[root@garage dazuko-2.3.4]#

 

I hope this helps !!!!

 

Chris

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...