Jump to content
AussieJohn

Video Capture

Recommended Posts

Guest n8oay

I just read through this and some other threads about video capture, but did not see any mention of the ATI All-in-Wonder cards. I have an 256mb AIW that uses the Radeon 9600 chipset. Has anyone had any experience with the AIW and Mandriva?

Share this post


Link to post
Share on other sites

Thanks very much to everyone for their excellent contributions to this thread.

 

I have taken on board all suggestions and hope to have some results in the near future.

 

On of the first tapes I plan to dvd is the free to air continuous broadcast of the winning race that won the Americas Cup for Australia all those years back and thus breaking the long strangle hold that the US had on the cup.

 

When done, if anyone wants a copy I will be pleased to send one to the first 10 to contact me. Just PM me with your address. No need to send any money at all in fact I prefer you didn't.

 

Cheers. John.

Share this post


Link to post
Share on other sites
To record the composite signal :-

 

mencoder tv:// -tv driver=v4l:input=1:width=720:height=406:volume=80 -of avi -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4000 -oac lavc -lavcopts acodec=ac3:abitrate=96 -o record.avi -endpos 119:00

 

Note the resolution in this example is 720x406 which is for a widescreen movie. Depending on your PC specs, you might not be able to capture at this resolution. 640x480 is good for 4:3 VHS.

 

I'm trying this, and I get an .avi file with a severely distorted picture, sort of a double-ghost image, very little color. Any idea what I might be doing wrong?

 

(I can watch using tvtime with no problem, btw.)

Share this post


Link to post
Share on other sites

maybe ntsc vs pal options?

vbitrate=4000 maybe remove option to let the default one being used

try a smaller size picture and more standard (say about 320 x200) in case it is a processor power issue

and for easier tests

no other ideas, no card like this here

Share this post


Link to post
Share on other sites
ntsc/pal issue

man mencoder I am afraid

also picture look like (speaking thrg my ar__ because really I do not know, hope sbdy else joins in)

- bad physical connection

- ntsc sampling on pal

- having both vga and HDI cables connected together (is this case)

- software issue

 

I have not a clue, sorry

 

Are you pal or ntsc where you are?

Share this post


Link to post
Share on other sites
I don't think it's a processor power issue. I just upgraded my mobo and got a 64-bit processor.

 

I tried it without the vbitrate and got the same result.

 

What do I need to do to check out the ntsc/pal issue?

 

Here's what the .avi I get looks like:

 

http://sammckee.com/snapshot1.png

Your sample looks like de-interlacing. How to get round it I'm afraid I don't know but, it may give fuel for thought.

Share this post


Link to post
Share on other sites

+1, could not think of the term

yes anything with that and frame per second sampling (and the whole ntsc/pal issue)

also I had green lines when using HDI

 

worst case scenario it is a 64 bits code issue or a clock issue (unlikely)

but you may try to install 32 bits OS mandriva on spare partition

if you cannot resolve simply what mencoder is doing

 

>>mpeg2video

Did you try another codec? (just in case) and remove any supefluous option during this testing phase

Share this post


Link to post
Share on other sites

It's definitely not a bad physical connection because I can watch it using tvtime, and it looks perfect.

 

I'm in the U.S. That means NTSC, right? I seem to recall I tried changing that while watching it on tvtime, and I couldn't get a picture using anything other than NTSC. I'll check again tonight.

 

+1, could not think of the term

 

I don't understand. (Sorry--I'm really new at this.)

 

I'm already using 32-bit Mandriva even though I have a 64-bit box b/c numerous people have advised me to wait on installing 64-bit until it's a little more stable.

 

Looks like I'm going to be spending some time in the man page.

Share this post


Link to post
Share on other sites

Success!

 

But failure. :(

 

It was working fine when I watched it on wintv, so I knew the connection was sound. The secret to recording was to add the norm=ntsc option. That gets me very good quality .avi files.

 

But...

 

Suddenly there's no sound! Neither when I watch in tvtime nor when I record an .avi. I had sound last night. What the hell. My worst fear is that the card's sound function suddenly blew. It's a used card, but sheesh. It was working--hardware-wise, anyway--just last night.

Share this post


Link to post
Share on other sites

More follow-up: Rebooted system, now have sound in tvtime. No clue about that but happy it works.

 

When I record, though, I get .avi with no sound. I have verified that I do hear sound when I play other .avi files. :)

 

Using this command to record:

 

mencoder tv:// -tv driver=v4l:norm=ntsc:input=0:width=640:height=480:volume=80 -of avi -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4000 -oac lavc -o record.avi -endpos 0:15

 

I think I'm getting close!

Share this post


Link to post
Share on other sites
Using this command to record:

 

mencoder tv:// -tv driver=v4l:norm=ntsc:input=0:width=640:height=480:volume=80 -of avi -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4000 -oac lavc -o record.avi -endpos 0:15

Looks to me as though you have no audio codec in your command? :idea2:

Share this post


Link to post
Share on other sites

Tried it like this:

mencoder tv:// -tv driver=v4l:norm=ntsc:input=0:width=640:height=480:volume=80 -of avi -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4000:acodec=mp2 -oac lavc -o record.avi -endpos 0:15

 

Same results.

 

Actually, I've tried it a couple hundred different ways now. :(

Share this post


Link to post
Share on other sites

If it's any consolation I can get a reasonable result with :-

mencoder tv:// -tv driver=v4l2:input=1:norm=pal:harddup:width=240:height=176:volume=30 -of mpeg -ovc lavc -lavcopts vcodec=mpeg1video:vrc_buf_size=327:vrc_minrate=1152:vrc_maxrate=1152:vbitrate=1152:keyint=15:acodec=mp2:vbitrate=1152 -oac lavc -lavcopts acodec=ac3:abitrate=96: -o record.mpg

Although you will need to change norm=pal to norm=ntsc but everything else should be ok.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...