Jump to content

Freezing Mandy and slow graphics [solved]


Recommended Posts

I still have not managed to get 2007 working properly yet, and am nearing the end of my patience with it. Please help me with one last push to try and make it work...


My system is desktop 1 below. Every so often, I'm getting system freezes of about 30 seconds duration, during which nothing works including ctrl-alt-backspace and ctrl-alt-f5. When it un-freezes, whatever I did during the freeze (eg pressed a key on the keyboard) gets done. The only way to stop this happening to is reboots (logging out and then in of KDE doesn't work, nor does re-starting X). Sometimes it can take a couple of reboots to stop the freezes. I can't see any pattern to the freezes.


I had this problem much more often when I was using the Nvidia proprietry drivers. Since switching to the plf rpm of the 9-series driver they've become less frequent, but still extremely irritating, especially when it happens in the middle of a skype call.


Another problem, which may or may not be related, is that I am getting extremely poor graphics performance: 200fps on glxgears, and a visible stuttering on screensavers. Sometimes the system seems to grind almost to a halt, with things like scrolling in firefox being very jumpy and slow. Only a restart works on this. Glxinfo says that I have directly rendering turned on.


I have turned off all the services I don't need, including clamd and freshclam. I'm running on the latest kernel. Please help!

Link to comment
Share on other sites

Check your /etc/X11/xorg.conf to make sure you don't have:


driver "nv"


and that it reads:


driver "nvidia"


this is required to ensure you use the correct nvidia driver. The nv is opensource and performance is crap with it as it's basic functionality, and never seen opengl work with it. I just wanted to make sure this was OK, as this could explain the graphics problem.


What's your system board? Does it have the nforce chipset? Or via? I'm using a via chipset board at home with an Athlon XP1800+ and Nvidia Geforce 4400 TI - 128MB card and I get about 4400fps.

Link to comment
Share on other sites

I found in my experience that similar symptoms were usually caused by memory. In the case of dual stick it was usually due to one dubious stick or was caused by one of the sticks not having a good connection in its socket. Usually switching off and pulling out the sticks and wiping the contacts with metholated spirits or alcohol and then plugging them in and out about 5 times usually did the trick.


I have 1Gb Corsair Twinex which is two matched 512Mb sticks and they worked perfectly for 9 months at the Corsair recommended settings and then I started getting similar problems to yours. After 3 weeks the machine would just not reboot. Found one of the sticks was the cause because everything ran perfectly with just the other stick. Rechecked to be certain.

Sent sticks back to retailer. They insisted both tested Ok. Received back....still same problem. Returned again...still insisting both OK.


When I put them in again, I put a hunch to the test. I set the bios for a memory speed one setting below the Corsair rating.

BINGO. Rebooted and have never had a problem since and that was 21 months ago.........Many reinstalls and hardware changes in that time. I firmly believe that the retailer did not test the sticks at their rated settings but in a system already setup for much slower memory, obviously a very slack service centre. Why haven't I persisted with the Problem???. As I said in another post, the chase for speed improvements of such a small amount is just a waste of time. If the questionable stick starts to fail then it will be replaced (It has a lifetime warranty) so until that event occurs I won't worry.


To recap. Check your memory sticks.


Cheers. John.

Link to comment
Share on other sites

Thanks for the help, people. I've swapped in some different ram, so I'm just waiting to see if I get the freezes again.


While I was in the box I checked the graphics card was in properly, and hoovered out lots of dust (there was some family evolving in there...).


I'm still getting the same low framerate, and the 'KTux' screensaver sort of stutters across the screen. xorg.conf is all it should be - any ideas?


I've just had a look in /var/log/messages. I seem to have a lot of

Dec 22 01:11:54 localhost kernel: CPU0: Running in modulated clock mode

Dec 22 01:12:00 localhost kernel: CPU0: Temperature above threshold

Could this be causing things to go wrong, and what should I do about it? NB both fans in the case are working.

Link to comment
Share on other sites

Check if suspend2 is installed on your machine. It has caused overheating CPUs on more than one occasion.


Check if the air flow is blocked by cables or other stuff. If the air-flow is blocked, the system can overheat. Once it overheats, the system will usually brake down the CPU if it cannot raise the fan-power, which is why your box could be slow and/or freezing at times. It the CPU is allowed to rn with only 50% due to overheating-risk then it will have an hicup from time to time.


In order to make sure if it is a heating problem, look in your /var/log/messages as the tempratures should have been recorded in the messages log for those times and dates.

Link to comment
Share on other sites

It's still freezing with the new ram, so it's not a memory problem.


Looking in /var/log/messages, I'm not getting the CPU messages very often, and not before each freeze. I've also checked the outlet is OK and got rid of suspend. The only thing that is consistently there before each freeze is a set of Shorewall blocking messages, and then

Dec 23 12:24:13 localhost gconfd (claresimon-5820): starting (version 2.14.0), pid 5820 user 'dustpuppy'

Dec 23 12:24:13 localhost gconfd (dustpuppy-5820): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0

Dec 23 12:24:13 localhost gconfd (dustpuppy-5820): Resolved address "xml:readonly:/etc/gconf/gconf.xml.local-mandatory" to a read-only configuration source at position 1

Dec 23 12:24:13 localhost gconfd (dustpuppy-5820): Resolved address "xml:readwrite:/home/claresimon/.gconf" to a writable configuration source at position 2

Dec 23 12:24:13 localhost gconfd (dustpuppy-5820): Resolved address "xml:readonly:/etc/gconf/gconf.xml.local-defaults" to a read-only configuration source at position 3

Dec 23 12:24:13 localhost gconfd (dustpuppy-5820): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 4


I'm running KDE. Any ideas what's going on, and could this be causing the freezes?

Edited by Dustpuppy
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...